lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.
Published 2013-01-30 12:00:09
Updated 2023-02-13 04:41:09
Source Red Hat, Inc.
View at NVD,   CVE.org
Vulnerability category: Sql InjectionExecute code

Threat overview for CVE-2013-0333

Top countries where our scanners detected CVE-2013-0333
Top open port discovered on systems with this issue 80
IPs affected by CVE-2013-0333 144
Threat actors abusing to this issue? Yes
Find out if you* are affected by CVE-2013-0333!
*Directly or indirectly through your vendors, service providers and 3rd parties. Powered by attack surface intelligence from SecurityScorecard.

Exploit prediction scoring system (EPSS) score for CVE-2013-0333

97.39%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 100 %
Percentile, the proportion of vulnerabilities that are scored at or less

Metasploit modules for CVE-2013-0333

  • Ruby on Rails JSON Processor YAML Deserialization Scanner
    First seen: 2020-04-26
    auxiliary/scanner/http/rails_json_yaml_scanner
    This module attempts to identify Ruby on Rails instances vulnerable to an arbitrary object instantiation flaw in the JSON request processor. Authors: - jjarmoc - hdm <x@hdm.io>
  • Ruby on Rails JSON Processor YAML Deserialization Code Execution
    Disclosure Date: 2013-01-28
    First seen: 2020-04-26
    exploit/multi/http/rails_json_yaml_code_exec
    This module exploits a remote code execution vulnerability in the JSON request processor of the Ruby on Rails application framework. This vulnerability allows an attacker to instantiate a remote object, which in turn can be used to execute any ruby code remotely in

CVSS scores for CVE-2013-0333

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
7.5
HIGH AV:N/AC:L/Au:N/C:P/I:P/A:P
10.0
6.4
NIST

References for CVE-2013-0333

Products affected by CVE-2013-0333

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!