CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2012-6619

The default configuration for MongoDB before 2.3.2 does not validate objects, which allows remote authenticated users to cause a denial of service (crash) or read system memory via a crafted BSON object in the column name in an insert command, which triggers a buffer over-read.
Publish Date : 2014-03-06 Last Update Date : 2014-05-06
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.4
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 20

- Products Affected By CVE-2012-6619

# Product Type Vendor Product Version Update Edition Language
1 Application Mongodb Mongodb 1.2.0 Version Details Vulnerabilities
2 Application Mongodb Mongodb 1.4.0 Version Details Vulnerabilities
3 Application Mongodb Mongodb 1.6.0 Version Details Vulnerabilities
4 Application Mongodb Mongodb 1.8.0 Version Details Vulnerabilities
5 Application Mongodb Mongodb 2.0.0 Version Details Vulnerabilities
6 Application Mongodb Mongodb 2.0.1 Version Details Vulnerabilities
7 Application Mongodb Mongodb 2.0.2 Version Details Vulnerabilities
8 Application Mongodb Mongodb 2.0.3 Version Details Vulnerabilities
9 Application Mongodb Mongodb 2.0.4 Version Details Vulnerabilities
10 Application Mongodb Mongodb 2.0.5 Version Details Vulnerabilities
11 Application Mongodb Mongodb 2.0.6 Version Details Vulnerabilities
12 Application Mongodb Mongodb 2.0.7 Version Details Vulnerabilities
13 Application Mongodb Mongodb 2.0.8 Version Details Vulnerabilities
14 Application Mongodb Mongodb 2.2.0 Version Details Vulnerabilities
15 Application Mongodb Mongodb 2.2.1 Version Details Vulnerabilities
16 Application Mongodb Mongodb 2.2.2 Version Details Vulnerabilities
17 Application Mongodb Mongodb 2.2.3 Version Details Vulnerabilities
18 Application Mongodb Mongodb 2.2.4 Version Details Vulnerabilities
19 Application Mongodb Mongodb 2.2.5 Version Details Vulnerabilities
20 Application Mongodb Mongodb 2.2.6 Version Details Vulnerabilities
21 Application Mongodb Mongodb 2.2.7 Version Details Vulnerabilities
22 Application Mongodb Mongodb 2.3.0 Version Details Vulnerabilities
23 Application Mongodb Mongodb 2.3.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mongodb Mongodb 23

- References For CVE-2012-6619

https://bugzilla.redhat.com/show_bug.cgi?id=1049748 CONFIRM
http://www.openwall.com/lists/oss-security/2014/01/08/9
MLIST [oss-security] 20140108 Re: MongoDB memory over-read via incorrect BSON object length (was: [HITB-Announce] HITB Magazine Issue 10 Out Now)
http://www.openwall.com/lists/oss-security/2014/01/07/2
MLIST [oss-security] 20140107 MongoDB memory over-read via incorrect BSON object length (was: [HITB-Announce] HITB Magazine Issue 10 Out Now)
http://www.openwall.com/lists/oss-security/2014/01/07/13
MLIST [oss-security] 20140107 Re: MongoDB memory over-read via incorrect BSON object length (was: [HITB-Announce] HITB Magazine Issue 10 Out Now)
http://rhn.redhat.com/errata/RHSA-2014-0440.html
REDHAT RHSA-2014:0440
http://rhn.redhat.com/errata/RHSA-2014-0230.html
REDHAT RHSA-2014:0230
https://jira.mongodb.org/browse/SERVER-7769 CONFIRM
http://blog.ptsecurity.com/2012/11/attacking-mongodb.html

- Metasploit Modules Related To CVE-2012-6619

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.