CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2012-3960

Use-after-free vulnerability in the mozSpellChecker::SetCurrentDictionary function in Mozilla Firefox before 15.0, Firefox ESR 10.x before 10.0.7, Thunderbird before 15.0, Thunderbird ESR 10.x before 10.0.7, and SeaMonkey before 2.12 allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption) via unspecified vectors.
Publish Date : 2012-08-29 Last Update Date : 2020-08-26
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceExecute CodeMemory corruption
CWE ID 416

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat critical
6.8
AV:N/AC:M/Au:N/C:P/I:P/A:P 2012-08-27 2012-08-28
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
DEPRECATED: ELSA-2012-1211 -- thunderbird security update (critical) oval:org.mitre.oval:def:27740 unix
DEPRECATED: ELSA-2012-1210 -- firefox security update (critical) oval:org.mitre.oval:def:26887 unix
DEPRECATED: ELSA-2012:1211: thunderbird security update (Critical) oval:org.mitre.oval:def:23230 unix
DEPRECATED: ELSA-2012:1210: firefox security update (Critical) oval:org.mitre.oval:def:23251 unix
ELSA-2012:1210: firefox security update (Critical) oval:org.mitre.oval:def:23971 unix
ELSA-2012:1211: thunderbird security update (Critical) oval:org.mitre.oval:def:23862 unix
RHSA-2012:1210: firefox security update (Critical) oval:com.redhat.rhsa:def:20121210 unix
RHSA-2012:1210: firefox security update (Critical) oval:org.mitre.oval:def:21434 unix
RHSA-2012:1211: thunderbird security update (Critical) oval:com.redhat.rhsa:def:20121211 unix
RHSA-2012:1211: thunderbird security update (Critical) oval:org.mitre.oval:def:21268 unix
Use-after-free vulnerability in the mozSpellChecker::SetCurrentDictionary function in Mozilla Firefox before 15.0, Firef... oval:org.mitre.oval:def:16853 windows
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2012-3960

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 10.04 * * * Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 11.04 * * * Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 11.10 * * * Version Details Vulnerabilities
4 OS Canonical Ubuntu Linux 12.04 * * * Version Details Vulnerabilities
5 Application Mozilla Firefox * * * * Version Details Vulnerabilities
6 Application Mozilla Firefox Esr * * * * Version Details Vulnerabilities
7 Application Mozilla Seamonkey * * * * Version Details Vulnerabilities
8 Application Mozilla Thunderbird * * * * Version Details Vulnerabilities
9 Application Mozilla Thunderbird Esr * * * * Version Details Vulnerabilities
10 OS Opensuse Opensuse 12.2 * * * Version Details Vulnerabilities
11 OS Redhat Enterprise Linux Desktop 5.0 * * * Version Details Vulnerabilities
12 OS Redhat Enterprise Linux Desktop 6.0 * * * Version Details Vulnerabilities
13 OS Redhat Enterprise Linux Eus 6.3 * * * Version Details Vulnerabilities
14 OS Redhat Enterprise Linux Server 5.0 * * * Version Details Vulnerabilities
15 OS Redhat Enterprise Linux Server 6.0 * * * Version Details Vulnerabilities
16 OS Redhat Enterprise Linux Server Eus 6.3 * * * Version Details Vulnerabilities
17 OS Redhat Enterprise Linux Workstation 5.0 * * * Version Details Vulnerabilities
18 OS Redhat Enterprise Linux Workstation 6.0 * * * Version Details Vulnerabilities
19 OS Suse Linux Enterprise Desktop 10 SP4 * * Version Details Vulnerabilities
20 OS Suse Linux Enterprise Desktop 11 SP2 * * Version Details Vulnerabilities
21 OS Suse Linux Enterprise Server 10 SP4 * * Version Details Vulnerabilities
22 OS Suse Linux Enterprise Server 11 SP2 * * Version Details Vulnerabilities
23 OS Suse Linux Enterprise Server 11 SP2 * * Version Details Vulnerabilities
24 OS Suse Linux Enterprise Software Development Kit 11 SP2 * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 4
Mozilla Firefox 1
Mozilla Firefox Esr 1
Mozilla Seamonkey 1
Mozilla Thunderbird 1
Mozilla Thunderbird Esr 1
Opensuse Opensuse 1
Redhat Enterprise Linux Desktop 2
Redhat Enterprise Linux Eus 1
Redhat Enterprise Linux Server 2
Redhat Enterprise Linux Server Eus 1
Redhat Enterprise Linux Workstation 2
Suse Linux Enterprise Desktop 2
Suse Linux Enterprise Server 3
Suse Linux Enterprise Software Development Kit 1

- References For CVE-2012-3960

http://www.mozilla.org/security/announce/2012/mfsa2012-58.html CONFIRM
http://www.securityfocus.com/bid/55325
BID 55325 Mozilla Firefox/Thunderbird/SeaMonkey CVE-2012-3960 Use-After-Free Memory Corruption Vulnerability Release Date:2014-09-16
http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00011.html
SUSE SUSE-SU-2012:1157
http://www.xerox.com/download/security/security-bulletin/16287-4d6b7b0c81f7b/cert_XRX13-003_v1.0.pdf CONFIRM
http://www.ubuntu.com/usn/USN-1548-2
UBUNTU USN-1548-2
http://rhn.redhat.com/errata/RHSA-2012-1210.html
REDHAT RHSA-2012:1210
http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00028.html
SUSE openSUSE-SU-2012:1065
http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00014.html
SUSE SUSE-SU-2012:1167
http://rhn.redhat.com/errata/RHSA-2012-1211.html
REDHAT RHSA-2012:1211
http://www.ubuntu.com/usn/USN-1548-1
UBUNTU USN-1548-1
https://bugzilla.mozilla.org/show_bug.cgi?id=771976 CONFIRM
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A16853
OVAL oval:org.mitre.oval:def:16853

- Metasploit Modules Related To CVE-2012-3960

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.