CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2012-1909

The Bitcoin protocol, as used in bitcoind before 0.4.4, wxBitcoin, Bitcoin-Qt, and other programs, does not properly handle multiple transactions with the same identifier, which allows remote attackers to cause a denial of service (unspendable transaction) by leveraging the ability to create a duplicate coinbase transaction.
Publish Date : 2012-08-06 Last Update Date : 2012-08-07
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 16

- Products Affected By CVE-2012-1909

# Product Type Vendor Product Version Update Edition Language
1 Application Bitcoin Bitcoin-qt Version Details Vulnerabilities
2 Application Bitcoin Bitcoind 0.3.4 Version Details Vulnerabilities
3 Application Bitcoin Bitcoind 0.3.5 Version Details Vulnerabilities
4 Application Bitcoin Bitcoind 0.3.8 Version Details Vulnerabilities
5 Application Bitcoin Bitcoind 0.3.10 Version Details Vulnerabilities
6 Application Bitcoin Bitcoind 0.3.11 Version Details Vulnerabilities
7 Application Bitcoin Bitcoind 0.3.12 Version Details Vulnerabilities
8 Application Bitcoin Bitcoind 0.4.0 Version Details Vulnerabilities
9 Application Bitcoin Bitcoind 0.4.1 RC6 Version Details Vulnerabilities
10 Application Bitcoin Bitcoind 0.4.1 Version Details Vulnerabilities
11 Application Bitcoin Bitcoind 0.4.4 RC2 Version Details Vulnerabilities
12 Application Bitcoin Wxbitcoin Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Bitcoin Bitcoin-qt 1
Bitcoin Bitcoind 10
Bitcoin Wxbitcoin 1

- References For CVE-2012-1909

https://github.com/sipa/bitcoin/commit/a206b0ea12eb4606b93323268fc81a4f1f952531 CONFIRM
https://bitcointalk.org/index.php?topic=67738.0 CONFIRM
http://sourceforge.net/mailarchive/forum.php?thread_name=CAPg%2BsBhmGHnMResVxPDZdfpmWTb9uqD0RrQD7oSXBQq7oHpm8g%40mail.gmail.com&forum_name=bitcoin-development
MLIST [bitcoin-development] 20120228 Duplicate transactions vulnerability
http://r6.ca/blog/20120206T005236Z.html
https://bugs.gentoo.org/show_bug.cgi?id=407793 CONFIRM
https://en.bitcoin.it/wiki/CVEs CONFIRM
https://en.bitcoin.it/wiki/BIP_0030 CONFIRM

- Metasploit Modules Related To CVE-2012-1909

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.