CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2012-1118

The access_has_bug_level function in core/access_api.php in MantisBT before 1.2.9 does not properly restrict access when the private_bug_view_threshold is set to an array, which allows remote attackers to bypass intended restrictions and perform certain operations on private bug reports.
Publish Date : 2012-06-29 Last Update Date : 2013-08-26
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Bypass a restriction or similar
CWE ID 264

- Related OVAL Definitions

Title Definition Id Class Family
DSA-2500-1 mantis - several oval:org.mitre.oval:def:19825 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2012-1118

# Product Type Vendor Product Version Update Edition Language
1 Application Mantisbt Mantisbt 0.18.0 Version Details Vulnerabilities
2 Application Mantisbt Mantisbt 0.19.0 Version Details Vulnerabilities
3 Application Mantisbt Mantisbt 0.19.0 RC1 Version Details Vulnerabilities
4 Application Mantisbt Mantisbt 0.19.0a2 Version Details Vulnerabilities
5 Application Mantisbt Mantisbt 0.19.0a1 Version Details Vulnerabilities
6 Application Mantisbt Mantisbt 0.19.1 Version Details Vulnerabilities
7 Application Mantisbt Mantisbt 0.19.2 Version Details Vulnerabilities
8 Application Mantisbt Mantisbt 0.19.3 Version Details Vulnerabilities
9 Application Mantisbt Mantisbt 0.19.4 Version Details Vulnerabilities
10 Application Mantisbt Mantisbt 0.19.5 Version Details Vulnerabilities
11 Application Mantisbt Mantisbt 1.0.0 Version Details Vulnerabilities
12 Application Mantisbt Mantisbt 1.0.0 RC1 Version Details Vulnerabilities
13 Application Mantisbt Mantisbt 1.0.0a3 Version Details Vulnerabilities
14 Application Mantisbt Mantisbt 1.0.0 RC5 Version Details Vulnerabilities
15 Application Mantisbt Mantisbt 1.0.0a2 Version Details Vulnerabilities
16 Application Mantisbt Mantisbt 1.0.0 RC4 Version Details Vulnerabilities
17 Application Mantisbt Mantisbt 1.0.0a1 Version Details Vulnerabilities
18 Application Mantisbt Mantisbt 1.0.0 RC3 Version Details Vulnerabilities
19 Application Mantisbt Mantisbt 1.0.0 RC2 Version Details Vulnerabilities
20 Application Mantisbt Mantisbt 1.0.1 Version Details Vulnerabilities
21 Application Mantisbt Mantisbt 1.0.2 Version Details Vulnerabilities
22 Application Mantisbt Mantisbt 1.0.3 Version Details Vulnerabilities
23 Application Mantisbt Mantisbt 1.0.4 Version Details Vulnerabilities
24 Application Mantisbt Mantisbt 1.0.5 Version Details Vulnerabilities
25 Application Mantisbt Mantisbt 1.0.6 Version Details Vulnerabilities
26 Application Mantisbt Mantisbt 1.0.7 Version Details Vulnerabilities
27 Application Mantisbt Mantisbt 1.0.8 Version Details Vulnerabilities
28 Application Mantisbt Mantisbt 1.1.0 Version Details Vulnerabilities
29 Application Mantisbt Mantisbt 1.1.1 Version Details Vulnerabilities
30 Application Mantisbt Mantisbt 1.1.2 Version Details Vulnerabilities
31 Application Mantisbt Mantisbt 1.1.4 Version Details Vulnerabilities
32 Application Mantisbt Mantisbt 1.1.5 Version Details Vulnerabilities
33 Application Mantisbt Mantisbt 1.1.6 Version Details Vulnerabilities
34 Application Mantisbt Mantisbt 1.1.7 Version Details Vulnerabilities
35 Application Mantisbt Mantisbt 1.1.8 Version Details Vulnerabilities
36 Application Mantisbt Mantisbt 1.2.0 Version Details Vulnerabilities
37 Application Mantisbt Mantisbt 1.2.0a2 Version Details Vulnerabilities
38 Application Mantisbt Mantisbt 1.2.0a1 Version Details Vulnerabilities
39 Application Mantisbt Mantisbt 1.2.1 Version Details Vulnerabilities
40 Application Mantisbt Mantisbt 1.2.2 Version Details Vulnerabilities
41 Application Mantisbt Mantisbt 1.2.3 Version Details Vulnerabilities
42 Application Mantisbt Mantisbt 1.2.4 Version Details Vulnerabilities
43 Application Mantisbt Mantisbt 1.2.5 Version Details Vulnerabilities
44 Application Mantisbt Mantisbt 1.2.6 Version Details Vulnerabilities
45 Application Mantisbt Mantisbt 1.2.7 Version Details Vulnerabilities
46 Application Mantisbt Mantisbt 1.2.8 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mantisbt Mantisbt 46

- References For CVE-2012-1118

http://lists.fedoraproject.org/pipermail/package-announce/2012-November/092926.html
FEDORA FEDORA-2012-18273
http://secunia.com/advisories/48258
SECUNIA 48258
http://lists.fedoraproject.org/pipermail/package-announce/2012-November/093064.html
FEDORA FEDORA-2012-18294
http://lists.fedoraproject.org/pipermail/package-announce/2012-November/093063.html
FEDORA FEDORA-2012-18299
http://www.debian.org/security/2012/dsa-2500
DEBIAN DSA-2500
http://security.gentoo.org/glsa/glsa-201211-01.xml
GENTOO GLSA-201211-01
http://www.mantisbt.org/bugs/changelog_page.php?version_id=140 CONFIRM
http://secunia.com/advisories/49572
SECUNIA 49572
http://secunia.com/advisories/51199
SECUNIA 51199
http://www.openwall.com/lists/oss-security/2012/03/06/9
MLIST [oss-security] 20120306 Re: CVE request: mantisbt before 1.2.9
http://www.mantisbt.org/bugs/view.php?id=10124 CONFIRM
https://github.com/mantisbt/mantisbt/commit/eb803ed02105fc919cf5f789e939f2b824162927 CONFIRM
http://www.securityfocus.com/bid/52313
BID 52313 MantisBT Multiple Security Bypass Vulnerabilities Release Date:2012-11-27

- Metasploit Modules Related To CVE-2012-1118

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.