CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2011-3481

The index_get_ids function in index.c in imapd in Cyrus IMAP Server before 2.4.11, when server-side threading is enabled, allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted References header in an e-mail message.
Publish Date : 2011-09-14 Last Update Date : 2018-10-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate
4.3
AV:N/AC:M/Au:N/C:N/I:N/A:P 2011-09-14 2005-12-17
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2011-3481 oval:org.opensuse.security:def:20113481 unix
DEPRECATED: ELSA-2011:1508: cyrus-imapd security update (Moderate) oval:org.mitre.oval:def:22757 unix
DSA-2377-1 cyrus-imapd-2.2 -- NULL pointer dereference oval:org.mitre.oval:def:14883 unix
ELSA-2011:1508: cyrus-imapd security update (Moderate) oval:org.mitre.oval:def:23438 unix
RHSA-2011:1508: cyrus-imapd security update (Moderate) oval:org.mitre.oval:def:22075 unix
RHSA-2011:1508: cyrus-imapd security update (Moderate) oval:com.redhat.rhsa:def:20111508 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2011-3481

# Product Type Vendor Product Version Update Edition Language
1 Application CMU Cyrus Imap Server 2.0.17 Version Details Vulnerabilities
2 Application CMU Cyrus Imap Server 2.1.16 Version Details Vulnerabilities
3 Application CMU Cyrus Imap Server 2.1.17 Version Details Vulnerabilities
4 Application CMU Cyrus Imap Server 2.1.18 Version Details Vulnerabilities
5 Application CMU Cyrus Imap Server 2.2.8 Version Details Vulnerabilities
6 Application CMU Cyrus Imap Server 2.2.9 Version Details Vulnerabilities
7 Application CMU Cyrus Imap Server 2.2.10 Version Details Vulnerabilities
8 Application CMU Cyrus Imap Server 2.2.11 Version Details Vulnerabilities
9 Application CMU Cyrus Imap Server 2.2.12 Version Details Vulnerabilities
10 Application CMU Cyrus Imap Server 2.2.13 Version Details Vulnerabilities
11 Application CMU Cyrus Imap Server 2.2.13p1 Version Details Vulnerabilities
12 Application CMU Cyrus Imap Server 2.3.0 Version Details Vulnerabilities
13 Application CMU Cyrus Imap Server 2.3.1 Version Details Vulnerabilities
14 Application CMU Cyrus Imap Server 2.3.2 Version Details Vulnerabilities
15 Application CMU Cyrus Imap Server 2.3.3 Version Details Vulnerabilities
16 Application CMU Cyrus Imap Server 2.3.4 Version Details Vulnerabilities
17 Application CMU Cyrus Imap Server 2.3.5 Version Details Vulnerabilities
18 Application CMU Cyrus Imap Server 2.3.6 Version Details Vulnerabilities
19 Application CMU Cyrus Imap Server 2.3.7 Version Details Vulnerabilities
20 Application CMU Cyrus Imap Server 2.3.8 Version Details Vulnerabilities
21 Application CMU Cyrus Imap Server 2.3.9 Version Details Vulnerabilities
22 Application CMU Cyrus Imap Server 2.3.10 Version Details Vulnerabilities
23 Application CMU Cyrus Imap Server 2.3.11 Version Details Vulnerabilities
24 Application CMU Cyrus Imap Server 2.3.12 Version Details Vulnerabilities
25 Application CMU Cyrus Imap Server 2.3.13 Version Details Vulnerabilities
26 Application CMU Cyrus Imap Server 2.3.14 Version Details Vulnerabilities
27 Application CMU Cyrus Imap Server 2.3.15 Version Details Vulnerabilities
28 Application CMU Cyrus Imap Server 2.3.16 Version Details Vulnerabilities
29 Application CMU Cyrus Imap Server 2.3.17 Version Details Vulnerabilities
30 Application CMU Cyrus Imap Server 2.4.0 Version Details Vulnerabilities
31 Application CMU Cyrus Imap Server 2.4.1 Version Details Vulnerabilities
32 Application CMU Cyrus Imap Server 2.4.2 Version Details Vulnerabilities
33 Application CMU Cyrus Imap Server 2.4.3 Version Details Vulnerabilities
34 Application CMU Cyrus Imap Server 2.4.4 Version Details Vulnerabilities
35 Application CMU Cyrus Imap Server 2.4.5 Version Details Vulnerabilities
36 Application CMU Cyrus Imap Server 2.4.6 Version Details Vulnerabilities
37 Application CMU Cyrus Imap Server 2.4.7 Version Details Vulnerabilities
38 Application CMU Cyrus Imap Server 2.4.8 Version Details Vulnerabilities
39 Application CMU Cyrus Imap Server 2.4.9 Version Details Vulnerabilities
40 Application CMU Cyrus Imap Server 2.4.10 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
CMU Cyrus Imap Server 40

- References For CVE-2011-3481

http://www.redhat.com/support/errata/RHSA-2011-1508.html
REDHAT RHSA-2011:1508
http://git.cyrusimap.org/cyrus-imapd/commit/?id=6e776956a1a9dfa58eacdd0ddd52644009eac9e5 CONFIRM
http://bugzilla.cyrusimap.org/show_bug.cgi?id=2772 CONFIRM
https://exchange.xforce.ibmcloud.com/vulnerabilities/69842
XF cyrus-imap-indexgetids-dos(69842)
http://bugzilla.cyrusimap.org/show_bug.cgi?id=3463 CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2012:037
MANDRIVA MDVSA-2012:037

- Metasploit Modules Related To CVE-2011-3481

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.