CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2011-3371

Multiple cross-site scripting (XSS) vulnerabilities in include/functions.php in PunBB before 1.3.6 allow remote attackers to inject arbitrary web script or HTML via the (1) id, (2) form_sent, (3) csrf_token, (4) req_confirm, or (5) delete parameter to delete.php, the (6) id, (7) form_sent, (8) csrf_token, (9) req_message, or (10) submit parameter to edit.php, the (11) action, (12) form_sent, (13) csrf_token, (14) req_email, or (15) request_pass parameter to login.php, the (16) email, (17) form_sent, (18) redirect_url, (19) csrf_token, (20) req_subject, (21) req_message, or (22) submit parameter to misc.php, the (23) action, (24) id, (25) form_sent, (26) csrf_token, (27) req_old_password, (28) req_new_password1, (29) req_new_password2, or (30) update parameter to profile.php, or the (31) action, (32) form_sent, (33) csrf_token, (34) req_username, (35) req_password1, (36) req_password2, (37) req_email1, (38) timezone, or (39) register parameter to register.php.
Publish Date : 2011-10-02 Last Update Date : 2012-05-18
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Cross Site ScriptingCSRF
CWE ID 79

- Products Affected By CVE-2011-3371

# Product Type Vendor Product Version Update Edition Language
1 Application Punbb Punbb 1.0 RC2 Version Details Vulnerabilities
2 Application Punbb Punbb 1.0 Beta1a Version Details Vulnerabilities
3 Application Punbb Punbb 1.0 RC1 Version Details Vulnerabilities
4 Application Punbb Punbb 1.0 Version Details Vulnerabilities
5 Application Punbb Punbb 1.0 Beta1 Version Details Vulnerabilities
6 Application Punbb Punbb 1.0 Beta3 Version Details Vulnerabilities
7 Application Punbb Punbb 1.0 Alpha Version Details Vulnerabilities
8 Application Punbb Punbb 1.0 Beta2 Version Details Vulnerabilities
9 Application Punbb Punbb 1.0.1 Version Details Vulnerabilities
10 Application Punbb Punbb 1.1 Version Details Vulnerabilities
11 Application Punbb Punbb 1.1.1 Version Details Vulnerabilities
12 Application Punbb Punbb 1.1.2 Version Details Vulnerabilities
13 Application Punbb Punbb 1.1.3 Version Details Vulnerabilities
14 Application Punbb Punbb 1.1.4 Version Details Vulnerabilities
15 Application Punbb Punbb 1.1.5 Version Details Vulnerabilities
16 Application Punbb Punbb 1.2 Version Details Vulnerabilities
17 Application Punbb Punbb 1.2.1 Version Details Vulnerabilities
18 Application Punbb Punbb 1.2.2 Version Details Vulnerabilities
19 Application Punbb Punbb 1.2.3 Version Details Vulnerabilities
20 Application Punbb Punbb 1.2.4 Version Details Vulnerabilities
21 Application Punbb Punbb 1.2.5 Version Details Vulnerabilities
22 Application Punbb Punbb 1.2.6 Version Details Vulnerabilities
23 Application Punbb Punbb 1.2.7 Version Details Vulnerabilities
24 Application Punbb Punbb 1.2.8 Version Details Vulnerabilities
25 Application Punbb Punbb 1.2.9 Version Details Vulnerabilities
26 Application Punbb Punbb 1.2.10 Version Details Vulnerabilities
27 Application Punbb Punbb 1.2.11 Version Details Vulnerabilities
28 Application Punbb Punbb 1.2.12 Version Details Vulnerabilities
29 Application Punbb Punbb 1.2.13 Version Details Vulnerabilities
30 Application Punbb Punbb 1.2.14 Version Details Vulnerabilities
31 Application Punbb Punbb 1.2.15 Version Details Vulnerabilities
32 Application Punbb Punbb 1.2.16 Version Details Vulnerabilities
33 Application Punbb Punbb 1.2.17 Version Details Vulnerabilities
34 Application Punbb Punbb 1.2.18 Version Details Vulnerabilities
35 Application Punbb Punbb 1.2.19 Version Details Vulnerabilities
36 Application Punbb Punbb 1.2.20 Version Details Vulnerabilities
37 Application Punbb Punbb 1.2.21 Version Details Vulnerabilities
38 Application Punbb Punbb 1.2.22 Version Details Vulnerabilities
39 Application Punbb Punbb 1.2.23 Version Details Vulnerabilities
40 Application Punbb Punbb 1.3 RC7 Version Details Vulnerabilities
41 Application Punbb Punbb 1.3 RC2 Version Details Vulnerabilities
42 Application Punbb Punbb 1.3 Version Details Vulnerabilities
43 Application Punbb Punbb 1.3 Beta Version Details Vulnerabilities
44 Application Punbb Punbb 1.3 RC1 Version Details Vulnerabilities
45 Application Punbb Punbb 1.3.1 Version Details Vulnerabilities
46 Application Punbb Punbb 1.3.2 Version Details Vulnerabilities
47 Application Punbb Punbb 1.3.3 Version Details Vulnerabilities
48 Application Punbb Punbb 1.3.4 Version Details Vulnerabilities
49 Application Punbb Punbb 1.3.5 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Punbb Punbb 49

- References For CVE-2011-3371

https://github.com/punbb/punbb/commit/dd50a50a2760f10bd2d09814e30af4b36052ca6d CONFIRM
http://archives.neohapsis.com/archives/fulldisclosure/2011-09/0193.html
FULLDISC 20110916 PunBB PHP Forum - Multiple XSS
http://archives.neohapsis.com/archives/fulldisclosure/2011-09/0210.html
FULLDISC 20110918 Re: PunBB PHP Forum - Multiple XSS
http://securitytracker.com/id?1026073
SECTRACK 1026073
http://archives.neohapsis.com/archives/fulldisclosure/2011-09/0272.html
FULLDISC 20110922 Re: PunBB PHP Forum - Multiple XSS
http://punbb.informer.com/forums/topic/24427/multiple-xss-vulnerabilities/ CONFIRM
http://www.openwall.com/lists/oss-security/2011/09/18/1
MLIST [oss-security] 20110918 CVE request: PunBB multiple XSS issues
http://punbb.informer.com/forums/topic/24430/punbb-136/ CONFIRM
http://www.openwall.com/lists/oss-security/2011/09/22/3
MLIST [oss-security] 20110922 Re: CVE request: PunBB multiple XSS issues
https://github.com/downloads/punbb/punbb/punbb-1.3.6.zip CONFIRM

- Metasploit Modules Related To CVE-2011-3371

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.