CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2011-2998

Integer underflow in Mozilla Firefox 3.6.x before 3.6.23 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via JavaScript code containing a large RegExp expression.
Publish Date : 2011-09-30 Last Update Date : 2017-09-19
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceExecute Code
CWE ID 189

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat critical
6.8
AV:N/AC:M/Au:N/C:P/I:P/A:P 2011-09-28 2011-09-28
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2011-2998 oval:org.opensuse.security:def:20112998 unix
DEPRECATED: ELSA-2011-1342 -- thunderbird security update (critical) oval:org.mitre.oval:def:27971 unix
DEPRECATED: ELSA-2011:1341: firefox security update (Critical) oval:org.mitre.oval:def:22973 unix
DSA-2312-1 iceape -- several oval:org.mitre.oval:def:14709 unix
DSA-2313-1 iceweasel -- several oval:org.mitre.oval:def:15132 unix
DSA-2317-1 icedove -- several oval:org.mitre.oval:def:14910 unix
ELSA-2011:1341: firefox security update (Critical) oval:org.mitre.oval:def:23500 unix
ELSA-2011:1342: thunderbird security update (Critical) oval:org.mitre.oval:def:22791 unix
ELSA-2011:1343: thunderbird security update (Critical) oval:org.mitre.oval:def:22887 unix
Integer underflow in Mozilla Firefox 3.6.x before 3.6.23 allows remote attackers to cause a denial of service (applicati... oval:org.mitre.oval:def:14012 windows
RHSA-2011:1341: firefox security update (Critical) oval:org.mitre.oval:def:22193 unix
RHSA-2011:1341: firefox security update (Critical) oval:com.redhat.rhsa:def:20111341 unix
RHSA-2011:1342: thunderbird security update (Critical) oval:org.mitre.oval:def:22072 unix
RHSA-2011:1342: thunderbird security update (Critical) oval:com.redhat.rhsa:def:20111342 unix
RHSA-2011:1343: thunderbird security update (Critical) oval:org.mitre.oval:def:22014 unix
RHSA-2011:1343: thunderbird security update (Critical) oval:com.redhat.rhsa:def:20111343 unix
RHSA-2011:1344: seamonkey security update (Critical) oval:com.redhat.rhsa:def:20111344 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2011-2998

# Product Type Vendor Product Version Update Edition Language
1 Application Mozilla Firefox 3.6 * * * Version Details Vulnerabilities
2 Application Mozilla Firefox 3.6.2 * * * Version Details Vulnerabilities
3 Application Mozilla Firefox 3.6.3 * * * Version Details Vulnerabilities
4 Application Mozilla Firefox 3.6.4 * * * Version Details Vulnerabilities
5 Application Mozilla Firefox 3.6.6 * * * Version Details Vulnerabilities
6 Application Mozilla Firefox 3.6.7 * * * Version Details Vulnerabilities
7 Application Mozilla Firefox 3.6.8 * * * Version Details Vulnerabilities
8 Application Mozilla Firefox 3.6.9 * * * Version Details Vulnerabilities
9 Application Mozilla Firefox 3.6.10 * * * Version Details Vulnerabilities
10 Application Mozilla Firefox 3.6.11 * * * Version Details Vulnerabilities
11 Application Mozilla Firefox 3.6.12 * * * Version Details Vulnerabilities
12 Application Mozilla Firefox 3.6.13 * * * Version Details Vulnerabilities
13 Application Mozilla Firefox 3.6.14 * * * Version Details Vulnerabilities
14 Application Mozilla Firefox 3.6.15 * * * Version Details Vulnerabilities
15 Application Mozilla Firefox 3.6.16 * * * Version Details Vulnerabilities
16 Application Mozilla Firefox 3.6.17 * * * Version Details Vulnerabilities
17 Application Mozilla Firefox 3.6.18 * * * Version Details Vulnerabilities
18 Application Mozilla Firefox 3.6.19 * * * Version Details Vulnerabilities
19 Application Mozilla Firefox 3.6.20 * * * Version Details Vulnerabilities
20 Application Mozilla Firefox 3.6.21 * * * Version Details Vulnerabilities
21 Application Mozilla Firefox 3.6.22 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mozilla Firefox 21

- References For CVE-2011-2998

http://lists.opensuse.org/opensuse-security-announce/2011-11/msg00020.html
SUSE SUSE-SU-2011:1256
http://www.mandriva.com/security/advisories?name=MDVSA-2011:141
MANDRIVA MDVSA-2011:141
http://www.mandriva.com/security/advisories?name=MDVSA-2011:140
MANDRIVA MDVSA-2011:140
http://www.debian.org/security/2011/dsa-2313
DEBIAN DSA-2313
http://www.debian.org/security/2011/dsa-2317
DEBIAN DSA-2317
http://www.mandriva.com/security/advisories?name=MDVSA-2011:139
MANDRIVA MDVSA-2011:139
http://www.redhat.com/support/errata/RHSA-2011-1341.html
REDHAT RHSA-2011:1341
http://www.debian.org/security/2011/dsa-2312
DEBIAN DSA-2312
https://bugzilla.mozilla.org/show_bug.cgi?id=684815 CONFIRM
http://www.mozilla.org/security/announce/2011/mfsa2011-37.html CONFIRM
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A14012
OVAL oval:org.mitre.oval:def:14012

- Metasploit Modules Related To CVE-2011-2998

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.