CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2011-2705

The SecureRandom.random_bytes function in lib/securerandom.rb in Ruby before 1.8.7-p352 and 1.9.x before 1.9.2-p290 relies on PID values for initialization, which makes it easier for context-dependent attackers to predict the result string by leveraging knowledge of random strings obtained in an earlier process with the same PID.
Publish Date : 2011-08-05 Last Update Date : 2012-01-18
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 20

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low
2.1
AV:L/AC:L/Au:N/C:P/I:N/A:N 2011-07-07 2011-07-02
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2011-2705 oval:org.opensuse.security:def:20112705 unix
ELSA-2011-1581 -- ruby security, bug fix, and enhancement update (low) oval:org.mitre.oval:def:27928 unix
RHSA-2011:1581 -- ruby security, bug fix, and enhancement update (Low) oval:org.mitre.oval:def:26914 unix
RHSA-2011:1581: ruby security, bug fix, and enhancement update (Low) oval:com.redhat.rhsa:def:20111581 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2011-2705

# Product Type Vendor Product Version Update Edition Language
1 Application Ruby-lang Ruby 1.8.7 P71 Version Details Vulnerabilities
2 Application Ruby-lang Ruby 1.8.7-173 Version Details Vulnerabilities
3 Application Ruby-lang Ruby 1.8.7-330 Version Details Vulnerabilities
4 Application Ruby-lang Ruby 1.8.7-248 Version Details Vulnerabilities
5 Application Ruby-lang Ruby 1.8.7 P22 Version Details Vulnerabilities
6 Application Ruby-lang Ruby 1.8.7-249 Version Details Vulnerabilities
7 Application Ruby-lang Ruby 1.8.7-299 Version Details Vulnerabilities
8 Application Ruby-lang Ruby 1.8.7-p21 Version Details Vulnerabilities
9 Application Ruby-lang Ruby 1.8.7 P72 Version Details Vulnerabilities
10 Application Ruby-lang Ruby 1.8.7-334 Version Details Vulnerabilities
11 Application Ruby-lang Ruby 1.8.7-302 Version Details Vulnerabilities
12 Application Ruby-lang Ruby 1.8.7-160 Version Details Vulnerabilities
13 Application Ruby-lang Ruby 1.9 R18423 Version Details Vulnerabilities
14 Application Ruby-lang Ruby 1.9 Version Details Vulnerabilities
15 Application Ruby-lang Ruby 1.9.0-20060415 Version Details Vulnerabilities
16 Application Ruby-lang Ruby 1.9.0-2 Version Details Vulnerabilities
17 Application Ruby-lang Ruby 1.9.0-1 Version Details Vulnerabilities
18 Application Ruby-lang Ruby 1.9.0-0 Version Details Vulnerabilities
19 Application Ruby-lang Ruby 1.9.0 Version Details Vulnerabilities
20 Application Ruby-lang Ruby 1.9.0 R18423 Version Details Vulnerabilities
21 Application Ruby-lang Ruby 1.9.0-20070709 Version Details Vulnerabilities
22 Application Ruby-lang Ruby 1.9.1 -p243 Version Details Vulnerabilities
23 Application Ruby-lang Ruby 1.9.1 -rc2 Version Details Vulnerabilities
24 Application Ruby-lang Ruby 1.9.1 -preview 2 Version Details Vulnerabilities
25 Application Ruby-lang Ruby 1.9.1 -p429 Version Details Vulnerabilities
26 Application Ruby-lang Ruby 1.9.1 -preview 1 Version Details Vulnerabilities
27 Application Ruby-lang Ruby 1.9.1 Version Details Vulnerabilities
28 Application Ruby-lang Ruby 1.9.1 -p376 Version Details Vulnerabilities
29 Application Ruby-lang Ruby 1.9.1 -p129 Version Details Vulnerabilities
30 Application Ruby-lang Ruby 1.9.1 -P0 Version Details Vulnerabilities
31 Application Ruby-lang Ruby 1.9.1 -rc1 Version Details Vulnerabilities
32 Application Ruby-lang Ruby 1.9.2 Version Details Vulnerabilities
33 Application Ruby-lang Ruby 1.9.2-p180 Version Details Vulnerabilities
34 Application Ruby-lang Ruby 1.9.2 DEV Version Details Vulnerabilities
35 Application Ruby-lang Ruby 1.9.2-p136 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Ruby-lang Ruby 35

- References For CVE-2011-2705

http://lists.fedoraproject.org/pipermail/package-announce/2011-July/063071.html
FEDORA FEDORA-2011-9359
https://bugzilla.redhat.com/show_bug.cgi?id=722415 CONFIRM
http://www.ruby-lang.org/en/news/2011/07/15/ruby-1-9-2-p290-is-released/ CONFIRM
http://www.ruby-lang.org/en/news/2011/07/02/ruby-1-8-7-p352-released/ CONFIRM
http://www.openwall.com/lists/oss-security/2011/07/20/16
MLIST [oss-security] 20110720 Re: CVE Request: ruby PRNG fixes
http://www.openwall.com/lists/oss-security/2011/07/20/1
MLIST [oss-security] 20110720 Re: CVE Request: ruby PRNG fixes
http://www.openwall.com/lists/oss-security/2011/07/12/14
MLIST [oss-security] 20110712 Re: CVE Request: ruby PRNG fixes
http://www.openwall.com/lists/oss-security/2011/07/11/1
MLIST [oss-security] 20110711 CVE Request: ruby PRNG fixes
http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=32050 CONFIRM
http://lists.fedoraproject.org/pipermail/package-announce/2011-July/063062.html
FEDORA FEDORA-2011-9374
http://www.securityfocus.com/bid/49015
BID 49015 Ruby Random Number Generation Local Denial Of Service Vulnerability Release Date:2014-02-13
http://www.redhat.com/support/errata/RHSA-2011-1581.html
REDHAT RHSA-2011:1581
http://svn.ruby-lang.org/repos/ruby/tags/v1_9_2_290/ChangeLog CONFIRM
http://redmine.ruby-lang.org/issues/4579 CONFIRM
http://svn.ruby-lang.org/repos/ruby/tags/v1_8_7_352/ChangeLog CONFIRM

- Metasploit Modules Related To CVE-2011-2705

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.