CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2011-1005

The safe-level feature in Ruby 1.8.6 through 1.8.6-420, 1.8.7 through 1.8.7-330, and 1.8.8dev allows context-dependent attackers to modify strings via the Exception#to_s method, as demonstrated by changing an intended pathname.
Publish Date : 2011-03-02 Last Update Date : 2013-08-13
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 264

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low
4.3
AV:N/AC:M/Au:N/C:N/I:P/A:N 2011-02-18 2011-02-18
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2011-1005 oval:org.opensuse.security:def:20111005 unix
DEPRECATED: ELSA-2011-0909 -- ruby security update (moderate) oval:org.mitre.oval:def:28124 unix
DEPRECATED: ELSA-2011-0910 -- ruby security update (moderate) oval:org.mitre.oval:def:27961 unix
ELSA-2011:0909: ruby security update (Moderate) oval:org.mitre.oval:def:23159 unix
ELSA-2011:0910: ruby security update (Moderate) oval:org.mitre.oval:def:23508 unix
RHSA-2011:0908: ruby security update (Moderate) oval:com.redhat.rhsa:def:20110908 unix
RHSA-2011:0909: ruby security update (Moderate) oval:com.redhat.rhsa:def:20110909 unix
RHSA-2011:0909: ruby security update (Moderate) oval:org.mitre.oval:def:21638 unix
RHSA-2011:0910: ruby security update (Moderate) oval:com.redhat.rhsa:def:20110910 unix
RHSA-2011:0910: ruby security update (Moderate) oval:org.mitre.oval:def:21881 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2011-1005

# Product Type Vendor Product Version Update Edition Language
1 Application Ruby-lang Ruby 1.8.6 Version Details Vulnerabilities
2 Application Ruby-lang Ruby 1.8.6-420 Version Details Vulnerabilities
3 Application Ruby-lang Ruby 1.8.7 Version Details Vulnerabilities
4 Application Ruby-lang Ruby 1.8.7-330 Version Details Vulnerabilities
5 Application Ruby-lang Ruby 1.8.8 DEV Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Ruby-lang Ruby 5

- References For CVE-2011-1005

http://www.redhat.com/support/errata/RHSA-2011-0909.html
REDHAT RHSA-2011:0909
http://www.redhat.com/support/errata/RHSA-2011-0908.html
REDHAT RHSA-2011:0908
http://lists.fedoraproject.org/pipermail/package-announce/2011-March/054422.html
FEDORA FEDORA-2011-1876
http://secunia.com/advisories/43420
SECUNIA 43420
http://osvdb.org/70957
OSVDB 70957
http://lists.fedoraproject.org/pipermail/package-announce/2011-March/054436.html
FEDORA FEDORA-2011-1913
http://secunia.com/advisories/43573
SECUNIA 43573
http://lists.apple.com/archives/security-announce/2012/May/msg00001.html
APPLE APPLE-SA-2012-05-09-1
http://support.apple.com/kb/HT5281 CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2011:098
MANDRIVA MDVSA-2011:098
http://www.openwall.com/lists/oss-security/2011/02/21/2
MLIST [oss-security] 20110221 CVE request: ruby: FileUtils is vulnerable to symlink race attacks + Exception methods can bypass $SAFE
http://www.mandriva.com/security/advisories?name=MDVSA-2011:097
MANDRIVA MDVSA-2011:097
https://bugzilla.redhat.com/show_bug.cgi?id=678920 CONFIRM
http://www.ruby-lang.org/en/news/2011/02/18/exception-methods-can-bypass-safe/ CONFIRM
http://www.openwall.com/lists/oss-security/2011/02/21/5
MLIST [oss-security] 20110221 Re: CVE request: ruby: FileUtils is vulnerable to symlink race attacks + Exception methods can bypass $SAFE
http://www.securityfocus.com/bid/46458
BID 46458 Ruby "#to_s" Security Bypass Vulnerability Release Date:2014-12-15
http://www.redhat.com/support/errata/RHSA-2011-0910.html
REDHAT RHSA-2011:0910
http://www.vupen.com/english/advisories/2011/0539
VUPEN ADV-2011-0539

- Metasploit Modules Related To CVE-2011-1005

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.