The Janrain Engage (formerly RPX) module 6.x-1.3 for Drupal does not validate the file for a profile image, which allows remote authenticated users to conduct cross-site scripting (XSS) attacks and possibly execute arbitrary PHP code by causing a crafted avatar to be downloaded from an external login provider site.
Published 2011-02-04 01:00:09
Updated 2017-08-17 01:33:44
Source MITRE
View at NVD,   CVE.org
Vulnerability category: Cross site scripting (XSS)Input validation

Exploit prediction scoring system (EPSS) score for CVE-2011-0771

0.80%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 81 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2011-0771

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
6.8
MEDIUM AV:N/AC:M/Au:N/C:P/I:P/A:P
8.6
6.4
NIST

CWE ids for CVE-2011-0771

  • The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
    Assigned by: nvd@nist.gov (Primary)

References for CVE-2011-0771

Products affected by CVE-2011-0771

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!