CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-4494

Double free vulnerability in libxml2 2.7.8 and other versions, as used in Google Chrome before 8.0.552.215 and other products, allows remote attackers to cause a denial of service or possibly have unspecified other impact via vectors related to XPath handling.
Publish Date : 2010-12-07 Last Update Date : 2020-07-31
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 415

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low
4.3
AV:N/AC:M/Au:N/C:N/I:N/A:P 2010-12-07 2010-11-17
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2010-4494 oval:org.opensuse.security:def:20104494 unix
DEPRECATED: ELSA-2013-0217 -- mingw32-libxml2 security update (important) oval:org.mitre.oval:def:27385 unix
Double free vulnerability in Google Chrome before 8.0.552.215 via vectors related to XPath handling oval:org.mitre.oval:def:11916 windows
ELSA-2011-1749 -- libxml2 security and bug fix update (low) oval:org.mitre.oval:def:27942 unix
ELSA-2013:0217: mingw32-libxml2 security update (Important) oval:org.mitre.oval:def:23888 unix
RHSA-2011:1749 -- libxml2 security and bug fix update (Low) oval:org.mitre.oval:def:27147 unix
RHSA-2011:1749: libxml2 security and bug fix update (Low) oval:com.redhat.rhsa:def:20111749 unix
RHSA-2013:0217: mingw32-libxml2 security update (Important) oval:org.mitre.oval:def:20771 unix
RHSA-2013:0217: mingw32-libxml2 security update (Important) oval:com.redhat.rhsa:def:20130217 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2010-4494

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Openoffice * * * * Version Details Vulnerabilities
2 OS Apple Iphone Os * * * * Version Details Vulnerabilities
3 Application Apple Itunes * * * * Version Details Vulnerabilities
4 OS Apple Mac Os X * * * * Version Details Vulnerabilities
5 Application Apple Safari * * * * Version Details Vulnerabilities
6 OS Debian Debian Linux 5.0 * * * Version Details Vulnerabilities
7 OS Debian Debian Linux 6.0 * * * Version Details Vulnerabilities
8 OS Fedoraproject Fedora 14 * * * Version Details Vulnerabilities
9 Application Google Chrome * * * * Version Details Vulnerabilities
10 Application HP Insight Control Server Deployment * * * * Version Details Vulnerabilities
11 Application HP Rapid Deployment Pack * * * * Version Details Vulnerabilities
12 OS Opensuse Opensuse 11.2 * * * Version Details Vulnerabilities
13 OS Opensuse Opensuse 11.3 * * * Version Details Vulnerabilities
14 OS Redhat Enterprise Linux Desktop 6.0 * * * Version Details Vulnerabilities
15 OS Redhat Enterprise Linux Eus 6.3 * * * Version Details Vulnerabilities
16 OS Redhat Enterprise Linux Server 6.0 * * * Version Details Vulnerabilities
17 OS Redhat Enterprise Linux Workstation 6.0 * * * Version Details Vulnerabilities
18 OS Suse Suse Linux Enterprise Server 11 SP1 * * Version Details Vulnerabilities
19 Application Xmlsoft Libxml2 * * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Openoffice 1
Apple Iphone Os 1
Apple Itunes 1
Apple Mac Os X 1
Apple Safari 1
Debian Debian Linux 2
Fedoraproject Fedora 1
Google Chrome 1
HP Insight Control Server Deployment 1
HP Rapid Deployment Pack 1
Opensuse Opensuse 2
Redhat Enterprise Linux Desktop 1
Redhat Enterprise Linux Eus 1
Redhat Enterprise Linux Server 1
Redhat Enterprise Linux Workstation 1
Suse Suse Linux Enterprise Server 1
Xmlsoft Libxml2 1

- References For CVE-2010-4494

http://lists.opensuse.org/opensuse-security-announce/2011-04/msg00000.html
SUSE SUSE-SR:2011:005
http://www.redhat.com/support/errata/RHSA-2011-1749.html
REDHAT RHSA-2011:1749
http://rhn.redhat.com/errata/RHSA-2013-0217.html
REDHAT RHSA-2013:0217
http://lists.fedoraproject.org/pipermail/package-announce/2011-March/055775.html
FEDORA FEDORA-2011-2697
http://lists.apple.com/archives/security-announce/2011/Mar/msg00006.html
APPLE APPLE-SA-2011-03-21-1
http://support.apple.com/kb/HT4564 CONFIRM
http://support.apple.com/kb/HT4566 CONFIRM
http://lists.apple.com/archives/security-announce/2011//Mar/msg00004.html
APPLE APPLE-SA-2011-03-09-2
http://googlechromereleases.blogspot.com/2010/12/stable-beta-channel-updates.html CONFIRM
http://support.apple.com/kb/HT4581 CONFIRM
http://lists.apple.com/archives/security-announce/2011//Mar/msg00003.html
APPLE APPLE-SA-2011-03-09-1
http://lists.apple.com/archives/security-announce/2011/Mar/msg00000.html
APPLE APPLE-SA-2011-03-02-1
http://support.apple.com/kb/HT4554 CONFIRM
http://www.openoffice.org/security/cves/CVE-2010-4008_CVE-2010-4494.html CONFIRM
http://secunia.com/advisories/42721
SECUNIA 42721
http://www.vupen.com/english/advisories/2010/3319
VUPEN ADV-2010-3319
http://www.debian.org/security/2010/dsa-2137
DEBIAN DSA-2137
http://www.vupen.com/english/advisories/2011/0230
VUPEN ADV-2011-0230
http://www.vupen.com/english/advisories/2010/3336
VUPEN ADV-2010-3336
http://secunia.com/advisories/42762
SECUNIA 42762
http://www.mandriva.com/security/advisories?name=MDVSA-2010:260
MANDRIVA MDVSA-2010:260
http://code.google.com/p/chromium/issues/detail?id=63444 CONFIRM
http://secunia.com/advisories/42472
SECUNIA 42472
http://secunia.com/advisories/40775
SECUNIA 40775
http://marc.info/?l=bugtraq&m=139447903326211&w=2
HP HPSBGN02970
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11916
OVAL oval:org.mitre.oval:def:11916

- Metasploit Modules Related To CVE-2010-4494

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.