CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-3470

Multiple cross-site scripting (XSS) vulnerabilities in the Workplace (aka WP) component in IBM FileNet P8 Application Engine (P8AE) 3.5.1 before 3.5.1-021 and 4.0.2.x before 4.0.2.7-P8AE-FP007 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Publish Date : 2010-09-20 Last Update Date : 2010-09-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Cross Site Scripting
CWE ID 79

- Products Affected By CVE-2010-3470

# Product Type Vendor Product Version Update Edition Language
1 Application IBM Filenet P8 Application Engine 3.5.1 014 Version Details Vulnerabilities
2 Application IBM Filenet P8 Application Engine 3.5.1 020 Version Details Vulnerabilities
3 Application IBM Filenet P8 Application Engine 3.5.1 001 Version Details Vulnerabilities
4 Application IBM Filenet P8 Application Engine 3.5.1 015 Version Details Vulnerabilities
5 Application IBM Filenet P8 Application Engine 3.5.1 005 Version Details Vulnerabilities
6 Application IBM Filenet P8 Application Engine 3.5.1 013 Version Details Vulnerabilities
7 Application IBM Filenet P8 Application Engine 3.5.1 018 Version Details Vulnerabilities
8 Application IBM Filenet P8 Application Engine 3.5.1 004 Version Details Vulnerabilities
9 Application IBM Filenet P8 Application Engine 3.5.1 009 Version Details Vulnerabilities
10 Application IBM Filenet P8 Application Engine 3.5.1 017 Version Details Vulnerabilities
11 Application IBM Filenet P8 Application Engine 3.5.1 003 Version Details Vulnerabilities
12 Application IBM Filenet P8 Application Engine 3.5.1 010 Version Details Vulnerabilities
13 Application IBM Filenet P8 Application Engine 3.5.1 008 Version Details Vulnerabilities
14 Application IBM Filenet P8 Application Engine 3.5.1 012 Version Details Vulnerabilities
15 Application IBM Filenet P8 Application Engine 3.5.1 019 Version Details Vulnerabilities
16 Application IBM Filenet P8 Application Engine 3.5.1 002 Version Details Vulnerabilities
17 Application IBM Filenet P8 Application Engine 3.5.1 007 Version Details Vulnerabilities
18 Application IBM Filenet P8 Application Engine 3.5.1 011 Version Details Vulnerabilities
19 Application IBM Filenet P8 Application Engine 3.5.1 016 Version Details Vulnerabilities
20 Application IBM Filenet P8 Application Engine 3.5.1 Version Details Vulnerabilities
21 Application IBM Filenet P8 Application Engine 3.5.1 006 Version Details Vulnerabilities
22 Application IBM Filenet P8 Application Engine 4.0.2 002 Version Details Vulnerabilities
23 Application IBM Filenet P8 Application Engine 4.0.2 Version Details Vulnerabilities
24 Application IBM Filenet P8 Application Engine 4.0.2 001 Version Details Vulnerabilities
25 Application IBM Filenet P8 Application Engine 4.0.2 006 Version Details Vulnerabilities
26 Application IBM Filenet P8 Application Engine 4.0.2 005 Version Details Vulnerabilities
27 Application IBM Filenet P8 Application Engine 4.0.2 004 Version Details Vulnerabilities
28 Application IBM Filenet P8 Application Engine 4.0.2 003 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
IBM Filenet P8 Application Engine 28

- References For CVE-2010-3470

http://download2.boulder.ibm.com/sar/CMA/IMA/00yrk/0/readme-ae351-021.htm CONFIRM
http://www.vupen.com/english/advisories/2010/2419
VUPEN ADV-2010-2419
http://download2.boulder.ibm.com/sar/CMA/IMA/00y3y/0/readme-4027-P8AE-FP007.htm CONFIRM
http://secunia.com/advisories/41458
SECUNIA 41458
http://secunia.com/advisories/41460
SECUNIA 41460
http://www.securityfocus.com/bid/43271
BID 43271 IBM FileNet Application Engine Multiple Vulnerabilities Release Date:2015-02-28
http://www-01.ibm.com/support/docview.wss?uid=swg1PJ37179
AIXAPAR PJ37179
http://www.securityfocus.com/bid/43272
BID 43272 IBM FileNet Application Engine Open Redirection and Cross Site Scripting Vulnerabilities Release Date:2010-09-16

- Metasploit Modules Related To CVE-2010-3470

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.