CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-2235

template_api.py in Cobbler before 2.0.7, as used in Red Hat Network Satellite Server and other products, does not disable the ability of the Cheetah template engine to execute Python statements contained in templates, which allows remote authenticated administrators to execute arbitrary code via a crafted kickstart template file, a different vulnerability than CVE-2008-6954.
Publish Date : 2010-12-09 Last Update Date : 2010-12-10
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
8.5
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication ???
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 94

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important
7.1
AV:N/AC:H/Au:S/C:C/I:C/A:C 2010-06-23 2010-10-18
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Products Affected By CVE-2010-2235

# Product Type Vendor Product Version Update Edition Language
1 Application Michael Dehaan Cobbler * * * * Version Details Vulnerabilities
2 Application Michael Dehaan Cobbler 0.1.1.7 * * * Version Details Vulnerabilities
3 Application Michael Dehaan Cobbler 0.2.1 * * * Version Details Vulnerabilities
4 Application Michael Dehaan Cobbler 0.2.2 * * * Version Details Vulnerabilities
5 Application Michael Dehaan Cobbler 0.2.3 * * * Version Details Vulnerabilities
6 Application Michael Dehaan Cobbler 0.2.5 * * * Version Details Vulnerabilities
7 Application Michael Dehaan Cobbler 0.2.7 * * * Version Details Vulnerabilities
8 Application Michael Dehaan Cobbler 0.2.8 * * * Version Details Vulnerabilities
9 Application Michael Dehaan Cobbler 0.2.9 * * * Version Details Vulnerabilities
10 Application Michael Dehaan Cobbler 0.3.0 * * * Version Details Vulnerabilities
11 Application Michael Dehaan Cobbler 0.3.1 * * * Version Details Vulnerabilities
12 Application Michael Dehaan Cobbler 0.3.3 * * * Version Details Vulnerabilities
13 Application Michael Dehaan Cobbler 0.3.4 * * * Version Details Vulnerabilities
14 Application Michael Dehaan Cobbler 0.3.5 * * * Version Details Vulnerabilities
15 Application Michael Dehaan Cobbler 0.3.6 * * * Version Details Vulnerabilities
16 Application Michael Dehaan Cobbler 0.3.7 * * * Version Details Vulnerabilities
17 Application Michael Dehaan Cobbler 0.3.9 * * * Version Details Vulnerabilities
18 Application Michael Dehaan Cobbler 0.4.0 * * * Version Details Vulnerabilities
19 Application Michael Dehaan Cobbler 0.4.2 * * * Version Details Vulnerabilities
20 Application Michael Dehaan Cobbler 0.4.3 * * * Version Details Vulnerabilities
21 Application Michael Dehaan Cobbler 0.4.5 * * * Version Details Vulnerabilities
22 Application Michael Dehaan Cobbler 0.4.6 * * * Version Details Vulnerabilities
23 Application Michael Dehaan Cobbler 0.4.7 * * * Version Details Vulnerabilities
24 Application Michael Dehaan Cobbler 0.4.8 * * * Version Details Vulnerabilities
25 Application Michael Dehaan Cobbler 0.5.0 * * * Version Details Vulnerabilities
26 Application Michael Dehaan Cobbler 0.6.0 * * * Version Details Vulnerabilities
27 Application Michael Dehaan Cobbler 0.6.1 * * * Version Details Vulnerabilities
28 Application Michael Dehaan Cobbler 0.6.3 * * * Version Details Vulnerabilities
29 Application Michael Dehaan Cobbler 0.6.4 * * * Version Details Vulnerabilities
30 Application Michael Dehaan Cobbler 0.6.5 * * * Version Details Vulnerabilities
31 Application Michael Dehaan Cobbler 0.8.1 * * * Version Details Vulnerabilities
32 Application Michael Dehaan Cobbler 0.8.3 * * * Version Details Vulnerabilities
33 Application Michael Dehaan Cobbler 1.0.0 * * * Version Details Vulnerabilities
34 Application Michael Dehaan Cobbler 1.0.2 * * * Version Details Vulnerabilities
35 Application Michael Dehaan Cobbler 1.0.2-1 * * * Version Details Vulnerabilities
36 Application Michael Dehaan Cobbler 1.0.3-1 * * * Version Details Vulnerabilities
37 Application Michael Dehaan Cobbler 1.2.0 * * * Version Details Vulnerabilities
38 Application Michael Dehaan Cobbler 1.2.2 * * * Version Details Vulnerabilities
39 Application Michael Dehaan Cobbler 1.2.3 * * * Version Details Vulnerabilities
40 Application Michael Dehaan Cobbler 1.2.5 * * * Version Details Vulnerabilities
41 Application Michael Dehaan Cobbler 1.2.6 * * * Version Details Vulnerabilities
42 Application Michael Dehaan Cobbler 1.2.7 * * * Version Details Vulnerabilities
43 Application Michael Dehaan Cobbler 1.2.8 * * * Version Details Vulnerabilities
44 Application Michael Dehaan Cobbler 1.2.8-1 * * * Version Details Vulnerabilities
45 Application Michael Dehaan Cobbler 1.2.9 * * * Version Details Vulnerabilities
46 Application Michael Dehaan Cobbler 1.2.9-1 * * * Version Details Vulnerabilities
47 Application Michael Dehaan Cobbler 1.3.1 * * * Version Details Vulnerabilities
48 Application Michael Dehaan Cobbler 1.3.1-1 * * * Version Details Vulnerabilities
49 Application Michael Dehaan Cobbler 1.3.3 * * * Version Details Vulnerabilities
50 Application Michael Dehaan Cobbler 1.3.3-1 * * * Version Details Vulnerabilities
51 Application Michael Dehaan Cobbler 1.3.4-1 * * * Version Details Vulnerabilities
52 Application Michael Dehaan Cobbler 1.3.4 * * * Version Details Vulnerabilities
53 Application Michael Dehaan Cobbler 1.4.0-2 * * * Version Details Vulnerabilities
54 Application Michael Dehaan Cobbler 1.4.0 * * * Version Details Vulnerabilities
55 Application Michael Dehaan Cobbler 1.4.1-1 * * * Version Details Vulnerabilities
56 Application Michael Dehaan Cobbler 1.4.1 * * * Version Details Vulnerabilities
57 Application Michael Dehaan Cobbler 1.4.2-1 * * * Version Details Vulnerabilities
58 Application Michael Dehaan Cobbler 1.4.2 * * * Version Details Vulnerabilities
59 Application Michael Dehaan Cobbler 1.4.3-4 * * * Version Details Vulnerabilities
60 Application Michael Dehaan Cobbler 1.4.3 * * * Version Details Vulnerabilities
61 Application Michael Dehaan Cobbler 1.6.1-1 * * * Version Details Vulnerabilities
62 Application Michael Dehaan Cobbler 1.6.1 * * * Version Details Vulnerabilities
63 Application Michael Dehaan Cobbler 1.6.2-1 * * * Version Details Vulnerabilities
64 Application Michael Dehaan Cobbler 1.6.2 * * * Version Details Vulnerabilities
65 Application Michael Dehaan Cobbler 1.6.3 * * * Version Details Vulnerabilities
66 Application Michael Dehaan Cobbler 1.6.3-1 * * * Version Details Vulnerabilities
67 Application Michael Dehaan Cobbler 1.6.4-1 * * * Version Details Vulnerabilities
68 Application Michael Dehaan Cobbler 1.6.4 * * * Version Details Vulnerabilities
69 Application Michael Dehaan Cobbler 1.6.5 * * * Version Details Vulnerabilities
70 Application Michael Dehaan Cobbler 1.6.5-1 * * * Version Details Vulnerabilities
71 Application Michael Dehaan Cobbler 1.6.6 * * * Version Details Vulnerabilities
72 Application Michael Dehaan Cobbler 1.6.6-1 * * * Version Details Vulnerabilities
73 Application Michael Dehaan Cobbler 1.6.8-1 * * * Version Details Vulnerabilities
74 Application Michael Dehaan Cobbler 1.6.8 * * * Version Details Vulnerabilities
75 Application Michael Dehaan Cobbler 2.0.0 * * * Version Details Vulnerabilities
76 Application Michael Dehaan Cobbler 2.0.0-1 * * * Version Details Vulnerabilities
77 Application Michael Dehaan Cobbler 2.0.1 * * * Version Details Vulnerabilities
78 Application Michael Dehaan Cobbler 2.0.1-1 * * * Version Details Vulnerabilities
79 Application Michael Dehaan Cobbler 2.0.3 * * * Version Details Vulnerabilities
80 Application Michael Dehaan Cobbler 2.0.3.1-2 * * * Version Details Vulnerabilities
81 Application Michael Dehaan Cobbler 2.0.3.1 * * * Version Details Vulnerabilities
82 Application Michael Dehaan Cobbler 2.0.4-1 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Michael Dehaan Cobbler 82

- References For CVE-2010-2235

http://people.fedoraproject.org/~shenson/cobbler/cobbler-2.0.8.tar.gz CONFIRM
http://www.redhat.com/support/errata/RHSA-2010-0775.html
REDHAT RHSA-2010:0775
https://bugzilla.redhat.com/show_bug.cgi?id=607662 CONFIRM

- Metasploit Modules Related To CVE-2010-2235

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.