CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-2199

lib/fsm.c in RPM 4.8.0 and earlier does not properly reset the metadata of an executable file during replacement of the file in an RPM package upgrade or deletion of the file in an RPM package removal, which might allow local users to bypass intended access restrictions by creating a hard link to a vulnerable file that has a POSIX ACL, a related issue to CVE-2010-2059.
Publish Date : 2010-06-08 Last Update Date : 2017-08-17
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.2
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Bypass a restriction or similar
CWE ID 264

- Products Affected By CVE-2010-2199

# Product Type Vendor Product Version Update Edition Language
1 Application RPM RPM * * * * Version Details Vulnerabilities
2 Application RPM RPM 1.2 * * * Version Details Vulnerabilities
3 Application RPM RPM 1.3 * * * Version Details Vulnerabilities
4 Application RPM RPM 1.3.1 * * * Version Details Vulnerabilities
5 Application RPM RPM 1.4 * * * Version Details Vulnerabilities
6 Application RPM RPM 1.4.2\/a * * * Version Details Vulnerabilities
7 Application RPM RPM 1.4.2 * * * Version Details Vulnerabilities
8 Application RPM RPM 1.4.3 * * * Version Details Vulnerabilities
9 Application RPM RPM 1.4.4 * * * Version Details Vulnerabilities
10 Application RPM RPM 1.4.5 * * * Version Details Vulnerabilities
11 Application RPM RPM 1.4.6 * * * Version Details Vulnerabilities
12 Application RPM RPM 1.4.7 * * * Version Details Vulnerabilities
13 Application RPM RPM 2.0 * * * Version Details Vulnerabilities
14 Application RPM RPM 2.0.1 * * * Version Details Vulnerabilities
15 Application RPM RPM 2.0.2 * * * Version Details Vulnerabilities
16 Application RPM RPM 2.0.3 * * * Version Details Vulnerabilities
17 Application RPM RPM 2.0.4 * * * Version Details Vulnerabilities
18 Application RPM RPM 2..4.10 * * * Version Details Vulnerabilities
19 Application RPM RPM 2.0.5 * * * Version Details Vulnerabilities
20 Application RPM RPM 2.0.6 * * * Version Details Vulnerabilities
21 Application RPM RPM 2.0.7 * * * Version Details Vulnerabilities
22 Application RPM RPM 2.0.8 * * * Version Details Vulnerabilities
23 Application RPM RPM 2.0.9 * * * Version Details Vulnerabilities
24 Application RPM RPM 2.0.10 * * * Version Details Vulnerabilities
25 Application RPM RPM 2.0.11 * * * Version Details Vulnerabilities
26 Application RPM RPM 2.1 * * * Version Details Vulnerabilities
27 Application RPM RPM 2.1.1 * * * Version Details Vulnerabilities
28 Application RPM RPM 2.1.2 * * * Version Details Vulnerabilities
29 Application RPM RPM 2.2 * * * Version Details Vulnerabilities
30 Application RPM RPM 2.2.1 * * * Version Details Vulnerabilities
31 Application RPM RPM 2.2.2 * * * Version Details Vulnerabilities
32 Application RPM RPM 2.2.3 * * * Version Details Vulnerabilities
33 Application RPM RPM 2.2.3.10 * * * Version Details Vulnerabilities
34 Application RPM RPM 2.2.3.11 * * * Version Details Vulnerabilities
35 Application RPM RPM 2.2.4 * * * Version Details Vulnerabilities
36 Application RPM RPM 2.2.5 * * * Version Details Vulnerabilities
37 Application RPM RPM 2.2.6 * * * Version Details Vulnerabilities
38 Application RPM RPM 2.2.7 * * * Version Details Vulnerabilities
39 Application RPM RPM 2.2.8 * * * Version Details Vulnerabilities
40 Application RPM RPM 2.2.9 * * * Version Details Vulnerabilities
41 Application RPM RPM 2.2.10 * * * Version Details Vulnerabilities
42 Application RPM RPM 2.2.11 * * * Version Details Vulnerabilities
43 Application RPM RPM 2.3 * * * Version Details Vulnerabilities
44 Application RPM RPM 2.3.1 * * * Version Details Vulnerabilities
45 Application RPM RPM 2.3.2 * * * Version Details Vulnerabilities
46 Application RPM RPM 2.3.3 * * * Version Details Vulnerabilities
47 Application RPM RPM 2.3.4 * * * Version Details Vulnerabilities
48 Application RPM RPM 2.3.5 * * * Version Details Vulnerabilities
49 Application RPM RPM 2.3.6 * * * Version Details Vulnerabilities
50 Application RPM RPM 2.3.7 * * * Version Details Vulnerabilities
51 Application RPM RPM 2.3.8 * * * Version Details Vulnerabilities
52 Application RPM RPM 2.3.9 * * * Version Details Vulnerabilities
53 Application RPM RPM 2.4.1 * * * Version Details Vulnerabilities
54 Application RPM RPM 2.4.2 * * * Version Details Vulnerabilities
55 Application RPM RPM 2.4.3 * * * Version Details Vulnerabilities
56 Application RPM RPM 2.4.4 * * * Version Details Vulnerabilities
57 Application RPM RPM 2.4.5 * * * Version Details Vulnerabilities
58 Application RPM RPM 2.4.6 * * * Version Details Vulnerabilities
59 Application RPM RPM 2.4.8 * * * Version Details Vulnerabilities
60 Application RPM RPM 2.4.9 * * * Version Details Vulnerabilities
61 Application RPM RPM 2.4.11 * * * Version Details Vulnerabilities
62 Application RPM RPM 2.4.12 * * * Version Details Vulnerabilities
63 Application RPM RPM 2.5 * * * Version Details Vulnerabilities
64 Application RPM RPM 2.5.1 * * * Version Details Vulnerabilities
65 Application RPM RPM 2.5.2 * * * Version Details Vulnerabilities
66 Application RPM RPM 2.5.3 * * * Version Details Vulnerabilities
67 Application RPM RPM 2.5.4 * * * Version Details Vulnerabilities
68 Application RPM RPM 2.5.5 * * * Version Details Vulnerabilities
69 Application RPM RPM 2.5.6 * * * Version Details Vulnerabilities
70 Application RPM RPM 2.6.7 * * * Version Details Vulnerabilities
71 Application RPM RPM 3.0 * * * Version Details Vulnerabilities
72 Application RPM RPM 3.0.1 * * * Version Details Vulnerabilities
73 Application RPM RPM 3.0.2 * * * Version Details Vulnerabilities
74 Application RPM RPM 3.0.3 * * * Version Details Vulnerabilities
75 Application RPM RPM 3.0.4 * * * Version Details Vulnerabilities
76 Application RPM RPM 3.0.5 * * * Version Details Vulnerabilities
77 Application RPM RPM 3.0.6 * * * Version Details Vulnerabilities
78 Application RPM RPM 4.0. * * * Version Details Vulnerabilities
79 Application RPM RPM 4.0.1 * * * Version Details Vulnerabilities
80 Application RPM RPM 4.0.2 * * * Version Details Vulnerabilities
81 Application RPM RPM 4.0.3 * * * Version Details Vulnerabilities
82 Application RPM RPM 4.0.4 * * * Version Details Vulnerabilities
83 Application RPM RPM 4.1 * * * Version Details Vulnerabilities
84 Application RPM RPM 4.3.3 * * * Version Details Vulnerabilities
85 Application RPM RPM 4.4.2 * * * Version Details Vulnerabilities
86 Application RPM RPM 4.4.2.1 * * * Version Details Vulnerabilities
87 Application RPM RPM 4.4.2.2 * * * Version Details Vulnerabilities
88 Application RPM RPM 4.4.2.3 * * * Version Details Vulnerabilities
89 Application RPM RPM 4.6.0 * * * Version Details Vulnerabilities
90 Application RPM RPM 4.6.1 * * * Version Details Vulnerabilities
91 Application RPM RPM 4.7.0 * * * Version Details Vulnerabilities
92 Application RPM RPM 4.7.1 * * * Version Details Vulnerabilities
93 Application RPM RPM 4.7.2 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
RPM RPM 93

- References For CVE-2010-2199

https://exchange.xforce.ibmcloud.com/vulnerabilities/59416
XF rpm-fsm-security-bypass(59416)
https://bugzilla.redhat.com/show_bug.cgi?id=125517 CONFIRM

- Metasploit Modules Related To CVE-2010-2199

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.