CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-1850

Buffer overflow in MySQL 5.0 through 5.0.91 and 5.1 before 5.1.47 allows remote authenticated users to execute arbitrary code via a COM_FIELD_LIST command with a long table name.
Publish Date : 2010-06-08 Last Update Date : 2019-12-17
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication ???
Gained Access None
Vulnerability Type(s) Execute CodeOverflow
CWE ID 119

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important
6.0
AV:N/AC:M/Au:S/C:P/I:P/A:P 2010-05-13 2010-05-13
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
Buffer overflow in MySQL 5.0 through 5.0.91 and 5.1 before 5.1.47 allows remote authenticated users to execute arbitrary... oval:org.mitre.oval:def:10846 unix
CVE-2010-1850 oval:org.opensuse.security:def:20101850 unix
DEPRECATED: ELSA-2010-0442 -- mysql security update (important) oval:org.mitre.oval:def:28096 unix
DSA-2057 mysql-dfsg-5.0 -- several vulnerabilities oval:org.mitre.oval:def:11765 unix
DSA-2057-1 mysql-dfsg-5.0 -- several oval:org.mitre.oval:def:13286 unix
ELSA-2010:0442: mysql security update (Important) oval:org.mitre.oval:def:23130 unix
Oracle MySQL 'COM_FIELD_LIST' Command Buffer Overflow Vulnerability oval:org.mitre.oval:def:6693 windows
RHSA-2010:0442: mysql security update (Important) oval:com.redhat.rhsa:def:20100442 unix
RHSA-2010:0442: mysql security update (Important) oval:org.mitre.oval:def:22134 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2010-1850

# Product Type Vendor Product Version Update Edition Language
1 Application Mysql Mysql 5.0.0 * * * Version Details Vulnerabilities
2 Application Mysql Mysql 5.0.1 * * * Version Details Vulnerabilities
3 Application Mysql Mysql 5.0.2 * * * Version Details Vulnerabilities
4 Application Mysql Mysql 5.0.3 * * * Version Details Vulnerabilities
5 Application Mysql Mysql 5.0.4 * * * Version Details Vulnerabilities
6 Application Mysql Mysql 5.0.5 * * * Version Details Vulnerabilities
7 Application Mysql Mysql 5.0.5.0.21 * * * Version Details Vulnerabilities
8 Application Mysql Mysql 5.0.10 * * * Version Details Vulnerabilities
9 Application Mysql Mysql 5.0.15 * * * Version Details Vulnerabilities
10 Application Mysql Mysql 5.0.16 * * * Version Details Vulnerabilities
11 Application Mysql Mysql 5.0.17 * * * Version Details Vulnerabilities
12 Application Mysql Mysql 5.0.20 * * * Version Details Vulnerabilities
13 Application Mysql Mysql 5.0.24 * * * Version Details Vulnerabilities
14 Application Mysql Mysql 5.0.45b * * * Version Details Vulnerabilities
15 Application Mysql Mysql 5.0.82 * * * Version Details Vulnerabilities
16 Application Mysql Mysql 5.0.84 * * * Version Details Vulnerabilities
17 Application Mysql Mysql 5.0.87 * * * Version Details Vulnerabilities
18 Application Mysql Mysql 5.1.5 * * * Version Details Vulnerabilities
19 Application Mysql Mysql 5.1.23 * * * Version Details Vulnerabilities
20 Application Mysql Mysql 5.1.31 * * * Version Details Vulnerabilities
21 Application Mysql Mysql 5.1.32 * * * Version Details Vulnerabilities
22 Application Mysql Mysql 5.1.34 * * * Version Details Vulnerabilities
23 Application Mysql Mysql 5.1.37 * * * Version Details Vulnerabilities
24 Application Oracle Mysql 5.0.0 Alpha * * Version Details Vulnerabilities
25 Application Oracle Mysql 5.0.3 Beta * * Version Details Vulnerabilities
26 Application Oracle Mysql 5.0.6 * * * Version Details Vulnerabilities
27 Application Oracle Mysql 5.0.7 * * * Version Details Vulnerabilities
28 Application Oracle Mysql 5.0.8 * * * Version Details Vulnerabilities
29 Application Oracle Mysql 5.0.9 * * * Version Details Vulnerabilities
30 Application Oracle Mysql 5.0.11 * * * Version Details Vulnerabilities
31 Application Oracle Mysql 5.0.12 * * * Version Details Vulnerabilities
32 Application Oracle Mysql 5.0.13 * * * Version Details Vulnerabilities
33 Application Oracle Mysql 5.0.14 * * * Version Details Vulnerabilities
34 Application Oracle Mysql 5.0.18 * * * Version Details Vulnerabilities
35 Application Oracle Mysql 5.0.19 * * * Version Details Vulnerabilities
36 Application Oracle Mysql 5.0.21 * * * Version Details Vulnerabilities
37 Application Oracle Mysql 5.0.22 * * * Version Details Vulnerabilities
38 Application Oracle Mysql 5.0.23 * * * Version Details Vulnerabilities
39 Application Oracle Mysql 5.0.27 * * * Version Details Vulnerabilities
40 Application Oracle Mysql 5.0.33 * * * Version Details Vulnerabilities
41 Application Oracle Mysql 5.0.37 * * * Version Details Vulnerabilities
42 Application Oracle Mysql 5.0.41 * * * Version Details Vulnerabilities
43 Application Oracle Mysql 5.0.45 * * * Version Details Vulnerabilities
44 Application Oracle Mysql 5.0.51 * * * Version Details Vulnerabilities
45 Application Oracle Mysql 5.0.67 * * * Version Details Vulnerabilities
46 Application Oracle Mysql 5.0.75 * * * Version Details Vulnerabilities
47 Application Oracle Mysql 5.0.77 * * * Version Details Vulnerabilities
48 Application Oracle Mysql 5.0.81 * * * Version Details Vulnerabilities
49 Application Oracle Mysql 5.0.83 * * * Version Details Vulnerabilities
50 Application Oracle Mysql 5.0.85 * * * Version Details Vulnerabilities
51 Application Oracle Mysql 5.0.86 * * * Version Details Vulnerabilities
52 Application Oracle Mysql 5.0.88 * * * Version Details Vulnerabilities
53 Application Oracle Mysql 5.0.89 * * * Version Details Vulnerabilities
54 Application Oracle Mysql 5.0.90 * * * Version Details Vulnerabilities
55 Application Oracle Mysql 5.0.91 * * * Version Details Vulnerabilities
56 Application Oracle Mysql 5.1 * * * Version Details Vulnerabilities
57 Application Oracle Mysql 5.1.1 * * * Version Details Vulnerabilities
58 Application Oracle Mysql 5.1.2 * * * Version Details Vulnerabilities
59 Application Oracle Mysql 5.1.3 * * * Version Details Vulnerabilities
60 Application Oracle Mysql 5.1.4 * * * Version Details Vulnerabilities
61 Application Oracle Mysql 5.1.6 * * * Version Details Vulnerabilities
62 Application Oracle Mysql 5.1.7 * * * Version Details Vulnerabilities
63 Application Oracle Mysql 5.1.8 * * * Version Details Vulnerabilities
64 Application Oracle Mysql 5.1.9 * * * Version Details Vulnerabilities
65 Application Oracle Mysql 5.1.10 * * * Version Details Vulnerabilities
66 Application Oracle Mysql 5.1.11 * * * Version Details Vulnerabilities
67 Application Oracle Mysql 5.1.12 * * * Version Details Vulnerabilities
68 Application Oracle Mysql 5.1.13 * * * Version Details Vulnerabilities
69 Application Oracle Mysql 5.1.14 * * * Version Details Vulnerabilities
70 Application Oracle Mysql 5.1.15 * * * Version Details Vulnerabilities
71 Application Oracle Mysql 5.1.16 * * * Version Details Vulnerabilities
72 Application Oracle Mysql 5.1.17 * * * Version Details Vulnerabilities
73 Application Oracle Mysql 5.1.30 * * * Version Details Vulnerabilities
74 Application Oracle Mysql 5.1.33 * * * Version Details Vulnerabilities
75 Application Oracle Mysql 5.1.35 * * * Version Details Vulnerabilities
76 Application Oracle Mysql 5.1.36 * * * Version Details Vulnerabilities
77 Application Oracle Mysql 5.1.38 * * * Version Details Vulnerabilities
78 Application Oracle Mysql 5.1.39 * * * Version Details Vulnerabilities
79 Application Oracle Mysql 5.1.40 * * * Version Details Vulnerabilities
80 Application Oracle Mysql 5.1.41 * * * Version Details Vulnerabilities
81 Application Oracle Mysql 5.1.42 * * * Version Details Vulnerabilities
82 Application Oracle Mysql 5.1.43 * * * Version Details Vulnerabilities
83 Application Oracle Mysql 5.1.44 * * * Version Details Vulnerabilities
84 Application Oracle Mysql 5.1.45 * * * Version Details Vulnerabilities
85 Application Oracle Mysql 5.1.46 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mysql Mysql 23
Oracle Mysql 62

- References For CVE-2010-1850

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6693
OVAL oval:org.mitre.oval:def:6693
http://lists.apple.com/archives/security-announce/2010//Nov/msg00000.html
APPLE APPLE-SA-2010-11-10-1
http://bugs.mysql.com/bug.php?id=53237 CONFIRM
http://www.redhat.com/support/errata/RHSA-2010-0442.html
REDHAT RHSA-2010:0442
http://lists.opensuse.org/opensuse-security-announce/2010-10/msg00006.html
SUSE SUSE-SR:2010:019
http://support.apple.com/kb/HT4435 CONFIRM
http://dev.mysql.com/doc/refman/5.1/en/news-5-1-47.html CONFIRM
http://securitytracker.com/id?1024033
SECTRACK 1024033
http://dev.mysql.com/doc/refman/5.0/en/news-5-0-91.html CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2010:107
MANDRIVA MDVSA-2010:107
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10846
OVAL oval:org.mitre.oval:def:10846
http://www.ubuntu.com/usn/USN-1397-1
UBUNTU USN-1397-1

- Metasploit Modules Related To CVE-2010-1850

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.