CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-1623

Memory leak in the apr_brigade_split_line function in buckets/apr_brigade.c in the Apache Portable Runtime Utility library (aka APR-util) before 1.3.10, as used in the mod_reqtimeout module in the Apache HTTP Server and other software, allows remote attackers to cause a denial of service (memory consumption) via unspecified vectors related to the destruction of an APR bucket.
Publish Date : 2010-10-04 Last Update Date : 2017-09-18
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceOverflow
CWE ID 119

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate
5.0
AV:N/AC:L/Au:N/C:N/I:N/A:P 2010-10-04 2010-10-01
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
apr_bridage_split_line DoS oval:org.apache.httpd:def:20101623
CVE-2010-1623 oval:org.opensuse.security:def:20101623 unix
DEPRECATED: ELSA-2010:0950: apr-util security update (Moderate) oval:org.mitre.oval:def:23037 unix
ELSA-2010:0950: apr-util security update (Moderate) oval:org.mitre.oval:def:23618 unix
HP-UX Apache Web Server, Remote Information Disclosure, Cross-Site Scripting (XSS), Denial of Service (DoS) oval:org.mitre.oval:def:12800 unix
RHSA-2010:0950: apr-util security update (Moderate) oval:org.mitre.oval:def:22351 unix
RHSA-2010:0950: apr-util security update (Moderate) oval:com.redhat.rhsa:def:20100950 unix
USN-1022-1 -- apr-util vulnerability oval:org.mitre.oval:def:13027 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2010-1623

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Apr-util 0.9.1 Version Details Vulnerabilities
2 Application Apache Apr-util 0.9.2 Version Details Vulnerabilities
3 Application Apache Apr-util 0.9.3 Version Details Vulnerabilities
4 Application Apache Apr-util 0.9.4 Version Details Vulnerabilities
5 Application Apache Apr-util 0.9.5 Version Details Vulnerabilities
6 Application Apache Apr-util 0.9.6 Version Details Vulnerabilities
7 Application Apache Apr-util 0.9.7 Version Details Vulnerabilities
8 Application Apache Apr-util 0.9.8 Version Details Vulnerabilities
9 Application Apache Apr-util 0.9.9 Version Details Vulnerabilities
10 Application Apache Apr-util 0.9.10 Version Details Vulnerabilities
11 Application Apache Apr-util 0.9.11 Version Details Vulnerabilities
12 Application Apache Apr-util 0.9.12 Version Details Vulnerabilities
13 Application Apache Apr-util 0.9.13 Version Details Vulnerabilities
14 Application Apache Apr-util 0.9.14 Version Details Vulnerabilities
15 Application Apache Apr-util 0.9.15 Version Details Vulnerabilities
16 Application Apache Apr-util 0.9.16 Version Details Vulnerabilities
17 Application Apache Apr-util 0.9.17 Version Details Vulnerabilities
18 Application Apache Apr-util 0.9.18 Version Details Vulnerabilities
19 Application Apache Apr-util 1.0 Version Details Vulnerabilities
20 Application Apache Apr-util 1.0.1 Version Details Vulnerabilities
21 Application Apache Apr-util 1.0.2 Version Details Vulnerabilities
22 Application Apache Apr-util 1.1.0 Version Details Vulnerabilities
23 Application Apache Apr-util 1.1.1 Version Details Vulnerabilities
24 Application Apache Apr-util 1.1.2 Version Details Vulnerabilities
25 Application Apache Apr-util 1.2.1 Version Details Vulnerabilities
26 Application Apache Apr-util 1.2.2 Version Details Vulnerabilities
27 Application Apache Apr-util 1.2.6 Version Details Vulnerabilities
28 Application Apache Apr-util 1.2.7 Version Details Vulnerabilities
29 Application Apache Apr-util 1.2.8 Version Details Vulnerabilities
30 Application Apache Apr-util 1.2.9 Version Details Vulnerabilities
31 Application Apache Apr-util 1.2.10 Version Details Vulnerabilities
32 Application Apache Apr-util 1.2.12 Version Details Vulnerabilities
33 Application Apache Apr-util 1.2.13 Version Details Vulnerabilities
34 Application Apache Apr-util 1.3.0 Version Details Vulnerabilities
35 Application Apache Apr-util 1.3.1 Version Details Vulnerabilities
36 Application Apache Apr-util 1.3.2 Version Details Vulnerabilities
37 Application Apache Apr-util 1.3.3 Version Details Vulnerabilities
38 Application Apache Apr-util 1.3.4 Version Details Vulnerabilities
39 Application Apache Apr-util 1.3.5 Version Details Vulnerabilities
40 Application Apache Apr-util 1.3.6 Version Details Vulnerabilities
41 Application Apache Apr-util 1.3.7 Version Details Vulnerabilities
42 Application Apache Apr-util 1.3.8 Version Details Vulnerabilities
43 Application Apache Apr-util 1.3.9 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Apr-util 43

- References For CVE-2010-1623

http://www.vupen.com/english/advisories/2011/0358
VUPEN ADV-2011-0358
http://www.vupen.com/english/advisories/2010/3074
VUPEN ADV-2010-3074
http://www.vupen.com/english/advisories/2010/3064
VUPEN ADV-2010-3064
http://www.vupen.com/english/advisories/2010/3065
VUPEN ADV-2010-3065
http://www.vupen.com/english/advisories/2010/2806
VUPEN ADV-2010-2806
http://www.vupen.com/english/advisories/2010/2557
VUPEN ADV-2010-2557
http://www.vupen.com/english/advisories/2010/2556
VUPEN ADV-2010-2556
http://www.mandriva.com/security/advisories?name=MDVSA-2010:192
MANDRIVA MDVSA-2010:192
http://www.redhat.com/support/errata/RHSA-2010-0950.html
REDHAT RHSA-2010:0950
http://www.securityfocus.com/bid/43673
BID 43673 Apache APR-util 'apr_brigade_split_line()' Denial of Service Vulnerability Release Date:2014-05-21
http://www.redhat.com/support/errata/RHSA-2011-0897.html
REDHAT RHSA-2011:0897
http://www.redhat.com/support/errata/RHSA-2011-0896.html
REDHAT RHSA-2011:0896
http://www.apache.org/dist/apr/CHANGES-APR-UTIL-1.3 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg1PM31601
AIXAPAR PM23263
http://ubuntu.com/usn/usn-1021-1
UBUNTU USN-1021-1
http://svn.apache.org/viewvc?view=revision&revision=1003626 CONFIRM
http://www.ubuntu.com/usn/USN-1022-1
UBUNTU USN-1022-1
http://svn.apache.org/viewvc?view=revision&revision=1003495 CONFIRM
http://svn.apache.org/viewvc?view=revision&revision=1003494 CONFIRM
http://svn.apache.org/viewvc?view=revision&revision=1003493 CONFIRM
http://svn.apache.org/viewvc?view=revision&revision=1003492 CONFIRM
http://slackware.com/security/viewer.php?l=slackware-security&y=2011&m=slackware-security.627828
SLACKWARE SSA:2011-041-01
http://security-tracker.debian.org/tracker/CVE-2010-1623 CONFIRM
http://marc.info/?l=bugtraq&m=130168502603566&w=2
HP HPSBUX02645
http://blogs.sun.com/security/entry/cve_2010_1623_memory_leak CONFIRM
http://lists.fedoraproject.org/pipermail/package-announce/2010-October/049939.html
FEDORA FEDORA-2010-15916
http://lists.opensuse.org/opensuse-security-announce/2011-11/msg00011.html
SUSE SUSE-SU-2011:1229
http://lists.fedoraproject.org/pipermail/package-announce/2010-October/049885.html
FEDORA FEDORA-2010-15953

- Metasploit Modules Related To CVE-2010-1623

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.