CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2009-4780

Multiple cross-site scripting (XSS) vulnerabilities in index.php in phpMyFAQ before 2.5.5 allow remote attackers to inject arbitrary web script or HTML via (1) the lang parameter in a sitemap action, (2) the search parameter in a search action, (3) the tagging_id parameter in a search action, (4) the highlight parameter in an artikel action, (5) the artlang parameter in an artikel action, (6) the letter parameter in a sitemap action, (7) the lang parameter in a show action, (8) the cat parameter in a show action, (9) the newslang parameter in a news action, (10) the artlang parameter in a send2friend action, (11) the cat parameter in a send2friend action, (12) the id parameter in a send2friend action, (13) the srclang parameter in a translate action, (14) the id parameter in a translate action, (15) the cat parameter in a translate action, (16) the cat parameter in an add action, or (17) the question parameter in an add action. NOTE: the provenance of this information is unknown; the details are obtained solely from third party information.
Publish Date : 2010-04-21 Last Update Date : 2010-04-24
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Cross Site Scripting
CWE ID 79

- Products Affected By CVE-2009-4780

# Product Type Vendor Product Version Update Edition Language
1 Application Phpmyfaq Phpmyfaq 0.60 Version Details Vulnerabilities
2 Application Phpmyfaq Phpmyfaq 0.65 Version Details Vulnerabilities
3 Application Phpmyfaq Phpmyfaq 0.70 Version Details Vulnerabilities
4 Application Phpmyfaq Phpmyfaq 0.80 Version Details Vulnerabilities
5 Application Phpmyfaq Phpmyfaq 0.80a Version Details Vulnerabilities
6 Application Phpmyfaq Phpmyfaq 0.85 Version Details Vulnerabilities
7 Application Phpmyfaq Phpmyfaq 0.86 Version Details Vulnerabilities
8 Application Phpmyfaq Phpmyfaq 0.87 Version Details Vulnerabilities
9 Application Phpmyfaq Phpmyfaq 0.90 Version Details Vulnerabilities
10 Application Phpmyfaq Phpmyfaq 0.95 Version Details Vulnerabilities
11 Application Phpmyfaq Phpmyfaq 0.666 Version Details Vulnerabilities
12 Application Phpmyfaq Phpmyfaq 1.0 Version Details Vulnerabilities
13 Application Phpmyfaq Phpmyfaq 1.0.1 Version Details Vulnerabilities
14 Application Phpmyfaq Phpmyfaq 1.0.1a Version Details Vulnerabilities
15 Application Phpmyfaq Phpmyfaq 1.1.0 Version Details Vulnerabilities
16 Application Phpmyfaq Phpmyfaq 1.1.1 Version Details Vulnerabilities
17 Application Phpmyfaq Phpmyfaq 1.1.2 Version Details Vulnerabilities
18 Application Phpmyfaq Phpmyfaq 1.1.3 Version Details Vulnerabilities
19 Application Phpmyfaq Phpmyfaq 1.1.4 Version Details Vulnerabilities
20 Application Phpmyfaq Phpmyfaq 1.1.4a Version Details Vulnerabilities
21 Application Phpmyfaq Phpmyfaq 1.1.5 Version Details Vulnerabilities
22 Application Phpmyfaq Phpmyfaq 1.2.0 Version Details Vulnerabilities
23 Application Phpmyfaq Phpmyfaq 1.2.1 Version Details Vulnerabilities
24 Application Phpmyfaq Phpmyfaq 1.2.2 Version Details Vulnerabilities
25 Application Phpmyfaq Phpmyfaq 1.2.3 Version Details Vulnerabilities
26 Application Phpmyfaq Phpmyfaq 1.2.4 Version Details Vulnerabilities
27 Application Phpmyfaq Phpmyfaq 1.2.5 Version Details Vulnerabilities
28 Application Phpmyfaq Phpmyfaq 1.2.5a Version Details Vulnerabilities
29 Application Phpmyfaq Phpmyfaq 1.2.5b Version Details Vulnerabilities
30 Application Phpmyfaq Phpmyfaq 1.3.0 Version Details Vulnerabilities
31 Application Phpmyfaq Phpmyfaq 1.3.1 Version Details Vulnerabilities
32 Application Phpmyfaq Phpmyfaq 1.3.2 Version Details Vulnerabilities
33 Application Phpmyfaq Phpmyfaq 1.3.3 Version Details Vulnerabilities
34 Application Phpmyfaq Phpmyfaq 1.3.4 Version Details Vulnerabilities
35 Application Phpmyfaq Phpmyfaq 1.3.5 Version Details Vulnerabilities
36 Application Phpmyfaq Phpmyfaq 1.3.6 Version Details Vulnerabilities
37 Application Phpmyfaq Phpmyfaq 1.3.7 Version Details Vulnerabilities
38 Application Phpmyfaq Phpmyfaq 1.3.8 Version Details Vulnerabilities
39 Application Phpmyfaq Phpmyfaq 1.3.9 PL1 Version Details Vulnerabilities
40 Application Phpmyfaq Phpmyfaq 1.3.9 Version Details Vulnerabilities
41 Application Phpmyfaq Phpmyfaq 1.3.10 Version Details Vulnerabilities
42 Application Phpmyfaq Phpmyfaq 1.3.11 Version Details Vulnerabilities
43 Application Phpmyfaq Phpmyfaq 1.3.12 Version Details Vulnerabilities
44 Application Phpmyfaq Phpmyfaq 1.3.13 Version Details Vulnerabilities
45 Application Phpmyfaq Phpmyfaq 1.3.14 Version Details Vulnerabilities
46 Application Phpmyfaq Phpmyfaq 1.4 Alpha1 Version Details Vulnerabilities
47 Application Phpmyfaq Phpmyfaq 1.4 Version Details Vulnerabilities
48 Application Phpmyfaq Phpmyfaq 1.4 Alpha2 Version Details Vulnerabilities
49 Application Phpmyfaq Phpmyfaq 1.4a Version Details Vulnerabilities
50 Application Phpmyfaq Phpmyfaq 1.4.0 Version Details Vulnerabilities
51 Application Phpmyfaq Phpmyfaq 1.4.0a Version Details Vulnerabilities
52 Application Phpmyfaq Phpmyfaq 1.4.1 Version Details Vulnerabilities
53 Application Phpmyfaq Phpmyfaq 1.4.2 Version Details Vulnerabilities
54 Application Phpmyfaq Phpmyfaq 1.4.3 Version Details Vulnerabilities
55 Application Phpmyfaq Phpmyfaq 1.4.4 Version Details Vulnerabilities
56 Application Phpmyfaq Phpmyfaq 1.4.5 Version Details Vulnerabilities
57 Application Phpmyfaq Phpmyfaq 1.4.6 Version Details Vulnerabilities
58 Application Phpmyfaq Phpmyfaq 1.4.7 Version Details Vulnerabilities
59 Application Phpmyfaq Phpmyfaq 1.4.8 Version Details Vulnerabilities
60 Application Phpmyfaq Phpmyfaq 1.4.9 Version Details Vulnerabilities
61 Application Phpmyfaq Phpmyfaq 1.4.10 Version Details Vulnerabilities
62 Application Phpmyfaq Phpmyfaq 1.4.11 Version Details Vulnerabilities
63 Application Phpmyfaq Phpmyfaq 1.5 RC3 Version Details Vulnerabilities
64 Application Phpmyfaq Phpmyfaq 1.5 Alpha1 Version Details Vulnerabilities
65 Application Phpmyfaq Phpmyfaq 1.5 Alpha2 Version Details Vulnerabilities
66 Application Phpmyfaq Phpmyfaq 1.5 Beta1 Version Details Vulnerabilities
67 Application Phpmyfaq Phpmyfaq 1.5 RC4 Version Details Vulnerabilities
68 Application Phpmyfaq Phpmyfaq 1.5 Beta2 Version Details Vulnerabilities
69 Application Phpmyfaq Phpmyfaq 1.5 RC1 Version Details Vulnerabilities
70 Application Phpmyfaq Phpmyfaq 1.5 Version Details Vulnerabilities
71 Application Phpmyfaq Phpmyfaq 1.5 RC5 Version Details Vulnerabilities
72 Application Phpmyfaq Phpmyfaq 1.5 RC2 Version Details Vulnerabilities
73 Application Phpmyfaq Phpmyfaq 1.5 Beta3 Version Details Vulnerabilities
74 Application Phpmyfaq Phpmyfaq 1.5.0 Version Details Vulnerabilities
75 Application Phpmyfaq Phpmyfaq 1.5.1 Version Details Vulnerabilities
76 Application Phpmyfaq Phpmyfaq 1.5.2 Version Details Vulnerabilities
77 Application Phpmyfaq Phpmyfaq 1.5.3 Version Details Vulnerabilities
78 Application Phpmyfaq Phpmyfaq 1.5.4 Version Details Vulnerabilities
79 Application Phpmyfaq Phpmyfaq 1.5.5 Version Details Vulnerabilities
80 Application Phpmyfaq Phpmyfaq 1.5.6 Version Details Vulnerabilities
81 Application Phpmyfaq Phpmyfaq 1.5.7 Version Details Vulnerabilities
82 Application Phpmyfaq Phpmyfaq 1.5.8 Version Details Vulnerabilities
83 Application Phpmyfaq Phpmyfaq 1.5.9 Version Details Vulnerabilities
84 Application Phpmyfaq Phpmyfaq 1.6.0 Version Details Vulnerabilities
85 Application Phpmyfaq Phpmyfaq 1.6.1 Version Details Vulnerabilities
86 Application Phpmyfaq Phpmyfaq 1.6.2 Version Details Vulnerabilities
87 Application Phpmyfaq Phpmyfaq 1.6.3 Version Details Vulnerabilities
88 Application Phpmyfaq Phpmyfaq 1.6.4 Version Details Vulnerabilities
89 Application Phpmyfaq Phpmyfaq 1.6.5 Version Details Vulnerabilities
90 Application Phpmyfaq Phpmyfaq 1.6.6 Version Details Vulnerabilities
91 Application Phpmyfaq Phpmyfaq 1.6.7 Version Details Vulnerabilities
92 Application Phpmyfaq Phpmyfaq 1.6.8 Version Details Vulnerabilities
93 Application Phpmyfaq Phpmyfaq 1.6.9 Version Details Vulnerabilities
94 Application Phpmyfaq Phpmyfaq 1.6.10 Version Details Vulnerabilities
95 Application Phpmyfaq Phpmyfaq 1.6.11 Version Details Vulnerabilities
96 Application Phpmyfaq Phpmyfaq 1.6.12 Version Details Vulnerabilities
97 Application Phpmyfaq Phpmyfaq 2.0.0 Version Details Vulnerabilities
98 Application Phpmyfaq Phpmyfaq 2.0.1 Version Details Vulnerabilities
99 Application Phpmyfaq Phpmyfaq 2.0.2 Version Details Vulnerabilities
100 Application Phpmyfaq Phpmyfaq 2.0.3 Version Details Vulnerabilities
101 Application Phpmyfaq Phpmyfaq 2.0.4 Version Details Vulnerabilities
102 Application Phpmyfaq Phpmyfaq 2.0.5 Version Details Vulnerabilities
103 Application Phpmyfaq Phpmyfaq 2.0.6 Version Details Vulnerabilities
104 Application Phpmyfaq Phpmyfaq 2.0.7 Version Details Vulnerabilities
105 Application Phpmyfaq Phpmyfaq 2.0.8 Version Details Vulnerabilities
106 Application Phpmyfaq Phpmyfaq 2.0.9 Version Details Vulnerabilities
107 Application Phpmyfaq Phpmyfaq 2.0.10 Version Details Vulnerabilities
108 Application Phpmyfaq Phpmyfaq 2.0.11 Version Details Vulnerabilities
109 Application Phpmyfaq Phpmyfaq 2.0.12 Version Details Vulnerabilities
110 Application Phpmyfaq Phpmyfaq 2.0.13 Version Details Vulnerabilities
111 Application Phpmyfaq Phpmyfaq 2.0.14 Version Details Vulnerabilities
112 Application Phpmyfaq Phpmyfaq 2.0.15 Version Details Vulnerabilities
113 Application Phpmyfaq Phpmyfaq 2.0.16 Version Details Vulnerabilities
114 Application Phpmyfaq Phpmyfaq 2.0.17 Version Details Vulnerabilities
115 Application Phpmyfaq Phpmyfaq 2.5.0 Version Details Vulnerabilities
116 Application Phpmyfaq Phpmyfaq 2.5.1 Version Details Vulnerabilities
117 Application Phpmyfaq Phpmyfaq 2.5.2 Version Details Vulnerabilities
118 Application Phpmyfaq Phpmyfaq 2.5.3 Version Details Vulnerabilities
119 Application Phpmyfaq Phpmyfaq 2.5.4 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Phpmyfaq Phpmyfaq 119

- References For CVE-2009-4780

http://secunia.com/advisories/37520
SECUNIA 37520
http://www.securityfocus.com/bid/37180
BID 37180 phpMyFAQ 2.5.4 and Prior Multiple Cross Site Scripting Vulnerabilities Release Date:2009-12-03

- Metasploit Modules Related To CVE-2009-4780

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.