CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2009-4492

WEBrick 1.3.1 in Ruby 1.8.6 through patchlevel 383, 1.8.7 through patchlevel 248, 1.8.8dev, 1.9.1 through patchlevel 376, and 1.9.2dev writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.
Publish Date : 2010-01-13 Last Update Date : 2011-08-23
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 20

- Vendor Statements

Red Hat is aware of this issue and is tracking it via the following bug: https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2009-4492 The Red Hat Security Response Team has rated this issue as having low security impact, a future update may address this flaw.
Source: Redhat

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low
2.6
AV:N/AC:H/Au:N/C:N/I:P/A:N 2009-12-30 2010-01-11
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2009-4492 oval:org.opensuse.security:def:20094492 unix
DEPRECATED: ELSA-2011-0909 -- ruby security update (moderate) oval:org.mitre.oval:def:28124 unix
ELSA-2011:0909: ruby security update (Moderate) oval:org.mitre.oval:def:23159 unix
RHSA-2011:0908: ruby security update (Moderate) oval:com.redhat.rhsa:def:20110908 unix
RHSA-2011:0909: ruby security update (Moderate) oval:org.mitre.oval:def:21638 unix
RHSA-2011:0909: ruby security update (Moderate) oval:com.redhat.rhsa:def:20110909 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2009-4492

# Product Type Vendor Product Version Update Edition Language
1 Application Ruby-lang Ruby 1.8.6 Version Details Vulnerabilities
2 Application Ruby-lang Ruby 1.8.7 Version Details Vulnerabilities
3 Application Ruby-lang Ruby 1.8.8 DEV Version Details Vulnerabilities
4 Application Ruby-lang Ruby 1.9.1 Version Details Vulnerabilities
5 Application Ruby-lang Ruby 1.9.2 DEV Version Details Vulnerabilities
6 Application Webrick Webrick 1.3.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Ruby-lang Ruby 5
Webrick Webrick 1

- References For CVE-2009-4492

http://secunia.com/advisories/37949
SECUNIA 37949
http://www.ruby-lang.org/en/news/2010/01/10/webrick-escape-sequence-injection CONFIRM
http://www.vupen.com/english/advisories/2010/0089
VUPEN ADV-2010-0089
http://www.ush.it/team/ush/hack_httpd_escape/adv.txt
http://www.securityfocus.com/bid/37710
BID 37710 Ruby WEBrick Terminal Escape Sequence in Logs Command Injection Vulnerability Release Date:2013-07-30
http://www.securityfocus.com/archive/1/archive/1/508830/100/0/threaded
BUGTRAQ 20100110 Nginx, Varnish, Cherokee, thttpd, mini-httpd, WEBrick, Orion, AOLserver, Yaws and Boa log escape sequence injection
http://securitytracker.com/id?1023429
SECTRACK 1023429
http://www.redhat.com/support/errata/RHSA-2011-0908.html
REDHAT RHSA-2011:0908
http://www.redhat.com/support/errata/RHSA-2011-0909.html
REDHAT RHSA-2011:0909

- Metasploit Modules Related To CVE-2009-4492

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.