the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew  

Vulnerability Details : CVE-2009-2990

Array index error in Adobe Reader and Acrobat 9.x before 9.2, 8.x before 8.1.7, and possibly 7.x through 7.1.4 might allow attackers to execute arbitrary code via unspecified vectors.
Publish Date : 2009-10-19 Last Update Date : 2018-10-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 189

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat critical
AV:N/AC:M/Au:N/C:P/I:P/A:P 2009-10-13 2009-10-13
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @

- Related OVAL Definitions

Title Definition Id Class Family
Adobe Reader and Acrobat allow attackers to execute arbitrary code via unspecified vectors oval:org.mitre.oval:def:6371 windows
CVE-2009-2990 unix
ELSA-2009:1499: acroread security update (Critical) oval:org.mitre.oval:def:22955 unix
RHSA-2009:1499: acroread security update (Critical) oval:com.redhat.rhsa:def:20091499 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2009-2990

# Product Type Vendor Product Version Update Edition Language
1 Application Adobe Acrobat 7.0 Version Details Vulnerabilities
2 Application Adobe Acrobat 7.0.1 Version Details Vulnerabilities
3 Application Adobe Acrobat 7.0.2 Version Details Vulnerabilities
4 Application Adobe Acrobat 7.0.3 Version Details Vulnerabilities
5 Application Adobe Acrobat 7.0.4 Version Details Vulnerabilities
6 Application Adobe Acrobat 7.0.5 Version Details Vulnerabilities
7 Application Adobe Acrobat 7.0.6 Version Details Vulnerabilities
8 Application Adobe Acrobat 7.0.7 Version Details Vulnerabilities
9 Application Adobe Acrobat 7.0.8 Version Details Vulnerabilities
10 Application Adobe Acrobat 7.0.9 Version Details Vulnerabilities
11 Application Adobe Acrobat 7.1.0 Version Details Vulnerabilities
12 Application Adobe Acrobat 7.1.1 Version Details Vulnerabilities
13 Application Adobe Acrobat 7.1.3 Version Details Vulnerabilities
14 Application Adobe Acrobat 8.0 Version Details Vulnerabilities
15 Application Adobe Acrobat 8.1 Version Details Vulnerabilities
16 Application Adobe Acrobat 8.1.1 Version Details Vulnerabilities
17 Application Adobe Acrobat 8.1.2 Version Details Vulnerabilities
18 Application Adobe Acrobat 8.1.3 Version Details Vulnerabilities
19 Application Adobe Acrobat 8.1.4 Version Details Vulnerabilities
20 Application Adobe Acrobat 8.1.6 Version Details Vulnerabilities
21 Application Adobe Acrobat 9.0 Version Details Vulnerabilities
22 Application Adobe Acrobat 9.1.1 Version Details Vulnerabilities
23 Application Adobe Acrobat 9.1.2 Version Details Vulnerabilities
24 Application Adobe Acrobat 9.1.3 Version Details Vulnerabilities
25 Application Adobe Acrobat Reader 7.0 Version Details Vulnerabilities
26 Application Adobe Acrobat Reader 7.0.1 Version Details Vulnerabilities
27 Application Adobe Acrobat Reader 7.0.2 Version Details Vulnerabilities
28 Application Adobe Acrobat Reader 7.0.3 Version Details Vulnerabilities
29 Application Adobe Acrobat Reader 7.0.4 Version Details Vulnerabilities
30 Application Adobe Acrobat Reader 7.0.5 Version Details Vulnerabilities
31 Application Adobe Acrobat Reader 7.0.6 Version Details Vulnerabilities
32 Application Adobe Acrobat Reader 7.0.7 Version Details Vulnerabilities
33 Application Adobe Acrobat Reader 7.0.8 Version Details Vulnerabilities
34 Application Adobe Acrobat Reader 7.0.9 Version Details Vulnerabilities
35 Application Adobe Acrobat Reader 7.1.0 Version Details Vulnerabilities
36 Application Adobe Acrobat Reader 7.1.1 Version Details Vulnerabilities
37 Application Adobe Acrobat Reader 7.1.3 Version Details Vulnerabilities
38 Application Adobe Acrobat Reader 8.0 Version Details Vulnerabilities
39 Application Adobe Acrobat Reader 8.1 Version Details Vulnerabilities
40 Application Adobe Acrobat Reader 8.1.1 Version Details Vulnerabilities
41 Application Adobe Acrobat Reader 8.1.2 Version Details Vulnerabilities
42 Application Adobe Acrobat Reader 8.1.3 Version Details Vulnerabilities
43 Application Adobe Acrobat Reader 8.1.4 Version Details Vulnerabilities
44 Application Adobe Acrobat Reader 8.1.5 Version Details Vulnerabilities
45 Application Adobe Acrobat Reader 8.1.6 Version Details Vulnerabilities
46 Application Adobe Acrobat Reader 9.0 Version Details Vulnerabilities
47 Application Adobe Acrobat Reader 9.1 Version Details Vulnerabilities
48 Application Adobe Acrobat Reader 9.1.1 Version Details Vulnerabilities
49 Application Adobe Acrobat Reader 9.1.2 Version Details Vulnerabilities
50 Application Adobe Acrobat Reader 9.1.3 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Adobe Acrobat 24
Adobe Acrobat Reader 26

- References For CVE-2009-2990
BID 36638 RETIRED: Adobe Reader and Acrobat October 2009 Multiple Remote Vulnerabilities Release Date:2009-10-14
VUPEN ADV-2009-2898
SECTRACK 1023007

- Metasploit Modules Related To CVE-2009-2990

Adobe U3D CLODProgressiveMeshDeclaration Array Overrun
This module exploits an array overflow in Adobe Reader and Adobe Acrobat. Affected versions include < 7.1.4, < 8.1.7, and < 9.2. By creating a specially crafted pdf that a contains malformed U3D data, an attacker may be able to execute arbitrary code.
Module type : exploit Rank : good Platforms : Windows,Linux

CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.