CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2009-2503

GDI+ in Microsoft Internet Explorer 6 SP1, Windows XP SP2 and SP3, Windows Server 2003 SP2, Office XP SP3, Office 2003 SP3, 2007 Microsoft Office System SP1 and SP2, Office Project 2002 SP1, Visio 2002 SP2, Office Word Viewer, Word Viewer 2003 Gold and SP3, Office Excel Viewer 2003 Gold and SP3, Office Excel Viewer, Office PowerPoint Viewer 2007 Gold, SP1, and SP2, Office Compatibility Pack for Word, Excel, and PowerPoint 2007 File Formats SP1 and SP2, Expression Web, Expression Web 2, Groove 2007 Gold and SP1, Works 8.5, SQL Server 2000 Reporting Services SP2, SQL Server 2005 SP2 and SP3, Report Viewer 2005 SP1, Report Viewer 2008 Gold and SP1, and Forefront Client Security 1.0 does not properly allocate an unspecified buffer, which allows remote attackers to execute arbitrary code via a crafted TIFF image file that triggers memory corruption, aka "GDI+ TIFF Memory Corruption Vulnerability."
Publish Date : 2009-10-14 Last Update Date : 2017-09-18
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access Admin
Vulnerability Type(s) Execute CodeMemory corruption
CWE ID 94

- Related OVAL Definitions

Title Definition Id Class Family
GDI+ TIFF Buffer Overflow Vulnerability oval:org.mitre.oval:def:6491 windows
MS09-062: Vulnerabilities in GDI+ Could Allow Remote Code Execution (957488) oval:gov.nist.fdcc.patch:def:11595 windows
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2009-2503

# Product Type Vendor Product Version Update Edition Language
1 Application Microsoft .net Framework 1.1 SP1 Version Details Vulnerabilities
2 Application Microsoft .net Framework 2.0 SP1 Version Details Vulnerabilities
3 Application Microsoft .net Framework 2.0 SP2 Version Details Vulnerabilities
4 Application Microsoft Excel Viewer 2003 Version Details Vulnerabilities
5 Application Microsoft Excel Viewer 2003 SP3 Version Details Vulnerabilities
6 Application Microsoft Expression Web Version Details Vulnerabilities
7 Application Microsoft Expression Web 2 Version Details Vulnerabilities
8 Application Microsoft Forefront Client Security 1.0 Version Details Vulnerabilities
9 Application Microsoft Internet Explorer 6 SP1 Version Details Vulnerabilities
10 Application Microsoft Office XP Version Details Vulnerabilities
11 Application Microsoft Office 2003 SP3 Version Details Vulnerabilities
12 Application Microsoft Office 2007 SP1 Version Details Vulnerabilities
13 Application Microsoft Office 2007 SP2 Version Details Vulnerabilities
14 Application Microsoft Office Compatibility Pack 2007 SP1 Version Details Vulnerabilities
15 Application Microsoft Office Compatibility Pack 2007 SP2 Version Details Vulnerabilities
16 Application Microsoft Office Excel Viewer Version Details Vulnerabilities
17 Application Microsoft Office Groove 2007 SP1 Version Details Vulnerabilities
18 Application Microsoft Office Groove 2007 Version Details Vulnerabilities
19 Application Microsoft Office Powerpoint Viewer Version Details Vulnerabilities
20 Application Microsoft Office Powerpoint Viewer 2007 SP1 Version Details Vulnerabilities
21 Application Microsoft Office Powerpoint Viewer 2007 SP2 Version Details Vulnerabilities
22 Application Microsoft Office Word Viewer Version Details Vulnerabilities
23 Application Microsoft Platform Sdk Redistrutable Gdi+ Version Details Vulnerabilities
24 Application Microsoft Project 2002 SP1 Version Details Vulnerabilities
25 Application Microsoft Report Viewer 2005 SP1 Redistributable Package Version Details Vulnerabilities
26 Application Microsoft Report Viewer 2008 Redistributable Package Version Details Vulnerabilities
27 Application Microsoft Report Viewer 2008 SP1 Redistributable Package Version Details Vulnerabilities
28 Application Microsoft Sql Server 2005 SP2 X64 Version Details Vulnerabilities
29 Application Microsoft Sql Server 2005 SP3 X64 Version Details Vulnerabilities
30 Application Microsoft Sql Server 2005 SP3 Version Details Vulnerabilities
31 Application Microsoft Sql Server 2005 SP2 Itanium Version Details Vulnerabilities
32 Application Microsoft Sql Server 2005 SP3 Itanium Version Details Vulnerabilities
33 Application Microsoft Sql Server 2005 SP2 Version Details Vulnerabilities
34 Application Microsoft Sql Server Reporting Services 2000 SP2 Version Details Vulnerabilities
35 Application Microsoft Visio 2002 SP2 Version Details Vulnerabilities
36 Application Microsoft Visual Foxpro 8.0 SP1 Version Details Vulnerabilities
37 Application Microsoft Visual Foxpro 9.0 SP2 Version Details Vulnerabilities
38 Application Microsoft Visual Studio 2008 Version Details Vulnerabilities
39 Application Microsoft Visual Studio 2008 SP1 Version Details Vulnerabilities
40 Application Microsoft Visual Studio .net 2003 SP1 Version Details Vulnerabilities
41 Application Microsoft Visual Studio .net 2005 SP1 Version Details Vulnerabilities
42 OS Microsoft Windows 2003 Server SP2 Version Details Vulnerabilities
43 OS Microsoft Windows 2003 Server SP2 X64 Version Details Vulnerabilities
44 OS Microsoft Windows 2003 Server SP2 Itanium Version Details Vulnerabilities
45 OS Microsoft Windows Server 2008 X32 Version Details Vulnerabilities
46 OS Microsoft Windows Server 2008 X64 Version Details Vulnerabilities
47 OS Microsoft Windows Server 2008 Itanium Version Details Vulnerabilities
48 OS Microsoft Windows Vista SP1 X64 Version Details Vulnerabilities
49 OS Microsoft Windows Vista Version Details Vulnerabilities
50 OS Microsoft Windows Vista SP1 Version Details Vulnerabilities
51 OS Microsoft Windows Vista X64 Version Details Vulnerabilities
52 OS Microsoft Windows Xp SP2 Professional X64 Version Details Vulnerabilities
53 OS Microsoft Windows Xp SP2 Version Details Vulnerabilities
54 OS Microsoft Windows Xp SP3 Version Details Vulnerabilities
55 Application Microsoft Word Viewer 2003 SP3 Version Details Vulnerabilities
56 Application Microsoft Word Viewer 2003 Version Details Vulnerabilities
57 Application Microsoft Works 8.5 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Microsoft .net Framework 3
Microsoft Excel Viewer 2
Microsoft Expression Web 2
Microsoft Forefront Client Security 1
Microsoft Internet Explorer 1
Microsoft Office 4
Microsoft Office Compatibility Pack 2
Microsoft Office Excel Viewer 1
Microsoft Office Groove 2
Microsoft Office Powerpoint Viewer 3
Microsoft Office Word Viewer 1
Microsoft Platform Sdk 1
Microsoft Project 1
Microsoft Report Viewer 3
Microsoft Sql Server 6
Microsoft Sql Server Reporting Services 1
Microsoft Visio 1
Microsoft Visual Foxpro 2
Microsoft Visual Studio 2
Microsoft Visual Studio .net 2
Microsoft Windows 2003 Server 3
Microsoft Windows Server 2008 3
Microsoft Windows Vista 4
Microsoft Windows Xp 3
Microsoft Word Viewer 2
Microsoft Works 1

- References For CVE-2009-2503

http://www.us-cert.gov/cas/techalerts/TA09-286A.html
CERT TA09-286A
http://technet.microsoft.com/en-us/security/bulletin/ms09-062
Microsoft Security Bulletin MS09-062 Vulnerabilities in GDI+ Could Allow Remote Code Execution (957488) This security update resolves several privately reported vulnerabilities in Microsoft Windows GDI+. These vulnerabilities could allow remote code execution if a user viewed a specially crafted image file using affected software or browsed a Web site that contains specially crafted content. Users whose accounts are configured to have fewer user rights on the system could be less impacted than users who operate with administrative user rights.

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2009-2503

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.