CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2009-0839

Stack-based buffer overflow in mapserv.c in mapserv in MapServer 4.x before 4.10.4 and 5.x before 5.2.2, when the server has a map with a long IMAGEPATH or NAME attribute, allows remote attackers to execute arbitrary code via a crafted id parameter in a query action.
Publish Date : 2009-03-31 Last Update Date : 2018-10-10
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute CodeOverflow
CWE ID 119

- Related OVAL Definitions

Title Definition Id Class Family
DSA-1914 mapserver -- several vulnerabilities oval:org.mitre.oval:def:7870 unix
DSA-1914-1 mapserver -- several oval:org.mitre.oval:def:13568 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2009-0839

# Product Type Vendor Product Version Update Edition Language
1 Application UMN Mapserver 4.0 Version Details Vulnerabilities
2 Application UMN Mapserver 4.0 Beta1 Version Details Vulnerabilities
3 Application UMN Mapserver 4.0 Beta2 Version Details Vulnerabilities
4 Application UMN Mapserver 4.2 Beta1 Version Details Vulnerabilities
5 Application UMN Mapserver 4.4.0 Beta1 Version Details Vulnerabilities
6 Application UMN Mapserver 4.4.0 Beta2 Version Details Vulnerabilities
7 Application UMN Mapserver 4.4.0 Beta3 Version Details Vulnerabilities
8 Application UMN Mapserver 4.4.0 Version Details Vulnerabilities
9 Application UMN Mapserver 4.6.0 Beta3 Version Details Vulnerabilities
10 Application UMN Mapserver 4.6.0 RC1 Version Details Vulnerabilities
11 Application UMN Mapserver 4.6.0 Version Details Vulnerabilities
12 Application UMN Mapserver 4.6.0 Beta1 Version Details Vulnerabilities
13 Application UMN Mapserver 4.6.0 Beta2 Version Details Vulnerabilities
14 Application UMN Mapserver 4.8 RC2 Version Details Vulnerabilities
15 Application UMN Mapserver 4.8 Beta1 Version Details Vulnerabilities
16 Application UMN Mapserver 4.8 Beta2 Version Details Vulnerabilities
17 Application UMN Mapserver 4.8 Beta3 Version Details Vulnerabilities
18 Application UMN Mapserver 4.8 RC1 Version Details Vulnerabilities
19 Application UMN Mapserver 4.10 Beta1 Version Details Vulnerabilities
20 Application UMN Mapserver 4.10 Beta2 Version Details Vulnerabilities
21 Application UMN Mapserver 4.10 Beta3 Version Details Vulnerabilities
22 Application UMN Mapserver 4.10 RC1 Version Details Vulnerabilities
23 Application UMN Mapserver 4.10.0 Version Details Vulnerabilities
24 Application UMN Mapserver 4.10.1 Version Details Vulnerabilities
25 Application UMN Mapserver 4.10.2 Version Details Vulnerabilities
26 Application UMN Mapserver 4.10.3 Version Details Vulnerabilities
27 Application UMN Mapserver 5.0.0 Beta1 Version Details Vulnerabilities
28 Application UMN Mapserver 5.0.0 RC1 Version Details Vulnerabilities
29 Application UMN Mapserver 5.0.0 Beta2 Version Details Vulnerabilities
30 Application UMN Mapserver 5.0.0 RC2 Version Details Vulnerabilities
31 Application UMN Mapserver 5.0.0 Beta3 Version Details Vulnerabilities
32 Application UMN Mapserver 5.0.0 Beta4 Version Details Vulnerabilities
33 Application UMN Mapserver 5.0.0 Beta5 Version Details Vulnerabilities
34 Application UMN Mapserver 5.0.0 Version Details Vulnerabilities
35 Application UMN Mapserver 5.0.0 Beta6 Version Details Vulnerabilities
36 Application UMN Mapserver 5.2.0 Beta3 Version Details Vulnerabilities
37 Application UMN Mapserver 5.2.0 Beta4 Version Details Vulnerabilities
38 Application UMN Mapserver 5.2.0 RC1 Version Details Vulnerabilities
39 Application UMN Mapserver 5.2.0 Version Details Vulnerabilities
40 Application UMN Mapserver 5.2.0 Beta1 Version Details Vulnerabilities
41 Application UMN Mapserver 5.2.0 Beta2 Version Details Vulnerabilities
42 Application UMN Mapserver 5.2.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
UMN Mapserver 42

- References For CVE-2009-0839

https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00170.html
FEDORA FEDORA-2009-3383
https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00147.html
FEDORA FEDORA-2009-3357
http://www.securitytracker.com/id?1021952
SECTRACK 1021952
http://www.debian.org/security/2009/dsa-1914
DEBIAN DSA-1914
http://www.positronsecurity.com/advisories/2009-000.html
http://trac.osgeo.org/mapserver/ticket/2944 CONFIRM
http://www.securityfocus.com/bid/34306
BID 34306 MapServer Multiple Security Vulnerabilities Release Date:2009-10-23
http://www.securityfocus.com/archive/1/502271/100/0/threaded
BUGTRAQ 20090330 Positron Security Advisory #2009-000: Multiple Vulnerabilities in MapServer v5.2.1 and v4.10.3
http://lists.osgeo.org/pipermail/mapserver-users/2009-March/060600.html
MLIST [mapserver-users] 20090326 MapServer 5.2.2 and 4.10.4 released with security fixes

- Metasploit Modules Related To CVE-2009-0839

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.