CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-5498

Array index error in the imageRotate function in PHP 5.2.8 and earlier allows context-dependent attackers to read the contents of arbitrary memory locations via a crafted value of the third argument (aka the bgd_color or clrBack argument) for an indexed image.
Publish Date : 2008-12-26 Last Update Date : 2017-09-28
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Obtain Information
CWE ID 200

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low 2008-12-24 2008-12-24
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
Array index error in the imageRotate function in PHP 5.2.8 and earlier allows context-dependent attackers to read the co... oval:org.mitre.oval:def:9667 unix
CVE-2008-5498 oval:org.opensuse.security:def:20085498 unix
ELSA-2009:0338: php security update (Moderate) oval:org.mitre.oval:def:22732 unix
RHSA-2009:0337: php security update (Moderate) oval:com.redhat.rhsa:def:20090337 unix
RHSA-2009:0338 -- php security update (Moderate) oval:org.mitre.oval:def:29345 unix
RHSA-2009:0338: php security update (Moderate) oval:com.redhat.rhsa:def:20090338 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-5498

# Product Type Vendor Product Version Update Edition Language
1 Application PHP PHP 5 Version Details Vulnerabilities
2 Application PHP PHP 5.0 RC1 Version Details Vulnerabilities
3 Application PHP PHP 5.0 RC2 Version Details Vulnerabilities
4 Application PHP PHP 5.0 RC3 Version Details Vulnerabilities
5 Application PHP PHP 5.0.0 Beta4 Version Details Vulnerabilities
6 Application PHP PHP 5.0.0 RC3 Version Details Vulnerabilities
7 Application PHP PHP 5.0.0 Beta3 Version Details Vulnerabilities
8 Application PHP PHP 5.0.0 Beta2 Version Details Vulnerabilities
9 Application PHP PHP 5.0.0 Version Details Vulnerabilities
10 Application PHP PHP 5.0.0 RC2 Version Details Vulnerabilities
11 Application PHP PHP 5.0.0 Beta1 Version Details Vulnerabilities
12 Application PHP PHP 5.0.0 RC1 Version Details Vulnerabilities
13 Application PHP PHP 5.0.1 Version Details Vulnerabilities
14 Application PHP PHP 5.0.2 Version Details Vulnerabilities
15 Application PHP PHP 5.0.3 Version Details Vulnerabilities
16 Application PHP PHP 5.0.4 Version Details Vulnerabilities
17 Application PHP PHP 5.0.5 Version Details Vulnerabilities
18 Application PHP PHP 5.1 Version Details Vulnerabilities
19 Application PHP PHP 5.1.0 Version Details Vulnerabilities
20 Application PHP PHP 5.1.1 Version Details Vulnerabilities
21 Application PHP PHP 5.1.2 Version Details Vulnerabilities
22 Application PHP PHP 5.1.3 Version Details Vulnerabilities
23 Application PHP PHP 5.1.4 Version Details Vulnerabilities
24 Application PHP PHP 5.1.5 Version Details Vulnerabilities
25 Application PHP PHP 5.1.6 Version Details Vulnerabilities
26 Application PHP PHP 5.2.0 Version Details Vulnerabilities
27 Application PHP PHP 5.2.1 Version Details Vulnerabilities
28 Application PHP PHP 5.2.2 Version Details Vulnerabilities
29 Application PHP PHP 5.2.3 Version Details Vulnerabilities
30 Application PHP PHP 5.2.4 Version Details Vulnerabilities
31 Application PHP PHP 5.2.5 Version Details Vulnerabilities
32 Application PHP PHP 5.2.6 Version Details Vulnerabilities
33 Application PHP PHP 5.2.7 Version Details Vulnerabilities
34 Application PHP PHP 5.2.8 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
PHP PHP 34

- References For CVE-2008-5498

https://www.redhat.com/archives/fedora-package-announce/2009-May/msg01465.html
FEDORA FEDORA-2009-3848
https://www.redhat.com/archives/fedora-package-announce/2009-May/msg01451.html
FEDORA FEDORA-2009-3768
http://www.php.net/releases/5_2_9.php CONFIRM
http://www.securityfocus.com/bid/33002
BID 33002 PHP 'imageRotate()' Uninitialized Memory Information Disclosure Vulnerability Release Date:2010-01-06
https://exchange.xforce.ibmcloud.com/vulnerabilities/47635
XF php-imagerotate-info-disclosure(47635)
http://www.redhat.com/support/errata/RHSA-2009-0350.html
REDHAT RHSA-2009:0350
http://www.mandriva.com/security/advisories?name=MDVSA-2009:023
MANDRIVA MDVSA-2009:023
http://www.mandriva.com/security/advisories?name=MDVSA-2009:022
MANDRIVA MDVSA-2009:022
http://www.mandriva.com/security/advisories?name=MDVSA-2009:021
MANDRIVA MDVSA-2009:021
http://support.apple.com/kb/HT3865 CONFIRM
http://securitytracker.com/id?1021494
SECTRACK 1021494
http://marc.info/?l=bugtraq&m=125631037611762&w=2
HP SSRT090192
http://marc.info/?l=bugtraq&m=124654546101607&w=2
HP SSRT090085
http://downloads.securityfocus.com/vulnerabilities/exploits/33002.php
http://lists.apple.com/archives/security-announce/2009/Sep/msg00004.html
APPLE APPLE-SA-2009-09-10-2
http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00003.html
SUSE SUSE-SR:2009:008
http://cvs.php.net/viewvc.cgi/php-src/NEWS?r1=1.2027.2.547.2.1360&r2=1.2027.2.547.2.1361&diff_format=u CONFIRM
http://downloads.securityfocus.com/vulnerabilities/exploits/33002-2.php

- Metasploit Modules Related To CVE-2008-5498

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.