CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-5090

Electron Inc. Advanced Electron Forum before 1.0.7 allows remote attackers to execute arbitrary PHP code via PHP code embedded in bbcode in the email parameter, which is processed by the preg_replace function with the eval switch.
Publish Date : 2008-11-14 Last Update Date : 2018-10-11
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 94

- Products Affected By CVE-2008-5090

# Product Type Vendor Product Version Update Edition Language
1 Application Anelectron Advanced Electron Forum 1.0.1 Version Details Vulnerabilities
2 Application Anelectron Advanced Electron Forum 1.0.2 Version Details Vulnerabilities
3 Application Anelectron Advanced Electron Forum 1.0.3 Version Details Vulnerabilities
4 Application Anelectron Advanced Electron Forum 1.0.4 Version Details Vulnerabilities
5 Application Anelectron Advanced Electron Forum 1.0.5 Version Details Vulnerabilities
6 Application Anelectron Advanced Electron Forum 1.0.6 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Anelectron Advanced Electron Forum 6

- References For CVE-2008-5090

https://www.exploit-db.com/exploits/6499
EXPLOIT-DB 6499
https://exchange.xforce.ibmcloud.com/vulnerabilities/45270
XF aef-pregreplace-code-execution(45270)
http://www.securityfocus.com/bid/31268
BID 31268 Advanced Electron Forum BBCode 'preg_replace' PHP Code Injection Vulnerabilities Release Date:2008-09-22
http://www.gulftech.org/?node=research&article_id=00131-09202008
http://www.securityfocus.com/archive/1/496552/100/0/threaded
BUGTRAQ 20080920 Advanced Electron Forum <= 1.0.6 Remote Code Execution
http://www.anelectron.com/board/index.php?tid=3282 CONFIRM
http://securityreason.com/securityalert/4598
SREASON 4598

- Metasploit Modules Related To CVE-2008-5090

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.