CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-5022

The nsXMLHttpRequest::NotifyEventListeners method in Firefox 3.x before 3.0.4, Firefox 2.x before 2.0.0.18, Thunderbird 2.x before 2.0.0.18, and SeaMonkey 1.x before 1.1.13 allows remote attackers to bypass the same-origin policy and execute arbitrary script via multiple listeners, which bypass the inner window check.
Publish Date : 2008-11-13 Last Update Date : 2018-11-02
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Bypass a restriction or similar
CWE ID 287

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2008-11-10 2008-11-12
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2008-5022 oval:org.opensuse.security:def:20085022 unix
DSA-1669 xulrunner -- several vulnerabilities oval:org.mitre.oval:def:7740 unix
DSA-1669-1 xulrunner - several vulnerabilities oval:org.mitre.oval:def:19874 unix
DSA-1671 iceweasel -- several vulnerabilities oval:org.mitre.oval:def:8140 unix
DSA-1671-1 iceweasel - several vulnerabilities oval:org.mitre.oval:def:20161 unix
DSA-1696 icedove -- several vulnerabilities oval:org.mitre.oval:def:8021 unix
DSA-1696-1 icedove -- several vulnerabilities oval:org.mitre.oval:def:12973 unix
DSA-1697 iceape -- several vulnerabilities oval:org.mitre.oval:def:7950 unix
DSA-1697-1 iceape -- several vulnerabilities oval:org.mitre.oval:def:13245 unix
ELSA-2008:0976: thunderbird security update (Moderate) oval:org.mitre.oval:def:22044 unix
ELSA-2008:0978: firefox security update (Critical) oval:org.mitre.oval:def:22309 unix
RHSA-2008:0976 -- thunderbird security update (Moderate) oval:org.mitre.oval:def:29116 unix
RHSA-2008:0976: thunderbird security update (Moderate) oval:com.redhat.rhsa:def:20080976 unix
RHSA-2008:0977: seamonkey security update (Critical) oval:com.redhat.rhsa:def:20080977 unix
RHSA-2008:0978 -- firefox security update (Critical) oval:org.mitre.oval:def:29237 unix
RHSA-2008:0978: firefox security update (Critical) oval:com.redhat.rhsa:def:20080978 unix
The nsXMLHttpRequest::NotifyEventListeners method in Firefox 3.x before 3.0.4, Firefox 2.x before 2.0.0.18, Thunderbird ... oval:org.mitre.oval:def:11186 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-5022

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 6.06 ~~lts~~~ Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 7.10 Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 8.04 ~~lts~~~ Version Details Vulnerabilities
4 OS Canonical Ubuntu Linux 8.10 Version Details Vulnerabilities
5 OS Debian Debian Linux 4.0 Version Details Vulnerabilities
6 Application Mozilla Firefox 2.0 Version Details Vulnerabilities
7 Application Mozilla Firefox 2.0.0.1 Version Details Vulnerabilities
8 Application Mozilla Firefox 2.0.0.2 Version Details Vulnerabilities
9 Application Mozilla Firefox 2.0.0.3 Version Details Vulnerabilities
10 Application Mozilla Firefox 2.0.0.4 Version Details Vulnerabilities
11 Application Mozilla Firefox 2.0.0.5 Version Details Vulnerabilities
12 Application Mozilla Firefox 2.0.0.6 Version Details Vulnerabilities
13 Application Mozilla Firefox 2.0.0.7 Version Details Vulnerabilities
14 Application Mozilla Firefox 2.0.0.8 Version Details Vulnerabilities
15 Application Mozilla Firefox 2.0.0.9 Version Details Vulnerabilities
16 Application Mozilla Firefox 2.0.0.10 Version Details Vulnerabilities
17 Application Mozilla Firefox 2.0.0.11 Version Details Vulnerabilities
18 Application Mozilla Firefox 2.0.0.12 Version Details Vulnerabilities
19 Application Mozilla Firefox 2.0.0.13 Version Details Vulnerabilities
20 Application Mozilla Firefox 2.0.0.14 Version Details Vulnerabilities
21 Application Mozilla Firefox 2.0.0.15 Version Details Vulnerabilities
22 Application Mozilla Firefox 2.0.0.16 Version Details Vulnerabilities
23 Application Mozilla Firefox 2.0.0.17 Version Details Vulnerabilities
24 Application Mozilla Firefox 3.0 Version Details Vulnerabilities
25 Application Mozilla Firefox 3.0.1 Version Details Vulnerabilities
26 Application Mozilla Firefox 3.0.2 Version Details Vulnerabilities
27 Application Mozilla Firefox 3.0.3 Version Details Vulnerabilities
28 Application Mozilla Seamonkey 1.0 Beta Version Details Vulnerabilities
29 Application Mozilla Seamonkey 1.0 Version Details Vulnerabilities
30 Application Mozilla Seamonkey 1.0 Alpha Version Details Vulnerabilities
31 Application Mozilla Seamonkey 1.0.1 Version Details Vulnerabilities
32 Application Mozilla Seamonkey 1.0.2 Version Details Vulnerabilities
33 Application Mozilla Seamonkey 1.0.3 Version Details Vulnerabilities
34 Application Mozilla Seamonkey 1.0.4 Version Details Vulnerabilities
35 Application Mozilla Seamonkey 1.0.5 Version Details Vulnerabilities
36 Application Mozilla Seamonkey 1.0.6 Version Details Vulnerabilities
37 Application Mozilla Seamonkey 1.0.7 Version Details Vulnerabilities
38 Application Mozilla Seamonkey 1.0.8 Version Details Vulnerabilities
39 Application Mozilla Seamonkey 1.0.9 Version Details Vulnerabilities
40 Application Mozilla Seamonkey 1.1 Alpha Version Details Vulnerabilities
41 Application Mozilla Seamonkey 1.1 Beta Version Details Vulnerabilities
42 Application Mozilla Seamonkey 1.1 Alpha Version Details Vulnerabilities
43 Application Mozilla Seamonkey 1.1 Beta Version Details Vulnerabilities
44 Application Mozilla Seamonkey 1.1 Version Details Vulnerabilities
45 Application Mozilla Seamonkey 1.1.1 Version Details Vulnerabilities
46 Application Mozilla Seamonkey 1.1.2 Version Details Vulnerabilities
47 Application Mozilla Seamonkey 1.1.3 Version Details Vulnerabilities
48 Application Mozilla Seamonkey 1.1.4 Version Details Vulnerabilities
49 Application Mozilla Seamonkey 1.1.5 Version Details Vulnerabilities
50 Application Mozilla Seamonkey 1.1.6 Version Details Vulnerabilities
51 Application Mozilla Seamonkey 1.1.7 Version Details Vulnerabilities
52 Application Mozilla Seamonkey 1.1.8 Version Details Vulnerabilities
53 Application Mozilla Seamonkey 1.1.9 Version Details Vulnerabilities
54 Application Mozilla Seamonkey 1.1.10 Version Details Vulnerabilities
55 Application Mozilla Seamonkey 1.1.11 Version Details Vulnerabilities
56 Application Mozilla Seamonkey 1.1.12 Version Details Vulnerabilities
57 Application Mozilla Thunderbird 2.0 Version Details Vulnerabilities
58 Application Mozilla Thunderbird 2.0.0.0 Version Details Vulnerabilities
59 Application Mozilla Thunderbird 2.0.0.1 Version Details Vulnerabilities
60 Application Mozilla Thunderbird 2.0.0.2 Version Details Vulnerabilities
61 Application Mozilla Thunderbird 2.0.0.3 Version Details Vulnerabilities
62 Application Mozilla Thunderbird 2.0.0.4 Version Details Vulnerabilities
63 Application Mozilla Thunderbird 2.0.0.5 Version Details Vulnerabilities
64 Application Mozilla Thunderbird 2.0.0.6 Version Details Vulnerabilities
65 Application Mozilla Thunderbird 2.0.0.7 Version Details Vulnerabilities
66 Application Mozilla Thunderbird 2.0.0.8 Version Details Vulnerabilities
67 Application Mozilla Thunderbird 2.0.0.9 Version Details Vulnerabilities
68 Application Mozilla Thunderbird 2.0.0.11 Version Details Vulnerabilities
69 Application Mozilla Thunderbird 2.0.0.12 Version Details Vulnerabilities
70 Application Mozilla Thunderbird 2.0.0.13 Version Details Vulnerabilities
71 Application Mozilla Thunderbird 2.0.0.14 Version Details Vulnerabilities
72 Application Mozilla Thunderbird 2.0.0.15 Version Details Vulnerabilities
73 Application Mozilla Thunderbird 2.0.0.16 Version Details Vulnerabilities
74 Application Mozilla Thunderbird 2.0.0.17 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 4
Debian Debian Linux 1
Mozilla Firefox 22
Mozilla Seamonkey 29
Mozilla Thunderbird 18

- References For CVE-2008-5022

https://www.redhat.com/archives/fedora-package-announce/2008-November/msg00385.html
FEDORA FEDORA-2008-9669
https://www.redhat.com/archives/fedora-package-announce/2008-November/msg00366.html
FEDORA FEDORA-2008-9667
https://bugzilla.mozilla.org/show_bug.cgi?id=460002
http://www.vupen.com/english/advisories/2009/0977
VUPEN ADV-2009-0977
http://www.vupen.com/english/advisories/2008/3146
VUPEN ADV-2008-3146
http://www.us-cert.gov/cas/techalerts/TA08-319A.html
CERT TA08-319A
http://www.redhat.com/support/errata/RHSA-2008-0976.html
REDHAT RHSA-2008:0976
http://www.securityfocus.com/bid/32281
BID 32281 Mozilla Firefox/Thunderbird/SeaMonkey Multiple Remote Vulnerabilities Release Date:2014-09-23
http://www.securitytracker.com/id?1021188
SECTRACK 1021188
http://www.mandriva.com/security/advisories?name=MDVSA-2008:230
MANDRIVA MDVSA-2008:230
http://www.mandriva.com/security/advisories?name=MDVSA-2008:235
MANDRIVA MDVSA-2008:235
http://www.mozilla.org/security/announce/2008/mfsa2008-56.html CONFIRM
http://www.redhat.com/support/errata/RHSA-2008-0977.html
REDHAT RHSA-2008:0977
http://www.debian.org/security/2009/dsa-1697
DEBIAN DSA-1697
http://www.mandriva.com/security/advisories?name=MDVSA-2008:228
MANDRIVA MDVSA-2008:228
http://www.debian.org/security/2008/dsa-1671
DEBIAN DSA-1671
http://www.debian.org/security/2009/dsa-1696
DEBIAN DSA-1696
http://sunsolve.sun.com/search/document.do?assetkey=1-26-256408-1
SUNALERT 256408
http://ubuntu.com/usn/usn-667-1
UBUNTU USN-667-1
http://lists.opensuse.org/opensuse-security-announce/2008-11/msg00004.html
SUSE SUSE-SA:2008:055
http://www.redhat.com/support/errata/RHSA-2008-0978.html
REDHAT RHSA-2008:0978
http://www.debian.org/security/2008/dsa-1669
DEBIAN DSA-1669

- Metasploit Modules Related To CVE-2008-5022

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.