CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-3014

Buffer overflow in gdiplus.dll in GDI+ in Microsoft Internet Explorer 6 SP1, Windows XP SP2 and SP3, Server 2003 SP1 and SP2, Vista Gold and SP1, Server 2008, Office XP SP3, Office 2003 SP2 and SP3, 2007 Microsoft Office System Gold and SP1, Visio 2002 SP2, PowerPoint Viewer 2003, Works 8, Digital Image Suite 2006, SQL Server 2000 Reporting Services SP2, SQL Server 2005 SP2, Report Viewer 2005 SP1 and 2008, and Forefront Client Security 1.0 allows remote attackers to execute arbitrary code via a malformed WMF image file that triggers improper memory allocation, aka "GDI+ WMF Buffer Overrun Vulnerability."
Publish Date : 2008-09-10 Last Update Date : 2018-10-12
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access Admin
Vulnerability Type(s) Execute CodeOverflow
CWE ID 119

- Related OVAL Definitions

Title Definition Id Class Family
GDI+ WMF Buffer Overrun Vulnerability oval:org.mitre.oval:def:6004 windows
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-3014

# Product Type Vendor Product Version Update Edition Language
1 Application Microsoft Digital Image Suite 2006 Version Details Vulnerabilities
2 Application Microsoft Forefront Client Security 1.0 Version Details Vulnerabilities
3 Application Microsoft Internet Explorer 6 SP1 Version Details Vulnerabilities
4 Application Microsoft Office XP SP3 Version Details Vulnerabilities
5 Application Microsoft Office 2003 SP2 Version Details Vulnerabilities
6 Application Microsoft Office 2003 SP3 Version Details Vulnerabilities
7 Application Microsoft Office 2007 Gold Version Details Vulnerabilities
8 Application Microsoft Office 2007 SP1 Version Details Vulnerabilities
9 Application Microsoft Office Powerpoint Viewer 2003 Version Details Vulnerabilities
10 Application Microsoft Report Viewer 2005 SP1 Version Details Vulnerabilities
11 Application Microsoft Report Viewer 2008 Version Details Vulnerabilities
12 OS Microsoft Server 2003 SP2 Version Details Vulnerabilities
13 OS Microsoft Server 2003 SP1 Version Details Vulnerabilities
14 Application Microsoft Server 2008 Version Details Vulnerabilities
15 Application Microsoft Sql Server 2005 SP2 Version Details Vulnerabilities
16 Application Microsoft Sql Server Reporting Services 2000 SP2 Version Details Vulnerabilities
17 Application Microsoft Visio 2002 SP2 Version Details Vulnerabilities
18 OS Microsoft Windows-nt XP SP2 Version Details Vulnerabilities
19 OS Microsoft Windows-nt XP SP3 Version Details Vulnerabilities
20 OS Microsoft Windows-nt Vista Gold Version Details Vulnerabilities
21 OS Microsoft Windows-nt Vista SP1 Version Details Vulnerabilities
22 Application Microsoft Works 8.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Microsoft Digital Image Suite 1
Microsoft Forefront Client Security 1
Microsoft Internet Explorer 1
Microsoft Office 5
Microsoft Office Powerpoint Viewer 1
Microsoft Report Viewer 2
Microsoft Server 2
Microsoft Server 1
Microsoft Sql Server 1
Microsoft Sql Server Reporting Services 1
Microsoft Visio 1
Microsoft Windows-nt 4
Microsoft Works 1

- References For CVE-2008-3014

https://docs.microsoft.com/en-us/security-updates/securitybulletins/2008/ms08-052
MS MS08-052
http://www.vupen.com/english/advisories/2008/2696
VUPEN ADV-2008-2696
http://www.vupen.com/english/advisories/2008/2520
VUPEN ADV-2008-2520
http://www.securitytracker.com/id?1020837
SECTRACK 1020837
http://www.us-cert.gov/cas/techalerts/TA08-253A.html
CERT TA08-253A
http://marc.info/?l=bugtraq&m=122235754013992&w=2
HP HPSBST02372
http://www.securityfocus.com/bid/31021
BID 31021 Microsoft GDI+ WMF Image File Buffer Overflow Vulnerability Release Date:2009-04-01

- Metasploit Modules Related To CVE-2008-3014

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.