CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-2829

php_imap.c in PHP 5.2.5, 5.2.6, 4.x, and other versions, uses obsolete API calls that allow context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long IMAP request, which triggers an "rfc822.c legacy routine buffer overflow" error message, related to the rfc822_write_address function.
Publish Date : 2008-06-23 Last Update Date : 2018-10-11
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceExecute CodeOverflow
CWE ID 119

- Vendor Statements

Not vulnerable. This issue did not affect the versions of PHP as shipped with Red Hat Enterprise Linux 2.1, 3, 4, or 5. For more details see: https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2008-2829
Source: Redhat

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2008-2829 oval:org.opensuse.security:def:20082829 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-2829

# Product Type Vendor Product Version Update Edition Language
1 Application PHP PHP 4.0 Version Details Vulnerabilities
2 Application PHP PHP 5.2.5 Version Details Vulnerabilities
3 Application PHP PHP 5.2.6 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
PHP PHP 3

- References For CVE-2008-2829

https://www.redhat.com/archives/fedora-package-announce/2009-May/msg01465.html
FEDORA FEDORA-2009-3848
https://www.redhat.com/archives/fedora-package-announce/2009-May/msg01451.html
FEDORA FEDORA-2009-3768
http://www.us-cert.gov/cas/techalerts/TA09-133A.html
CERT TA09-133A
http://www.vupen.com/english/advisories/2009/1297
VUPEN ADV-2009-1297
https://bugs.gentoo.org/show_bug.cgi?id=221969 CONFIRM
https://exchange.xforce.ibmcloud.com/vulnerabilities/43357
XF php-phpimap-dos(43357)
http://www.ubuntu.com/usn/usn-628-1
UBUNTU USN-628-1
http://www.openwall.com/lists/oss-security/2008/06/19/6
MLIST [oss-security] 20080619 CVE request: php 5.2.6 ext/imap buffer overflows
http://www.openwall.com/lists/oss-security/2008/06/24/2
MLIST [oss-security] 20080624 Re: CVE request: php 5.2.6 ext/imap buffer overflows
http://marc.info/?l=bugtraq&m=125631037611762&w=2
HP HPSBUX02465
http://security.gentoo.org/glsa/glsa-200811-05.xml
GENTOO GLSA-200811-05
http://support.apple.com/kb/HT3549 CONFIRM
http://wiki.rpath.com/Advisories:rPSA-2009-0035 CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2008:126
MANDRIVA MDVSA-2008:126
http://www.mandriva.com/security/advisories?name=MDVSA-2008:127
MANDRIVA MDVSA-2008:127
http://www.mandriva.com/security/advisories?name=MDVSA-2008:128
MANDRIVA MDVSA-2008:128
http://www.securityfocus.com/archive/1/501376/100/0/threaded
BUGTRAQ 20090302 rPSA-2009-0035-1 php php-cgi php-imap php-mcrypt php-mysql php-mysqli php-pgsql php-soap php-xsl php5 php5-cgi php5-imap php5-mcrypt php5-mysql php5-mysqli php5-pear php5-pgsql php5-soap php5-xsl
http://www.securityfocus.com/bid/29829
BID 29829 PHP 'rfc822_write_address()' Function Buffer Overflow Vulnerability Release Date:2009-10-22
http://marc.info/?l=bugtraq&m=124654546101607&w=2
HP HPSBUX02431
http://lists.opensuse.org/opensuse-security-announce/2008-12/msg00002.html
SUSE SUSE-SR:2008:027
http://bugs.php.net/bug.php?id=42862
http://lists.apple.com/archives/security-announce/2009/May/msg00002.html
APPLE APPLE-SA-2009-05-12

- Metasploit Modules Related To CVE-2008-2829

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.