CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-2380

SQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin locale Postgres database is used, allows remote attackers to execute arbitrary SQL commands via query parameters containing apostrophes.
Publish Date : 2008-12-22 Last Update Date : 2017-08-07
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.1
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Execute CodeSql Injection
CWE ID 89

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2008-2380 oval:org.opensuse.security:def:20082380 unix
DSA-1688 courier-authlib -- SQL injection oval:org.mitre.oval:def:8347 unix
DSA-1688-1 courier-authlib - SQL injection oval:org.mitre.oval:def:18407 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-2380

# Product Type Vendor Product Version Update Edition Language
1 Application Courier-mta Courtier-authlib 0.52 Version Details Vulnerabilities
2 Application Courier-mta Courtier-authlib 0.53 Version Details Vulnerabilities
3 Application Courier-mta Courtier-authlib 0.54 Version Details Vulnerabilities
4 Application Courier-mta Courtier-authlib 0.55 Version Details Vulnerabilities
5 Application Courier-mta Courtier-authlib 0.56 Version Details Vulnerabilities
6 Application Courier-mta Courtier-authlib 0.57 Version Details Vulnerabilities
7 Application Courier-mta Courtier-authlib 0.58 Version Details Vulnerabilities
8 Application Courier-mta Courtier-authlib 0.59 Version Details Vulnerabilities
9 Application Courier-mta Courtier-authlib 0.59.1 Version Details Vulnerabilities
10 Application Courier-mta Courtier-authlib 0.59.2 Version Details Vulnerabilities
11 Application Courier-mta Courtier-authlib 0.59.3 Version Details Vulnerabilities
12 Application Courier-mta Courtier-authlib 0.60 Version Details Vulnerabilities
13 Application Courier-mta Courtier-authlib 0.60.1 Version Details Vulnerabilities
14 Application Courier-mta Courtier-authlib 0.60.2 Version Details Vulnerabilities
15 Application Courier-mta Courtier-authlib 0.60.3 Version Details Vulnerabilities
16 Application Courier-mta Courtier-authlib 0.60.4 Version Details Vulnerabilities
17 Application Courier-mta Courtier-authlib 0.60.5 Version Details Vulnerabilities
18 Application Courier-mta Courtier-authlib 0.60.6 Version Details Vulnerabilities
19 Application Courier-mta Courtier-authlib 0.61.0 Version Details Vulnerabilities
20 Application Courier-mta Courtier-authlib 0.61.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Courier-mta Courtier-authlib 20

- References For CVE-2008-2380

http://security.gentoo.org/glsa/glsa-200903-25.xml
GENTOO GLSA-200903-25
http://www.courier-mta.org/authlib/changelog.html CONFIRM
http://www.securityfocus.com/bid/32926
BID 32926 Courier-Authlib Non-Latin Character Handling Postgres SQL Injection Vulnerability Release Date:2009-03-12
https://exchange.xforce.ibmcloud.com/vulnerabilities/47494
XF courier-library-postgres-sql-injection(47494)

- Metasploit Modules Related To CVE-2008-2380

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.