CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-2316

Integer overflow in _hashopenssl.c in the hashlib module in Python 2.5.2 and earlier might allow context-dependent attackers to defeat cryptographic digests, related to "partial hashlib hashing of data exceeding 4GB."
Publish Date : 2008-08-01 Last Update Date : 2018-10-11
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Overflow
CWE ID 189

- Vendor Statements

Not vulnerable. This issue did not affect the versions of python as shipped with Red Hat Enterprise Linux 2.1, 3, 4, or 5. Affected module was only introduced upstream in python 2.5.
Source: Redhat

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2008-2316 oval:org.opensuse.security:def:20082316 unix
DSA-1977 python2.4 python2.5 -- several vulnerabilities oval:org.mitre.oval:def:7152 unix
DSA-1977-1 python - several vulnerabilities oval:org.mitre.oval:def:18064 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-2316

# Product Type Vendor Product Version Update Edition Language
1 Application Python Software Foundation Python 1.5.2 Version Details Vulnerabilities
2 Application Python Software Foundation Python 1.6.1 Version Details Vulnerabilities
3 Application Python Software Foundation Python 2.0.1 Version Details Vulnerabilities
4 Application Python Software Foundation Python 2.1.3 Version Details Vulnerabilities
5 Application Python Software Foundation Python 2.2.3 Version Details Vulnerabilities
6 Application Python Software Foundation Python 2.3.7 Version Details Vulnerabilities
7 Application Python Software Foundation Python 2.4.5 Version Details Vulnerabilities
8 Application Python Software Foundation Python 2.5.1 Version Details Vulnerabilities
9 Application Python Software Foundation Python 2.5.2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Python Software Foundation Python 9

- References For CVE-2008-2316

https://exchange.xforce.ibmcloud.com/vulnerabilities/44174
XF python-hashlib-overflow(44174)
http://www.vupen.com/english/advisories/2008/2288
VUPEN ADV-2008-2288
https://exchange.xforce.ibmcloud.com/vulnerabilities/44173
XF python-multiple-bo(44173)
http://www.ubuntu.com/usn/usn-632-1
UBUNTU USN-632-1
http://www.securityfocus.com/bid/30491
BID 30491 Python Multiple Buffer Overflow Vulnerabilities Release Date:2013-01-30
http://www.novell.com/support/search.do?cmd=displayKC&docType=kc&externalId=InfoDocument-patchbuilder-readme5032900 CONFIRM
http://www.securityfocus.com/archive/1/495445/100/0/threaded
BUGTRAQ 20080813 rPSA-2008-0243-1 idle python
http://www.mandriva.com/security/advisories?name=MDVSA-2008:163
MANDRIVA MDVSA-2008:163
http://wiki.rpath.com/Advisories:rPSA-2008-0243 CONFIRM
http://support.apple.com/kb/HT3438 CONFIRM
http://security.gentoo.org/glsa/glsa-200807-16.xml
GENTOO GLSA-200807-16
http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.525289
SLACKWARE SSA:2008-217-01
http://lists.opensuse.org/opensuse-security-announce/2008-08/msg00006.html
SUSE SUSE-SR:2008:017
http://lists.apple.com/archives/security-announce/2009/Feb/msg00000.html
APPLE APPLE-SA-2009-02-12
http://bugs.gentoo.org/show_bug.cgi?id=230640 CONFIRM
http://bugs.gentoo.org/attachment.cgi?id=159422&action=view CONFIRM

- Metasploit Modules Related To CVE-2008-2316

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.