CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2007-5338

Mozilla Firefox before 2.0.0.8 and SeaMonkey before 1.1.5 allow remote attackers to execute arbitrary Javascript with user privileges by using the Script object to modify XPCNativeWrappers in a way that causes the script to be executed when a chrome action is performed.
Publish Date : 2007-10-21 Last Update Date : 2017-09-28
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 264

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat critical 2007-10-16 2007-10-18
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2007-5338 oval:org.opensuse.security:def:20075338 unix
DSA-1392-1 xulrunner - several vulnerabilities oval:org.mitre.oval:def:19745 unix
DSA-1396-1 iceweasel oval:org.mitre.oval:def:20376 unix
DSA-1401-1 iceape - several vulnerabilities oval:org.mitre.oval:def:18602 unix
DSA-1532 xulrunner -- several vulnerabilities oval:org.mitre.oval:def:7955 unix
DSA-1532-1 xulrunner oval:org.mitre.oval:def:18755 unix
DSA-1534 iceape -- several vulnerabilities oval:org.mitre.oval:def:7869 unix
DSA-1534-1 iceape oval:org.mitre.oval:def:18729 unix
DSA-1534-2 iceape - regression oval:org.mitre.oval:def:19906 unix
DSA-1535 iceweasel -- several vulnerabilities oval:org.mitre.oval:def:7395 unix
DSA-1535-1 iceweasel oval:org.mitre.oval:def:20297 unix
DSA-1574 icedove -- several vulnerabilities oval:org.mitre.oval:def:7681 unix
DSA-1574-1 icedove - several vulnerabilities oval:org.mitre.oval:def:18655 unix
ELSA-2007:0979: firefox security update (Critical) oval:org.mitre.oval:def:21818 unix
ELSA-2007:0981: thunderbird security update (Moderate) oval:org.mitre.oval:def:22422 unix
Mozilla Firefox before 2.0.0.8 and SeaMonkey before 1.1.5 allow remote attackers to execute arbitrary Javascript with us... oval:org.mitre.oval:def:10965 unix
RHSA-2007:0979: firefox security update (Critical) oval:com.redhat.rhsa:def:20070979 unix
RHSA-2007:0980: seamonkey security update (Critical) oval:com.redhat.rhsa:def:20070980 unix
RHSA-2007:0981: thunderbird security update (Moderate) oval:com.redhat.rhsa:def:20070981 unix
USN-536-1 -- mozilla-thunderbird, thunderbird vulnerabilities oval:org.mitre.oval:def:17494 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2007-5338

# Product Type Vendor Product Version Update Edition Language
1 Application Mozilla Firefox 2.0.0.7 Version Details Vulnerabilities
2 Application Mozilla Seamonkey 1.1.4 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mozilla Firefox 1
Mozilla Seamonkey 1

- References For CVE-2007-5338

https://www.redhat.com/archives/fedora-package-announce/2007-October/msg00285.html
FEDORA FEDORA-2007-2601
https://www.redhat.com/archives/fedora-package-announce/2007-October/msg00355.html
FEDORA FEDORA-2007-2664
https://www.redhat.com/archives/fedora-package-announce/2007-November/msg00498.html
FEDORA FEDORA-2007-3431
https://issues.rpath.com/browse/RPL-1858 CONFIRM
https://exchange.xforce.ibmcloud.com/vulnerabilities/37288
XF mozilla-xpcnativewrapper-code-execution(37288)
http://www.vupen.com/english/advisories/2007/3587
VUPEN ADV-2007-3587
http://www.vupen.com/english/advisories/2008/0083
VUPEN ADV-2008-0083
http://www.ubuntulinux.org/support/documentation/usn/usn-535-1
UBUNTU USN-535-1
http://www.vupen.com/english/advisories/2007/3544
VUPEN ADV-2007-3544
http://www.ubuntu.com/usn/usn-536-1
UBUNTU USN-536-1
http://www.securityfocus.com/archive/1/archive/1/482932/100/200/threaded
BUGTRAQ 20071029 rPSA-2007-0225-2 firefox thunderbird
http://www.securityfocus.com/bid/26132
BID 26132 Mozilla Firefox 2.0.0.7 Multiple Remote Vulnerabilities Release Date:2008-04-24
http://www.redhat.com/support/errata/RHSA-2007-0980.html
REDHAT RHSA-2007:0980
http://www.securityfocus.com/archive/1/archive/1/482925/100/0/threaded
BUGTRAQ 20071029 FLEA-2007-0062-1 firefox
http://www.securityfocus.com/archive/1/archive/1/482876/100/200/threaded
BUGTRAQ 20071026 rPSA-2007-0225-1 firefox
http://www.redhat.com/support/errata/RHSA-2007-0981.html
REDHAT RHSA-2007:0981
http://www.redhat.com/support/errata/RHSA-2007-0979.html
REDHAT RHSA-2007:0979
http://www.novell.com/linux/security/advisories/2007_57_mozilla.html
SUSE SUSE-SA:2007:057
http://www.mozilla.org/security/announce/2007/mfsa2007-35.html CONFIRM
http://www.mandriva.com/en/security/advisories?name=MDKSA-2007:202
MANDRIVA MDKSA-2007:202
http://www.debian.org/security/2007/dsa-1401
DEBIAN DSA-1401
http://www.gentoo.org/security/en/glsa/glsa-200711-14.xml
GENTOO GLSA-200711-14
http://www.debian.org/security/2007/dsa-1396
DEBIAN DSA-1396
http://www.debian.org/security/2007/dsa-1392
DEBIAN DSA-1392
http://sunsolve.sun.com/search/document.do?assetkey=1-66-201516-1
SUNALERT 201516
http://support.novell.com/techcenter/psdb/60eb95b75c76f9fbfcc9a89f99cd8f79.html CONFIRM
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00771742
HP HPSBUX02153
http://securitytracker.com/id?1018836
SECTRACK 1018836

- Metasploit Modules Related To CVE-2007-5338

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.