CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2007-3844

Mozilla Firefox 2.0.0.5, Thunderbird 2.0.0.5 and before 1.5.0.13, and SeaMonkey 1.1.3 allows remote attackers to conduct cross-site scripting (XSS) attacks with chrome privileges via an addon that inserts a (1) javascript: or (2) data: link into an about:blank document loaded by chrome via (a) the window.open function or (b) a content.location assignment, aka "Cross Context Scripting." NOTE: this issue is caused by a CVE-2007-3089 regression.
Publish Date : 2007-08-07 Last Update Date : 2018-10-15
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Cross Site Scripting
CWE ID CWE id is not defined for this vulnerability

- Vendor Statements

Red Hat is aware of this issue and is tracking it via the following bug: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=250648 The Red Hat Security Response Team has rated this issue as having moderate security impact, a future update may address this flaw.
Source: Redhat

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2007-08-01 2007-08-01
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2007-3844 oval:org.opensuse.security:def:20073844 unix
DSA-1344-1 iceweasel oval:org.mitre.oval:def:18825 unix
DSA-1345-1 xulrunner oval:org.mitre.oval:def:20237 unix
DSA-1346-1 iceape oval:org.mitre.oval:def:18682 unix
DSA-1391-1 icedove - several vulnerabilities oval:org.mitre.oval:def:17867 unix
ELSA-2007:0979: firefox security update (Critical) oval:org.mitre.oval:def:21818 unix
ELSA-2007:0981: thunderbird security update (Moderate) oval:org.mitre.oval:def:22422 unix
Mozilla Firefox 2.0.0.5, Thunderbird 2.0.0.5 and before 1.5.0.13, and SeaMonkey 1.1.3 allows remote attackers to conduct... oval:org.mitre.oval:def:9493 unix
RHSA-2007:0979: firefox security update (Critical) oval:com.redhat.rhsa:def:20070979 unix
RHSA-2007:0980: seamonkey security update (Critical) oval:com.redhat.rhsa:def:20070980 unix
RHSA-2007:0981: thunderbird security update (Moderate) oval:com.redhat.rhsa:def:20070981 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2007-3844

# Product Type Vendor Product Version Update Edition Language
1 Application Mozilla Firefox 2.0.0.5 Version Details Vulnerabilities
2 Application Mozilla Seamonkey 1.1.3 Version Details Vulnerabilities
3 Application Mozilla Thunderbird 2.0.0.5 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mozilla Firefox 1
Mozilla Seamonkey 1
Mozilla Thunderbird 1

- References For CVE-2007-3844

https://www.redhat.com/archives/fedora-package-announce/2007-October/msg00285.html
FEDORA FEDORA-2007-2601
http://bugzilla.mozilla.org/show_bug.cgi?id=388121 CONFIRM
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00771742
HP HPSBUX02153
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00774579
HP HPSBUX02156
http://securitytracker.com/id?1018479
SECTRACK 1018479
http://securitytracker.com/id?1018480
SECTRACK 1018480
http://securitytracker.com/id?1018481
SECTRACK 1018481
http://slackware.com/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.010101
SLACKWARE SSA:2007-213-01
http://sunsolve.sun.com/search/document.do?assetkey=1-26-103177-1
SUNALERT 103177
https://www.redhat.com/archives/fedora-package-announce/2007-November/msg00498.html
FEDORA FEDORA-2007-3431
http://www.vupen.com/english/advisories/2008/0082
VUPEN ADV-2008-0082
https://issues.rpath.com/browse/RPL-1600 CONFIRM
http://www.vupen.com/english/advisories/2007/4256
VUPEN ADV-2007-4256
http://www.ubuntu.com/usn/usn-503-1
UBUNTU USN-503-1
http://www.vupen.com/english/advisories/2007/3587
VUPEN ADV-2007-3587
http://www.securityfocus.com/archive/1/475265/100/200/threaded
BUGTRAQ 20070801 FLEA-2007-0039-1 firefox
http://www.securityfocus.com/archive/1/475450/30/5550/threaded
BUGTRAQ 20070803 FLEA-2007-0040-1 thunderbird
http://www.securityfocus.com/bid/25142
BID 25142 Mozilla Firefox/Thunderbird/SeaMonkey Chrome-Loaded About:Blank Script Execution Vulnerability Release Date:2008-03-18
http://www.ubuntu.com/usn/usn-493-1
UBUNTU USN-493-1
http://www.redhat.com/support/errata/RHSA-2007-0980.html
REDHAT RHSA-2007:0980
http://www.redhat.com/support/errata/RHSA-2007-0981.html
REDHAT RHSA-2007:0981
http://www.redhat.com/support/errata/RHSA-2007-0979.html
REDHAT RHSA-2007:0979
http://www.novell.com/linux/security/advisories/2007_57_mozilla.html
SUSE SUSE-SA:2007:057
http://www.mozilla.org/security/announce/2007/mfsa2007-26.html CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2008:047
MANDRIVA MDVSA-2008:047
http://www.gentoo.org/security/en/glsa/glsa-200708-09.xml
GENTOO GLSA-200708-09
http://www.mandriva.com/security/advisories?name=MDKSA-2007:152
MANDRIVA MDKSA-2007:152
http://www.mandriva.com/security/advisories?name=MDVSA-2007:047
MANDRIVA MDVSA-2007:047
http://www.debian.org/security/2007/dsa-1391
DEBIAN DSA-1391
http://www.debian.org/security/2007/dsa-1344
DEBIAN DSA-1344
http://www.debian.org/security/2007/dsa-1345
DEBIAN DSA-1345
http://www.debian.org/security/2007/dsa-1346
DEBIAN DSA-1346
http://support.novell.com/techcenter/psdb/60eb95b75c76f9fbfcc9a89f99cd8f79.html CONFIRM
http://sunsolve.sun.com/search/document.do?assetkey=1-66-201516-1
SUNALERT 201516

- Metasploit Modules Related To CVE-2007-3844

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.