Buffer overflow in the crack extension (CrackLib), as bundled with PHP 4.4.6 and other versions before 5.0.0, might allow local users to gain privileges via a long argument to the crack_opendict function.
Published 2007-03-10 22:19:00
Updated 2018-10-16 16:38:23
Source MITRE
View at NVD,   CVE.org
Vulnerability category: Overflow

Threat overview for CVE-2007-1401

Top countries where our scanners detected CVE-2007-1401
Top open port discovered on systems with this issue 80
IPs affected by CVE-2007-1401 100
Threat actors abusing to this issue? Yes
Find out if you* are affected by CVE-2007-1401!
*Directly or indirectly through your vendors, service providers and 3rd parties. Powered by attack surface intelligence from SecurityScorecard.

Exploit prediction scoring system (EPSS) score for CVE-2007-1401

Probability of exploitation activity in the next 30 days EPSS Score History
~ %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2007-1401

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen

Vendor statements for CVE-2007-1401

  • Red Hat 2007-03-19
    Not vulnerable. PHP as shipped with Red Hat Enterprise Linux 2.1, 3, 4, and 5 does not include Cracklib support.

Products affected by CVE-2007-1401

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!