CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-6504

Mozilla Firefox 2.x before 2.0.0.1, 1.5.x before 1.5.0.9, and SeaMonkey before 1.0.7 allows remote attackers to execute arbitrary code by appending an SVG comment DOM node to another type of document, which triggers memory corruption.
Publish Date : 2006-12-19 Last Update Date : 2018-10-17
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access Admin
Vulnerability Type(s) Execute CodeMemory corruption
CWE ID 94

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat critical 2006-12-12 2006-12-19
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2006-6504 oval:org.opensuse.security:def:20066504 unix
Mozilla Firefox 2.x before 2.0.0.1, 1.5.x before 1.5.0.9, and SeaMonkey before 1.0.7 allows remote attackers to execute ... oval:org.mitre.oval:def:11077 unix
RHSA-2006:0758: firefox security update (Critical) oval:com.redhat.rhsa:def:20060758 unix
RHSA-2006:0759: seamonkey security update (Critical) oval:com.redhat.rhsa:def:20060759 unix
RHSA-2006:0760: thunderbird security update (Critical) oval:com.redhat.rhsa:def:20060760 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2006-6504

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 5.10 Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 6.06 ~~lts~~~ Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 6.10 Version Details Vulnerabilities
4 Application Mozilla Firefox 1.5 Beta2 Version Details Vulnerabilities
5 Application Mozilla Firefox 1.5 Version Details Vulnerabilities
6 Application Mozilla Firefox 1.5 Beta1 Version Details Vulnerabilities
7 Application Mozilla Firefox 1.5.0.1 Version Details Vulnerabilities
8 Application Mozilla Firefox 1.5.0.2 Version Details Vulnerabilities
9 Application Mozilla Firefox 1.5.0.3 Version Details Vulnerabilities
10 Application Mozilla Firefox 1.5.0.4 Version Details Vulnerabilities
11 Application Mozilla Firefox 1.5.0.5 Version Details Vulnerabilities
12 Application Mozilla Firefox 1.5.0.6 Version Details Vulnerabilities
13 Application Mozilla Firefox 1.5.0.7 Version Details Vulnerabilities
14 Application Mozilla Firefox 1.5.0.8 Version Details Vulnerabilities
15 Application Mozilla Firefox 2.0 Version Details Vulnerabilities
16 Application Mozilla Seamonkey - Version Details Vulnerabilities
17 Application Mozilla Seamonkey 1.0 Version Details Vulnerabilities
18 Application Mozilla Seamonkey 1.0 Alpha Version Details Vulnerabilities
19 Application Mozilla Seamonkey 1.0 Beta Version Details Vulnerabilities
20 Application Mozilla Seamonkey 1.0.1 Version Details Vulnerabilities
21 Application Mozilla Seamonkey 1.0.2 Version Details Vulnerabilities
22 Application Mozilla Seamonkey 1.0.3 Version Details Vulnerabilities
23 Application Mozilla Seamonkey 1.0.4 Version Details Vulnerabilities
24 Application Mozilla Seamonkey 1.0.5 Version Details Vulnerabilities
25 Application Mozilla Seamonkey 1.0.6 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 3
Mozilla Firefox 12
Mozilla Seamonkey 10

- References For CVE-2006-6504

https://issues.rpath.com/browse/RPL-883 CONFIRM
http://www.zerodayinitiative.com/advisories/ZDI-06-051.html
http://www.vupen.com/english/advisories/2008/0083
VUPEN ADV-2008-0083
http://www.vupen.com/english/advisories/2006/5068
VUPEN ADV-2006-5068
http://www.us-cert.gov/cas/techalerts/TA06-354A.html
CERT TA06-354A
http://www.novell.com/linux/security/advisories/2007_06_mozilla.html
SUSE SUSE-SA:2007:006
http://www.securityfocus.com/archive/1/454939/100/0/threaded
BUGTRAQ 20061220 ZDI-06-051: Mozilla Firefox SVG Processing Remote Code Execution Vulnerability
http://www.securityfocus.com/archive/1/455145/100/0/threaded
BUGTRAQ 20061222 rPSA-2006-0234-1 firefox
http://www.securityfocus.com/archive/1/455728/100/200/threaded
BUGTRAQ 20070102 rPSA-2006-0234-2 firefox thunderbird
http://www.securityfocus.com/bid/21668
BID 21668 Mozilla Firefox/SeaMonkey/Thunderbird Multiple Remote Vulnerabilities Release Date:2007-11-01
http://www.ubuntu.com/usn/usn-398-1
UBUNTU USN-398-1
http://www.ubuntu.com/usn/usn-398-2
UBUNTU USN-398-2
http://www.novell.com/linux/security/advisories/2006_80_mozilla.html
SUSE SUSE-SA:2006:080
http://www.mandriva.com/security/advisories?name=MDKSA-2007:010
MANDRIVA MDKSA-2007:010
http://www.mozilla.org/security/announce/2006/mfsa2006-73.html CONFIRM
http://www.kb.cert.org/vuls/id/928956
CERT-VN VU#928956
http://rhn.redhat.com/errata/RHSA-2006-0759.html
REDHAT RHSA-2006:0759
http://rhn.redhat.com/errata/RHSA-2006-0760.html
REDHAT RHSA-2006:0760
http://security.gentoo.org/glsa/glsa-200701-02.xml
GENTOO GLSA-200701-02
http://securitytracker.com/id?1017418
SECTRACK 1017418
http://www.gentoo.org/security/en/glsa/glsa-200701-04.xml
GENTOO GLSA-200701-04
http://securitytracker.com/id?1017417
SECTRACK 1017417
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00771742
HP HPSBUX02153
http://fedoranews.org/cms/node/2338
FEDORA FEDORA-2007-004
http://rhn.redhat.com/errata/RHSA-2006-0758.html
REDHAT RHSA-2006:0758
http://fedoranews.org/cms/node/2297
FEDORA FEDORA-2006-1491
ftp://patches.sgi.com/support/free/security/advisories/20061202-01-P.asc
SGI 20061202-01-P

- Metasploit Modules Related To CVE-2006-6504

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.