CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-2779

Mozilla Firefox and Thunderbird before 1.5.0.4 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via (1) nested <option> tags in a select tag, (2) a DOMNodeRemoved mutation event, (3) "Content-implemented tree views," (4) BoxObjects, (5) the XBL implementation, (6) an iframe that attempts to remove itself, which leads to memory corruption.
Publish Date : 2006-06-02 Last Update Date : 2017-10-10
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access Admin
Vulnerability Type(s) Denial Of ServiceExecute CodeMemory corruption
CWE ID 94

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat critical 2006-06-01 2006-06-02
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
Mozilla Firefox and Thunderbird before 1.5.0.4 allow remote attackers to cause a denial of service (crash) and possibly ... oval:org.mitre.oval:def:9762 unix
RHSA-2006:0578: seamonkey security update (was mozilla) (Critical) oval:com.redhat.rhsa:def:20060578 unix
RHSA-2006:0609: seamonkey security update (Critical) oval:com.redhat.rhsa:def:20060609 unix
RHSA-2006:0610: firefox security update (Critical) oval:com.redhat.rhsa:def:20060610 unix
RHSA-2006:0611: thunderbird security update (Critical) oval:com.redhat.rhsa:def:20060611 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2006-2779

# Product Type Vendor Product Version Update Edition Language
1 Application Mozilla Firefox 0.8 Version Details Vulnerabilities
2 Application Mozilla Firefox 0.9 RC Version Details Vulnerabilities
3 Application Mozilla Firefox 0.9 Version Details Vulnerabilities
4 Application Mozilla Firefox 0.9.1 Version Details Vulnerabilities
5 Application Mozilla Firefox 0.9.2 Version Details Vulnerabilities
6 Application Mozilla Firefox 0.9.3 Version Details Vulnerabilities
7 Application Mozilla Firefox 0.10 Version Details Vulnerabilities
8 Application Mozilla Firefox 0.10.1 Version Details Vulnerabilities
9 Application Mozilla Firefox 1.0 Version Details Vulnerabilities
10 Application Mozilla Firefox 1.0.1 Version Details Vulnerabilities
11 Application Mozilla Firefox 1.0.2 Version Details Vulnerabilities
12 Application Mozilla Firefox 1.0.3 Version Details Vulnerabilities
13 Application Mozilla Firefox 1.0.4 Version Details Vulnerabilities
14 Application Mozilla Firefox 1.0.5 Version Details Vulnerabilities
15 Application Mozilla Firefox 1.0.6 Version Details Vulnerabilities
16 Application Mozilla Firefox 1.0.7 Version Details Vulnerabilities
17 Application Mozilla Firefox 1.0.8 Version Details Vulnerabilities
18 Application Mozilla Firefox 1.5 Beta1 Version Details Vulnerabilities
19 Application Mozilla Firefox 1.5 Beta2 Version Details Vulnerabilities
20 Application Mozilla Firefox 1.5 Version Details Vulnerabilities
21 Application Mozilla Firefox 1.5.0.2 Version Details Vulnerabilities
22 Application Mozilla Firefox 1.5.1 Version Details Vulnerabilities
23 Application Mozilla Firefox 1.5.2 Version Details Vulnerabilities
24 Application Mozilla Firefox 1.5.3 Version Details Vulnerabilities
25 Application Mozilla Firefox Preview Release Version Details Vulnerabilities
26 Application Mozilla Thunderbird 0.6 Version Details Vulnerabilities
27 Application Mozilla Thunderbird 0.7 Version Details Vulnerabilities
28 Application Mozilla Thunderbird 0.7.1 Version Details Vulnerabilities
29 Application Mozilla Thunderbird 0.7.2 Version Details Vulnerabilities
30 Application Mozilla Thunderbird 0.7.3 Version Details Vulnerabilities
31 Application Mozilla Thunderbird 0.8 Version Details Vulnerabilities
32 Application Mozilla Thunderbird 0.9 Version Details Vulnerabilities
33 Application Mozilla Thunderbird 1.0 Version Details Vulnerabilities
34 Application Mozilla Thunderbird 1.0.1 Version Details Vulnerabilities
35 Application Mozilla Thunderbird 1.0.2 Version Details Vulnerabilities
36 Application Mozilla Thunderbird 1.0.5 Version Details Vulnerabilities
37 Application Mozilla Thunderbird 1.0.6 Version Details Vulnerabilities
38 Application Mozilla Thunderbird 1.0.7 Version Details Vulnerabilities
39 Application Mozilla Thunderbird 1.0.8 Version Details Vulnerabilities
40 Application Mozilla Thunderbird 1.5 Version Details Vulnerabilities
41 Application Mozilla Thunderbird 1.5 Beta2 Version Details Vulnerabilities
42 Application Mozilla Thunderbird 1.5.1 Version Details Vulnerabilities
43 Application Mozilla Thunderbird 1.5.2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mozilla Firefox 25
Mozilla Thunderbird 18

- References For CVE-2006-2779

https://exchange.xforce.ibmcloud.com/vulnerabilities/26843
XF mozilla-browserengine-memory-corruption(26843)
http://www.vupen.com/english/advisories/2008/0083
VUPEN ADV-2008-0083
http://www.vupen.com/english/advisories/2007/3488
VUPEN ADV-2007-3488
http://www.vupen.com/english/advisories/2006/3749
VUPEN ADV-2006-3749
http://www.vupen.com/english/advisories/2006/3748
VUPEN ADV-2006-3748
http://www.vupen.com/english/advisories/2006/2106
VUPEN ADV-2006-2106
http://www.us-cert.gov/cas/techalerts/TA06-153A.html
CERT TA06-153A
http://www.ubuntulinux.org/support/documentation/usn/usn-297-3
UBUNTU USN-297-3
http://www.ubuntulinux.org/support/documentation/usn/usn-323-1
UBUNTU USN-323-1
http://www.ubuntulinux.org/support/documentation/usn/usn-296-2
UBUNTU USN-296-2
http://www.ubuntulinux.org/support/documentation/usn/usn-297-1
UBUNTU USN-297-1
http://www.securityfocus.com/bid/18228
BID 18228 Mozilla Firefox, SeaMonkey, Camino, and Thunderbird Multiple Remote Vulnerabilities Release Date:2009-06-10
http://www.ubuntulinux.org/support/documentation/usn/usn-296-1
UBUNTU USN-296-1
http://www.securityfocus.com/archive/1/archive/1/446658/100/200/threaded
HP SSRT061181
http://www.securityfocus.com/archive/1/archive/1/446657/100/200/threaded
HP SSRT061236
http://www.securityfocus.com/archive/1/archive/1/435795/100/0/threaded
BUGTRAQ 20060602 rPSA-2006-0091-1 firefox thunderbird
http://www.redhat.com/support/errata/RHSA-2006-0611.html
REDHAT RHSA-2006:0611
http://www.redhat.com/support/errata/RHSA-2006-0610.html
REDHAT RHSA-2006:0610
http://www.redhat.com/support/errata/RHSA-2006-0594.html
REDHAT RHSA-2006:0594
http://www.mozilla.org/security/announce/2006/mfsa2006-32.html CONFIRM
http://www.redhat.com/support/errata/RHSA-2006-0578.html
REDHAT RHSA-2006:0578
http://www.novell.com/linux/security/advisories/2006_35_mozilla.html
SUSE SUSE-SA:2006:035
http://www.mandriva.com/security/advisories?name=MDKSA-2006:146
MANDRIVA MDKSA-2006:146
http://www.mandriva.com/security/advisories?name=MDKSA-2006:145
MANDRIVA MDKSA-2006:145
http://www.kb.cert.org/vuls/id/466673
CERT-VN VU#466673
http://www.mandriva.com/security/advisories?name=MDKSA-2006:143
MANDRIVA MDKSA-2006:143
http://www.gentoo.org/security/en/glsa/glsa-200606-21.xml
GENTOO GLSA-200606-21
http://www.gentoo.org/security/en/glsa/glsa-200606-12.xml
GENTOO GLSA-200606-12
http://www.debian.org/security/2006/dsa-1134
DEBIAN DSA-1134
http://www.debian.org/security/2006/dsa-1160
DEBIAN DSA-1160
http://www.debian.org/security/2006/dsa-1159
DEBIAN DSA-1159
http://www.debian.org/security/2006/dsa-1118
DEBIAN DSA-1118
http://www.debian.org/security/2006/dsa-1120
DEBIAN DSA-1120
http://sunsolve.sun.com/search/document.do?assetkey=1-66-200387-1
SUNALERT 200387
http://sunsolve.sun.com/search/document.do?assetkey=1-26-102943-1
SUNALERT 102943
http://securitytracker.com/id?1016214
SECTRACK 1016214
http://rhn.redhat.com/errata/RHSA-2006-0609.html
REDHAT RHSA-2006:0609
http://securitytracker.com/id?1016202
SECTRACK 1016202

- Metasploit Modules Related To CVE-2006-2779

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.