CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2005-3352

Cross-site scripting (XSS) vulnerability in the mod_imap module of Apache httpd before 1.3.35-dev and Apache httpd 2.0.x before 2.0.56-dev allows remote attackers to inject arbitrary web script or HTML via the Referer when using image maps.
Publish Date : 2005-12-13 Last Update Date : 2018-10-19
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Cross Site Scripting
CWE ID CWE id is not defined for this vulnerability

- Vendor Statements

Fixed in Apache HTTP Server 2.2.2, 2.0.58, and 1.3.35: http://httpd.apache.org/security/vulnerabilities_22.html http://httpd.apache.org/security/vulnerabilities_20.html http://httpd.apache.org/security/vulnerabilities_13.html
Source: Apache

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2005-12-12 2005-12-12
Redhat moderate 2005-12-12 2005-12-12
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
Cross-site scripting (XSS) vulnerability in the mod_imap module of Apache httpd before 1.3.35-dev and Apache httpd 2.0.x... oval:org.mitre.oval:def:10480 unix
CVE-2005-3352 oval:org.opensuse.security:def:20053352 unix
mod_imap Referer Cross-Site Scripting oval:org.apache.httpd:def:20053352
RHSA-2006:0159: httpd security update (Moderate) oval:com.redhat.rhsa:def:20060159 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2005-3352

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Http Server 1.3 Version Details Vulnerabilities
2 Application Apache Http Server 1.3.0 Version Details Vulnerabilities
3 Application Apache Http Server 1.3.1 Version Details Vulnerabilities
4 Application Apache Http Server 1.3.2 Version Details Vulnerabilities
5 Application Apache Http Server 1.3.3 Version Details Vulnerabilities
6 Application Apache Http Server 1.3.4 Version Details Vulnerabilities
7 Application Apache Http Server 1.3.5 Version Details Vulnerabilities
8 Application Apache Http Server 1.3.6 Version Details Vulnerabilities
9 Application Apache Http Server 1.3.7 Version Details Vulnerabilities
10 Application Apache Http Server 1.3.7 DEV Version Details Vulnerabilities
11 Application Apache Http Server 1.3.8 Version Details Vulnerabilities
12 Application Apache Http Server 1.3.9 Version Details Vulnerabilities
13 Application Apache Http Server 1.3.10 Version Details Vulnerabilities
14 Application Apache Http Server 1.3.11 Version Details Vulnerabilities
15 Application Apache Http Server 1.3.11 Win32 Version Details Vulnerabilities
16 Application Apache Http Server 1.3.12 Version Details Vulnerabilities
17 Application Apache Http Server 1.3.12 Win32 Version Details Vulnerabilities
18 Application Apache Http Server 1.3.13 Win32 Version Details Vulnerabilities
19 Application Apache Http Server 1.3.13 Version Details Vulnerabilities
20 Application Apache Http Server 1.3.14 Version Details Vulnerabilities
21 Application Apache Http Server 1.3.14 Mac Os Version Details Vulnerabilities
22 Application Apache Http Server 1.3.14 Win32 Version Details Vulnerabilities
23 Application Apache Http Server 1.3.15 Win32 Version Details Vulnerabilities
24 Application Apache Http Server 1.3.15 Version Details Vulnerabilities
25 Application Apache Http Server 1.3.16 Version Details Vulnerabilities
26 Application Apache Http Server 1.3.16 Win32 Version Details Vulnerabilities
27 Application Apache Http Server 1.3.17 Version Details Vulnerabilities
28 Application Apache Http Server 1.3.17 Win32 Version Details Vulnerabilities
29 Application Apache Http Server 1.3.18 Version Details Vulnerabilities
30 Application Apache Http Server 1.3.18 Win32 Version Details Vulnerabilities
31 Application Apache Http Server 1.3.19 Version Details Vulnerabilities
32 Application Apache Http Server 1.3.19 Win32 Version Details Vulnerabilities
33 Application Apache Http Server 1.3.20 Win32 Version Details Vulnerabilities
34 Application Apache Http Server 1.3.20 Version Details Vulnerabilities
35 Application Apache Http Server 1.3.22 Version Details Vulnerabilities
36 Application Apache Http Server 1.3.22 Win32 Version Details Vulnerabilities
37 Application Apache Http Server 1.3.23 Version Details Vulnerabilities
38 Application Apache Http Server 1.3.23 Win32 Version Details Vulnerabilities
39 Application Apache Http Server 1.3.24 Win32 Version Details Vulnerabilities
40 Application Apache Http Server 1.3.24 Version Details Vulnerabilities
41 Application Apache Http Server 1.3.25 Version Details Vulnerabilities
42 Application Apache Http Server 1.3.25 Win32 Version Details Vulnerabilities
43 Application Apache Http Server 1.3.26 Version Details Vulnerabilities
44 Application Apache Http Server 1.3.26 Win32 Version Details Vulnerabilities
45 Application Apache Http Server 1.3.27 Version Details Vulnerabilities
46 Application Apache Http Server 1.3.28 Version Details Vulnerabilities
47 Application Apache Http Server 1.3.29 Version Details Vulnerabilities
48 Application Apache Http Server 1.3.30 Version Details Vulnerabilities
49 Application Apache Http Server 1.3.31 Version Details Vulnerabilities
50 Application Apache Http Server 1.3.32 Version Details Vulnerabilities
51 Application Apache Http Server 2.0 Version Details Vulnerabilities
52 Application Apache Http Server 2.0.9 Version Details Vulnerabilities
53 Application Apache Http Server 2.0.28 Version Details Vulnerabilities
54 Application Apache Http Server 2.0.28 Beta Version Details Vulnerabilities
55 Application Apache Http Server 2.0.28 Beta Win32 Version Details Vulnerabilities
56 Application Apache Http Server 2.0.32 Version Details Vulnerabilities
57 Application Apache Http Server 2.0.32 Beta Win32 Version Details Vulnerabilities
58 Application Apache Http Server 2.0.34 Beta Win32 Version Details Vulnerabilities
59 Application Apache Http Server 2.0.35 Version Details Vulnerabilities
60 Application Apache Http Server 2.0.36 Version Details Vulnerabilities
61 Application Apache Http Server 2.0.37 Version Details Vulnerabilities
62 Application Apache Http Server 2.0.38 Version Details Vulnerabilities
63 Application Apache Http Server 2.0.39 Version Details Vulnerabilities
64 Application Apache Http Server 2.0.40 Version Details Vulnerabilities
65 Application Apache Http Server 2.0.41 Version Details Vulnerabilities
66 Application Apache Http Server 2.0.42 Version Details Vulnerabilities
67 Application Apache Http Server 2.0.43 Version Details Vulnerabilities
68 Application Apache Http Server 2.0.44 Version Details Vulnerabilities
69 Application Apache Http Server 2.0.45 Version Details Vulnerabilities
70 Application Apache Http Server 2.0.46 Version Details Vulnerabilities
71 Application Apache Http Server 2.0.47 Version Details Vulnerabilities
72 Application Apache Http Server 2.0.48 Version Details Vulnerabilities
73 Application Apache Http Server 2.0.49 Version Details Vulnerabilities
74 Application Apache Http Server 2.0.50 Version Details Vulnerabilities
75 Application Apache Http Server 2.0.51 Version Details Vulnerabilities
76 Application Apache Http Server 2.0.52 Version Details Vulnerabilities
77 Application Apache Http Server 2.0.53 Version Details Vulnerabilities
78 Application Apache Http Server 2.0.54 Version Details Vulnerabilities
79 Application Apache Http Server 2.0.55 Version Details Vulnerabilities
80 Application Apache Mod Imap Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Http Server 79
Apache Mod Imap 1

- References For CVE-2005-3352

http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2006:007
MANDRIVA MDKSA-2006:007
http://www.vupen.com/english/advisories/2008/1697
VUPEN ADV-2008-1697
http://www.vupen.com/english/advisories/2008/1246/references
VUPEN ADV-2008-1246
http://www.vupen.com/english/advisories/2008/0924/references
VUPEN ADV-2008-0924
http://www.vupen.com/english/advisories/2006/4868
VUPEN ADV-2006-4868
http://www.vupen.com/english/advisories/2006/4300
VUPEN ADV-2006-4300
http://www.vupen.com/english/advisories/2006/4015
VUPEN ADV-2006-4015
http://www.vupen.com/english/advisories/2006/3995
VUPEN ADV-2006-3995
http://www.vupen.com/english/advisories/2006/2423
VUPEN ADV-2006-2423
http://www.vupen.com/english/advisories/2005/2870
VUPEN ADV-2005-2870
http://www.us-cert.gov/cas/techalerts/TA08-150A.html
CERT TA08-150A
http://www.ubuntulinux.org/usn/usn-241-1
UBUNTU USN-241-1
http://www.securityfocus.com/bid/15834
BID 15834 Apache 'mod_imap' Referer Cross-Site Scripting Vulnerability Release Date:2013-07-16
http://www.trustix.org/errata/2005/0074/
TRUSTIX TSLSA-2005-0074
http://www.securityfocus.com/archive/1/425399/100/0/threaded
FEDORA FLSA-2006:175406
http://www.securityfocus.com/archive/1/445206/100/0/threaded
HP HPSBUX02145
http://www.securityfocus.com/archive/1/450315/100/0/threaded
HP HPSBUX02172
http://www.securityfocus.com/archive/1/450321/100/0/threaded
HP HPSBUX02164
http://www.redhat.com/support/errata/RHSA-2006-0158.html
REDHAT RHSA-2006:0158
http://www.redhat.com/archives/fedora-announce-list/2006-January/msg00060.html
FEDORA FEDORA-2006-052
http://www.openpkg.org/security/OpenPKG-SA-2005.029-apache.txt
OPENPKG OpenPKG-SA-2005.029
http://www.oracle.com/technetwork/topics/security/cpujuly2013-1899826.html CONFIRM
http://www-1.ibm.com/support/search.wss?rs=0&q=PK25355&apar=only
AIXAPAR PK25355
http://www.debian.org/security/2006/dsa-1167
DEBIAN DSA-1167
http://www.gentoo.org/security/en/glsa/glsa-200602-03.xml
GENTOO GLSA-200602-03
http://slackware.com/security/viewer.php?l=slackware-security&y=2006&m=slackware-security.470158
SLACKWARE SSA:2006-130-01
http://slackware.com/security/viewer.php?l=slackware-security&y=2006&m=slackware-security.685483
SLACKWARE SSA:2006-129-01
http://sunsolve.sun.com/search/document.do?assetkey=1-26-102662-1
SUNALERT 102662
http://sunsolve.sun.com/search/document.do?assetkey=1-26-102663-1
SUNALERT 102663
http://lists.apple.com/archives/security-announce/2008//May/msg00001.html
APPLE APPLE-SA-2008-05-28
http://lists.apple.com/archives/security-announce/2008/Mar/msg00001.html
APPLE APPLE-SA-2008-03-18
http://lists.suse.com/archive/suse-security-announce/2007-May/0005.html
SUSE SUSE-SR:2007:011
http://lists.suse.de/archive/suse-security-announce/2006-Feb/0008.html
SUSE SUSE-SR:2006:004
http://www-1.ibm.com/support/search.wss?rs=0&q=PK16139&apar=only
AIXAPAR PK16139
http://securitytracker.com/id?1015344
SECTRACK 1015344
http://rhn.redhat.com/errata/RHSA-2006-0159.html
REDHAT RHSA-2006:0159
http://rhn.redhat.com/errata/RHSA-2006-0692.html
REDHAT RHSA-2006:0692
http://marc.info/?l=bugtraq&m=130497311408250&w=2
HP HPSBOV02683
http://www.novell.com/linux/security/advisories/2006_43_apache.html
SUSE SUSE-SA:2006:043
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01428449
HP HPSBMA02328
http://issues.apache.org/bugzilla/show_bug.cgi?id=37874 CONFIRM
http://docs.info.apple.com/article.html?artnum=307562 CONFIRM
ftp://patches.sgi.com/support/free/security/advisories/20060101-01-U
SGI 20060101-01-U

- Metasploit Modules Related To CVE-2005-3352

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.