CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2004-1068

A "missing serialization" error in the unix_dgram_recvmsg function in Linux 2.4.27 and earlier, and 2.6.x up to 2.6.9, allows local users to gain privileges via a race condition.
Publish Date : 2005-01-10 Last Update Date : 2017-10-11
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.2
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Gain privileges
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2004-11-15
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
A "missing serialization" error in the unix_dgram_recvmsg function in Linux 2.4.27 and earlier, and 2.6.x up to 2.6.9, a... oval:org.mitre.oval:def:11384 unix
CVE-2004-1068 oval:org.opensuse.security:def:20041068 unix
RHSA-2004:549: kernel security update (Important) oval:com.redhat.rhsa:def:2004549 unix
RHSA-2004:549: kernel security update (Important) oval:com.redhat.rhsa:def:20040549 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2004-1068

# Product Type Vendor Product Version Update Edition Language
1 OS Linux Linux Kernel 2.4.0 Test10 * * Version Details Vulnerabilities
2 OS Linux Linux Kernel 2.4.0 Test11 * * Version Details Vulnerabilities
3 OS Linux Linux Kernel 2.4.0 Test5 * * Version Details Vulnerabilities
4 OS Linux Linux Kernel 2.4.0 Test6 * * Version Details Vulnerabilities
5 OS Linux Linux Kernel 2.4.0 Test12 * * Version Details Vulnerabilities
6 OS Linux Linux Kernel 2.4.0 Test7 * * Version Details Vulnerabilities
7 OS Linux Linux Kernel 2.4.0 Test8 * * Version Details Vulnerabilities
8 OS Linux Linux Kernel 2.4.0 Test2 * * Version Details Vulnerabilities
9 OS Linux Linux Kernel 2.4.0 Test9 * * Version Details Vulnerabilities
10 OS Linux Linux Kernel 2.4.0 Test3 * * Version Details Vulnerabilities
11 OS Linux Linux Kernel 2.4.0 * * * Version Details Vulnerabilities
12 OS Linux Linux Kernel 2.4.0 Test1 * * Version Details Vulnerabilities
13 OS Linux Linux Kernel 2.4.0 Test4 * * Version Details Vulnerabilities
14 OS Linux Linux Kernel 2.4.1 * * * Version Details Vulnerabilities
15 OS Linux Linux Kernel 2.4.2 * * * Version Details Vulnerabilities
16 OS Linux Linux Kernel 2.4.3 * * * Version Details Vulnerabilities
17 OS Linux Linux Kernel 2.4.4 * * * Version Details Vulnerabilities
18 OS Linux Linux Kernel 2.4.5 * * * Version Details Vulnerabilities
19 OS Linux Linux Kernel 2.4.6 * * * Version Details Vulnerabilities
20 OS Linux Linux Kernel 2.4.7 * * * Version Details Vulnerabilities
21 OS Linux Linux Kernel 2.4.8 * * * Version Details Vulnerabilities
22 OS Linux Linux Kernel 2.4.9 * * * Version Details Vulnerabilities
23 OS Linux Linux Kernel 2.4.10 * * * Version Details Vulnerabilities
24 OS Linux Linux Kernel 2.4.12 * * * Version Details Vulnerabilities
25 OS Linux Linux Kernel 2.4.13 * * * Version Details Vulnerabilities
26 OS Linux Linux Kernel 2.4.14 * * * Version Details Vulnerabilities
27 OS Linux Linux Kernel 2.4.15 * * * Version Details Vulnerabilities
28 OS Linux Linux Kernel 2.4.16 * * * Version Details Vulnerabilities
29 OS Linux Linux Kernel 2.4.17 * * * Version Details Vulnerabilities
30 OS Linux Linux Kernel 2.4.18 Pre4 * * Version Details Vulnerabilities
31 OS Linux Linux Kernel 2.4.18 Pre6 * * Version Details Vulnerabilities
32 OS Linux Linux Kernel 2.4.18 * X86 * Version Details Vulnerabilities
33 OS Linux Linux Kernel 2.4.18 Pre5 * * Version Details Vulnerabilities
34 OS Linux Linux Kernel 2.4.18 Pre7 * * Version Details Vulnerabilities
35 OS Linux Linux Kernel 2.4.18 Pre1 * * Version Details Vulnerabilities
36 OS Linux Linux Kernel 2.4.18 Pre8 * * Version Details Vulnerabilities
37 OS Linux Linux Kernel 2.4.18 Pre2 * * Version Details Vulnerabilities
38 OS Linux Linux Kernel 2.4.18 Pre3 * * Version Details Vulnerabilities
39 OS Linux Linux Kernel 2.4.18 * * * Version Details Vulnerabilities
40 OS Linux Linux Kernel 2.4.19 Pre1 * * Version Details Vulnerabilities
41 OS Linux Linux Kernel 2.4.19 Pre2 * * Version Details Vulnerabilities
42 OS Linux Linux Kernel 2.4.19 Pre3 * * Version Details Vulnerabilities
43 OS Linux Linux Kernel 2.4.19 Pre5 * * Version Details Vulnerabilities
44 OS Linux Linux Kernel 2.4.19 Pre4 * * Version Details Vulnerabilities
45 OS Linux Linux Kernel 2.4.19 Pre6 * * Version Details Vulnerabilities
46 OS Linux Linux Kernel 2.4.19 * * * Version Details Vulnerabilities
47 OS Linux Linux Kernel 2.4.20 * * * Version Details Vulnerabilities
48 OS Linux Linux Kernel 2.4.21 * * * Version Details Vulnerabilities
49 OS Linux Linux Kernel 2.4.21 Pre1 * * Version Details Vulnerabilities
50 OS Linux Linux Kernel 2.4.21 Pre4 * * Version Details Vulnerabilities
51 OS Linux Linux Kernel 2.4.21 Pre7 * * Version Details Vulnerabilities
52 OS Linux Linux Kernel 2.4.22 * * * Version Details Vulnerabilities
53 OS Linux Linux Kernel 2.4.23 Pre9 * * Version Details Vulnerabilities
54 OS Linux Linux Kernel 2.4.23 Ow2 * * * Version Details Vulnerabilities
55 OS Linux Linux Kernel 2.4.23 * * * Version Details Vulnerabilities
56 OS Linux Linux Kernel 2.4.24 * * * Version Details Vulnerabilities
57 OS Linux Linux Kernel 2.4.24 Ow1 * * * Version Details Vulnerabilities
58 OS Linux Linux Kernel 2.4.25 * * * Version Details Vulnerabilities
59 OS Linux Linux Kernel 2.4.26 * * * Version Details Vulnerabilities
60 OS Linux Linux Kernel 2.4.27 Pre1 * * Version Details Vulnerabilities
61 OS Linux Linux Kernel 2.4.27 Pre5 * * Version Details Vulnerabilities
62 OS Linux Linux Kernel 2.4.27 * * * Version Details Vulnerabilities
63 OS Linux Linux Kernel 2.4.27 Pre2 * * Version Details Vulnerabilities
64 OS Linux Linux Kernel 2.4.27 Pre3 * * Version Details Vulnerabilities
65 OS Linux Linux Kernel 2.4.27 Pre4 * * Version Details Vulnerabilities
66 OS Redhat Enterprise Linux 2.1 * Enterprise Server Ia64 * Version Details Vulnerabilities
67 OS Redhat Enterprise Linux 2.1 * Workstation Ia64 * Version Details Vulnerabilities
68 OS Redhat Enterprise Linux 2.1 * Workstation * Version Details Vulnerabilities
69 OS Redhat Enterprise Linux 2.1 * Advanced Server * Version Details Vulnerabilities
70 OS Redhat Enterprise Linux 2.1 * Advanced Server Ia64 * Version Details Vulnerabilities
71 OS Redhat Enterprise Linux 2.1 * Enterprise Server * Version Details Vulnerabilities
72 OS Redhat Enterprise Linux 3.0 * Advanced Server * Version Details Vulnerabilities
73 OS Redhat Enterprise Linux 3.0 * Enterprise Server * Version Details Vulnerabilities
74 OS Redhat Enterprise Linux 3.0 * Workstation Server * Version Details Vulnerabilities
75 OS Redhat Enterprise Linux Desktop 3.0 * * * Version Details Vulnerabilities
76 OS Redhat Linux Advanced Workstation 2.1 * Ia64 * Version Details Vulnerabilities
77 OS Redhat Linux Advanced Workstation 2.1 * Itanium Processor * Version Details Vulnerabilities
78 OS Ubuntu Ubuntu Linux 4.1 * PPC * Version Details Vulnerabilities
79 OS Ubuntu Ubuntu Linux 4.1 * Ia64 * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Linux Linux Kernel 65
Redhat Enterprise Linux 9
Redhat Enterprise Linux Desktop 1
Redhat Linux Advanced Workstation 2
Ubuntu Ubuntu Linux 2

- References For CVE-2004-1068

ftp://patches.sgi.com/support/free/security/advisories/20060402-01-U
SGI 20060402-01-U
http://www.novell.com/linux/security/advisories/2004_44_kernel.html
SUSE SUSE-SA:2004:044
http://secunia.com/advisories/20338
SECUNIA 20338
http://secunia.com/advisories/20202
SECUNIA 20202
http://www.debian.org/security/2006/dsa-1082
DEBIAN DSA-1082
http://www.redhat.com/support/errata/RHSA-2004-505.html
REDHAT RHSA-2004:505
http://secunia.com/advisories/20163
SECUNIA 20163
http://www.redhat.com/support/errata/RHSA-2004-504.html
REDHAT RHSA-2004:504
http://secunia.com/advisories/20162
SECUNIA 20162
http://www.debian.org/security/2006/dsa-1069
DEBIAN DSA-1069
https://bugzilla.fedora.us/show_bug.cgi?id=2336
FEDORA FLSA:2336
http://www.debian.org/security/2006/dsa-1067
DEBIAN DSA-1067
http://www.debian.org/security/2006/dsa-1070
DEBIAN DSA-1070
http://www.redhat.com/support/errata/RHSA-2004-537.html
REDHAT RHSA-2004:537
http://www.securityfocus.com/bid/11715
BID 11715 Linux Kernel AF_UNIX Arbitrary Kernel Memory Modification Vulnerability Release Date:2007-01-18
http://www.securityfocus.com/archive/1/381689
BUGTRAQ 20041119 Addendum, recent Linux <= 2.4.27 vulnerabilities
http://secunia.com/advisories/19607
SECUNIA 19607
http://www.mandriva.com/security/advisories?name=MDKSA-2005:022
MANDRAKE MDKSA-2005:022
http://marc.info/?l=bugtraq&m=110306397320336&w=2
BUGTRAQ 20041214 [USN-38-1] Linux kernel vulnerabilities
https://exchange.xforce.ibmcloud.com/vulnerabilities/18230
XF linux-afunix-race-condition(18230)
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11384
OVAL oval:org.mitre.oval:def:11384

- Metasploit Modules Related To CVE-2004-1068

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.