In Apache HTTP Server 2.4 releases 2.4.17 to 2.4.38, with MPM event, worker or prefork, code executing in less-privileged child processes or threads (including scripts executed by an in-process scripting interpreter) could execute arbitrary code with the privileges of the parent process (usually root) by manipulating the scoreboard. Non-Unix systems are not affected.
Published 2019-04-08 22:29:00
Updated 2021-06-06 11:15:22
View at NVD,   CVE.org
Vulnerability category: Execute code

Threat overview for CVE-2019-0211

Top countries where our scanners detected CVE-2019-0211
Top open port discovered on systems with this issue 80
IPs affected by CVE-2019-0211 2,692,828
Threat actors abusing to this issue? Yes
Find out if you* are affected by CVE-2019-0211!
*Directly or indirectly through your vendors, service providers and 3rd parties. Powered by attack surface intelligence from SecurityScorecard.

CVE-2019-0211 is in the CISA Known Exploited Vulnerabilities Catalog

CISA vulnerability name:
Apache HTTP Server Privilege Escalation Vulnerability
CISA required action:
Apply updates per vendor instructions.
CISA description:
Apache HTTP Server, with MPM event, worker or prefork, code executing in less-privileged child processes or threads (including scripts executed by an in-process scripting interpreter) could execute code with the privileges of the parent process (usually root) by manipulating the scoreboard.
Added on 2021-11-03 Action due date 2022-05-03

Exploit prediction scoring system (EPSS) score for CVE-2019-0211

Probability of exploitation activity in the next 30 days: 97.33%

Percentile, the proportion of vulnerabilities that are scored at or less: ~ 100 % EPSS Score History EPSS FAQ

CVSS scores for CVE-2019-0211

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Source
7.2
HIGH AV:L/AC:L/Au:N/C:C/I:C/A:C
3.9
10.0
nvd@nist.gov
7.8
HIGH CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
1.8
5.9
nvd@nist.gov

CWE ids for CVE-2019-0211

  • Referencing memory after it has been freed can cause a program to crash, use unexpected values, or execute code.
    Assigned by: nvd@nist.gov (Primary)

References for CVE-2019-0211

Products affected by CVE-2019-0211

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!