Vulnerability Details : CVE-2017-9798

Apache httpd allows remote attackers to read secret data from process memory if the Limit directive can be set in a user's .htaccess file, or if httpd.conf has certain misconfigurations, aka Optionsbleed. This affects the Apache HTTP Server through 2.2.34 and 2.4.x through 2.4.27. The attacker sends an unauthenticated OPTIONS HTTP request when attempting to read secret data. This is a use-after-free issue and thus secret data is not always sent, and the specific data depends on many factors including configuration. Exploitation with .htaccess can be blocked with a patch to the ap_limit_section function in server/core.c.
Vulnerability category: Memory Corruption
Published 2017-09-18 15:29:00
Updated 2021-06-06 11:15:21
View at NVD,   CVE.org
At least one public exploit which can be used to exploit this vulnerability exists!

Threat overview for CVE-2017-9798

Top countries where our scanners detected CVE-2017-9798
Top open port discovered on systems with this issue 80
IPs affected by CVE-2017-9798 4,649,364
Threat actors abusing to this issue? Yes
Find out if you* are affected by CVE-2017-9798!
*Directly or indirectly through your vendors, service providers and 3rd parties. Powered by attack surface intelligence from SecurityScorecard.

Exploit prediction scoring system (EPSS) score for CVE-2017-9798

Probability of exploitation activity in the next 30 days: 97.36%

Percentile, the proportion of vulnerabilities that are scored at or less: ~ 100 % EPSS Score History EPSS FAQ

Metasploit modules for CVE-2017-9798

  • Apache Optionsbleed Scanner
    Disclosure Date: 2017-09-18
    First seen: 2020-04-26
    auxiliary/scanner/http/apache_optionsbleed
    This module scans for the Apache optionsbleed vulnerability where the Allow response header returned from an OPTIONS request may bleed memory if the server has a .htaccess file with an invalid Limit method defined.

CVSS scores for CVE-2017-9798

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Source
5.0
MEDIUM AV:N/AC:L/Au:N/C:P/I:N/A:N
10.0
2.9
nvd@nist.gov
7.5
HIGH CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
3.9
3.6
nvd@nist.gov

CWE ids for CVE-2017-9798

  • Referencing memory after it has been freed can cause a program to crash, use unexpected values, or execute code.
    Assigned by: nvd@nist.gov (Primary)

References for CVE-2017-9798

Products affected by CVE-2017-9798

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!