CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2022-23308

valid.c in libxml2 before 2.9.13 has a use-after-free of ID and IDREF attributes.
Publish Date : 2022-02-26 Last Update Date : 2022-11-02
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 416

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2022:0899: libxml2 security update (Moderate) oval:com.redhat.rhsa:def:20220899 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2022-23308

# Product Type Vendor Product Version Update Edition Language
1 OS Apple Ipados * * * * Version Details Vulnerabilities
2 OS Apple Iphone Os * * * * Version Details Vulnerabilities
3 OS Apple Mac Os X * * * * Version Details Vulnerabilities
4 OS Apple Mac Os X 10.15.7 Security Update 2021-003 * * Version Details Vulnerabilities
5 OS Apple Mac Os X 10.15.7 Security Update 2021-007 * * Version Details Vulnerabilities
6 OS Apple Mac Os X 10.15.7 Security Update 2021-004 * * Version Details Vulnerabilities
7 OS Apple Mac Os X 10.15.7 Security Update 2022-003 * * Version Details Vulnerabilities
8 OS Apple Mac Os X 10.15.7 Security Update 2020-001 * * Version Details Vulnerabilities
9 OS Apple Mac Os X 10.15.7 Security Update 2021-005 * * Version Details Vulnerabilities
10 OS Apple Mac Os X 10.15.7 Security Update 2021-001 * * Version Details Vulnerabilities
11 OS Apple Mac Os X 10.15.7 Security Update 2021-006 * * Version Details Vulnerabilities
12 OS Apple Mac Os X 10.15.7 Security Update 2021-002 * * Version Details Vulnerabilities
13 OS Apple Mac Os X 10.15.7 Security Update 2021-008 * * Version Details Vulnerabilities
14 OS Apple Mac Os X 10.15.7 * * * Version Details Vulnerabilities
15 OS Apple Mac Os X 10.15.7 Security Update 2022-001 * * Version Details Vulnerabilities
16 OS Apple Macos * * * * Version Details Vulnerabilities
17 OS Apple Tvos * * * * Version Details Vulnerabilities
18 OS Apple Watchos * * * * Version Details Vulnerabilities
19 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
20 OS Fedoraproject Fedora 34 * * * Version Details Vulnerabilities
21 Application Netapp Active Iq Unified Manager - * * * Version Details Vulnerabilities
22 Application Netapp Clustered Data Ontap - * * * Version Details Vulnerabilities
23 Application Netapp Clustered Data Ontap Antivirus Connector - * * * Version Details Vulnerabilities
24 Application Netapp Manageability Software Development Kit - * * * Version Details Vulnerabilities
25 Application Netapp Ontap Select Deploy Administration Utility - * * * Version Details Vulnerabilities
26 Application Netapp Smi-s Provider - * * * Version Details Vulnerabilities
27 Application Netapp Snapdrive - * * * Version Details Vulnerabilities
28 Application Netapp Snapmanager - * * * Version Details Vulnerabilities
29 Application Netapp Solidfire \& Hci Management Node - * * * Version Details Vulnerabilities
30 Application Netapp Solidfire\, Enterprise Sds \& Hci Storage Node - * * * Version Details Vulnerabilities
31 Application Oracle Communications Cloud Native Core Binding Support Function 22.2.0 * * * Version Details Vulnerabilities
32 Application Oracle Communications Cloud Native Core Network Function Cloud Native Environment 22.1.0 * * * Version Details Vulnerabilities
33 Application Oracle Communications Cloud Native Core Network Repository Function 22.1.2 * * * Version Details Vulnerabilities
34 Application Oracle Communications Cloud Native Core Network Repository Function 22.2.0 * * * Version Details Vulnerabilities
35 Application Oracle Communications Cloud Native Core Network Slice Selection Function 22.1.1 * * * Version Details Vulnerabilities
36 Application Oracle Communications Cloud Native Core Unified Data Repository 22.2.0 * * * Version Details Vulnerabilities
37 Application Oracle Mysql Workbench * * * * Version Details Vulnerabilities
38 Application Oracle Zfs Storage Appliance Kit 8.8 * * * Version Details Vulnerabilities
39 Application Xmlsoft Libxml2 * * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apple Ipados 1
Apple Iphone Os 1
Apple Mac Os X 13
Apple Macos 1
Apple Tvos 1
Apple Watchos 1
Debian Debian Linux 1
Fedoraproject Fedora 1
Netapp Active Iq Unified Manager 1
Netapp Clustered Data Ontap 1
Netapp Clustered Data Ontap Antivirus Connector 1
Netapp Manageability Software Development Kit 1
Netapp Ontap Select Deploy Administration Utility 1
Netapp Smi-s Provider 1
Netapp Snapdrive 1
Netapp Snapmanager 1
Netapp Solidfire \& Hci Management Node 1
Netapp Solidfire\, Enterprise Sds \& Hci Storage Node 1
Oracle Communications Cloud Native Core Binding Support Function 1
Oracle Communications Cloud Native Core Network Function Cloud Native Environment 1
Oracle Communications Cloud Native Core Network Repository Function 2
Oracle Communications Cloud Native Core Network Slice Selection Function 1
Oracle Communications Cloud Native Core Unified Data Repository 1
Oracle Mysql Workbench 1
Oracle Zfs Storage Appliance Kit 1
Xmlsoft Libxml2 1

- References For CVE-2022-23308

https://security.netapp.com/advisory/ntap-20220331-0008/ CONFIRM
https://www.oracle.com/security-alerts/cpujul2022.html
N/A N/A
http://seclists.org/fulldisclosure/2022/May/38
FULLDISC 20220516 APPLE-SA-2022-05-16-2 macOS Monterey 12.4
https://security.gentoo.org/glsa/202210-03
GENTOO GLSA-202210-03
https://support.apple.com/kb/HT213257 CONFIRM
https://support.apple.com/kb/HT213258 CONFIRM
https://support.apple.com/kb/HT213254 CONFIRM
https://gitlab.gnome.org/GNOME/libxml2/-/blob/v2.9.13/NEWS
http://seclists.org/fulldisclosure/2022/May/37
FULLDISC 20220516 APPLE-SA-2022-05-16-6 tvOS 15.5
http://seclists.org/fulldisclosure/2022/May/35
FULLDISC 20220516 APPLE-SA-2022-05-16-3 macOS Big Sur 11.6.6
http://seclists.org/fulldisclosure/2022/May/34
FULLDISC 20220516 APPLE-SA-2022-05-16-1 iOS 15.5 and iPadOS 15.5
http://seclists.org/fulldisclosure/2022/May/33
FULLDISC 20220516 APPLE-SA-2022-05-16-4 Security Update 2022-004 Catalina
https://lists.debian.org/debian-lts-announce/2022/04/msg00004.html
MLIST [debian-lts-announce] 20220408 [SECURITY] [DLA 2972-1] libxml2 security update
https://support.apple.com/kb/HT213253 CONFIRM
https://support.apple.com/kb/HT213256 CONFIRM
https://support.apple.com/kb/HT213255 CONFIRM
https://lists.fedoraproject.org/archives/list/[email protected]/message/LA3MWWAYZADWJ5F6JOUBX65UZAMQB7RF/
FEDORA FEDORA-2022-050c712ed7
https://github.com/GNOME/libxml2/commit/652dd12a858989b14eed4e84e453059cd3ba340e CONFIRM
http://seclists.org/fulldisclosure/2022/May/36
FULLDISC 20220516 APPLE-SA-2022-05-16-5 watchOS 8.6

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0

- Metasploit Modules Related To CVE-2022-23308

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.