CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2021-26291

Apache Maven will follow repositories that are defined in a dependency’s Project Object Model (pom) which may be surprising to some users, resulting in potential risk if a malicious actor takes over that repository or is able to insert themselves into a position to pretend to be that repository. Maven is changing the default behavior in 3.8.1+ to no longer follow http (non-SSL) repository references by default. More details available in the referenced urls. If you are currently using a repository manager to govern the repositories used by your builds, you are unaffected by the risks present in the legacy behavior, and are unaffected by this vulnerability and change to default behavior. See this link for more information about repository management: https://maven.apache.org/repository-management.html
Publish Date : 2021-04-23 Last Update Date : 2021-08-24
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.4
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 346

- Products Affected By CVE-2021-26291

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Maven * * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Maven 1

- References For CVE-2021-26291

https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210817 [jira] [Updated] (KARAF-7240) Upgrade bcprov 1.68 artifacts to mitigate CVE-2020-28052
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210817 [jira] [Commented] (KARAF-7240) Upgrade bcprov 1.68 artifacts to mitigate CVE-2020-28052
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210820 [jira] [Updated] (KARAF-7240) Upgrade bcprov 1.68 artifacts to mitigate CVE-2020-28052
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210719 [jira] [Commented] (KARAF-7224) Impact of CVE-2021-26291 on Karaf
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210720 [jira] [Commented] (KARAF-7224) Impact of CVE-2021-26291 on Karaf
https://lists.apache.org/thread.html/[email protected]%3Ccommits.druid.apache.org%3E
MLIST [druid-commits] 20210809 [GitHub] [druid] abhishekagarwal87 opened a new pull request #11562: suppress CVE-2021-26291 on kafka-clients
https://lists.apache.org/thread.html/[email protected]%3Cjira.kafka.apache.org%3E
MLIST [kafka-jira] 20210809 [jira] [Commented] (KAFKA-12820) Upgrade maven-artifact dependency to resolve CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Ccommits.druid.apache.org%3E
MLIST [druid-commits] 20210809 [GitHub] [druid] jihoonson commented on pull request #11562: suppress CVE-2021-26291 on kafka-clients
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210810 [jira] [Commented] (KARAF-7240) Upgrade bcprov artifacts to mitigate CVE-2020-28052
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210718 [jira] [Created] (KARAF-7224) Impact of CVE-2021-26291 on Karaf
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210718 [jira] [Created] (KARAF-7223) Upgrade maven artifacts to mitigate CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210719 [jira] [Assigned] (KARAF-7224) Impact of CVE-2021-26291 on Karaf
https://lists.apache.org/thread.html/r9a027668558264c4897633e66bcb7784099fdec9f9b22c38c2442f00%40%3Cusers.maven.apache.org%3E
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210824 [jira] [Resolved] (KARAF-7240) Upgrade bcprov 1.68 artifacts to mitigate CVE-2020-28052
https://lists.apache.org/thread.html/[email protected]%3Cdev.kafka.apache.org%3E
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210816 [jira] [Updated] (KARAF-7240) Upgrade bcprov artifacts to mitigate CVE-2020-28052
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210810 [jira] [Updated] (KARAF-7240) Upgrade bcprov artifacts to mitigate CVE-2020-28052
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210810 [jira] [Created] (KARAF-7240) Upgrade bcprov artifacts to mitigate CVE-2020-28052
https://lists.apache.org/thread.html/[email protected]%3Cusers.kafka.apache.org%3E
MLIST [kafka-users] 20210617 vulnerabilities
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210824 [jira] [Commented] (KARAF-7240) Upgrade bcprov 1.68 artifacts to mitigate CVE-2020-28052
https://lists.apache.org/thread.html/[email protected]%3Cdev.maven.apache.org%3E
MLIST [maven-dev] 20210423 CVE-2021-26291: Apache Maven: block repositories using http by default
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210719 [jira] [Assigned] (KARAF-7223) Upgrade maven artifacts to mitigate CVE-2021-26291
https://www.whitesourcesoftware.com/resources/blog/maven-security-vulnerability-cve-2021-26291/
https://lists.apache.org/thread.html/[email protected]%3Cissues.karaf.apache.org%3E
MLIST [karaf-issues] 20210816 [jira] [Updated] (KARAF-7240) Upgrade bcprov 1.69 artifacts to mitigate CVE-2020-28052
https://lists.apache.org/thread.html/[email protected]%3Cannounce.apache.org%3E
MLIST [announce] 20210423 CVE-2021-26291: Apache Maven: block repositories using http by default
https://lists.apache.org/thread.html/[email protected]%3Cdev.jena.apache.org%3E
MLIST [jena-dev] 20210428 FYI: Maven CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Cjira.kafka.apache.org%3E
MLIST [kafka-jira] 20210521 [GitHub] [kafka] omkreddy merged pull request #10739: KAFKA-12820: Upgrade maven-artifact dependency to resolve CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Cdev.myfaces.apache.org%3E
MLIST [myfaces-dev] 20210506 [GitHub] [myfaces-tobago] lofwyr14 opened a new pull request #817: build: CVE fix
https://lists.apache.org/thread.html/[email protected]%3Cjira.kafka.apache.org%3E
MLIST [kafka-jira] 20210520 [jira] [Created] (KAFKA-12820) Upgrade maven-artifact dependency to resolve CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Cdev.jena.apache.org%3E
MLIST [jena-dev] 20210429 Re: FYI: Maven CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Ccommits.druid.apache.org%3E
MLIST [druid-commits] 20210809 [GitHub] [druid] abhishekagarwal87 merged pull request #11562: suppress CVE-2021-26291 on kafka-clients
https://lists.apache.org/thread.html/[email protected]%3Ccommits.kafka.apache.org%3E
MLIST [kafka-commits] 20210521 [kafka] branch 2.6 updated: KAFKA-12820: Upgrade maven-artifact dependency to resolve CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Ccommits.kafka.apache.org%3E
MLIST [kafka-commits] 20210521 [kafka] branch 2.7 updated: KAFKA-12820: Upgrade maven-artifact dependency to resolve CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Cdev.kafka.apache.org%3E
MLIST [kafka-dev] 20210521 [jira] [Resolved] (KAFKA-12820) Upgrade maven-artifact dependency to resolve CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Cjira.kafka.apache.org%3E
MLIST [kafka-jira] 20210521 [jira] [Resolved] (KAFKA-12820) Upgrade maven-artifact dependency to resolve CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Ccommits.kafka.apache.org%3E
MLIST [kafka-commits] 20210521 [kafka] branch 2.8 updated: KAFKA-12820: Upgrade maven-artifact dependency to resolve CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Cjira.kafka.apache.org%3E
MLIST [kafka-jira] 20210520 [GitHub] [kafka] dongjinleekr opened a new pull request #10739: KAFKA-12820: Upgrade maven-artifact dependency to resolve CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Cjira.kafka.apache.org%3E
MLIST [kafka-jira] 20210520 [jira] [Assigned] (KAFKA-12820) Upgrade maven-artifact dependency to resolve CVE-2021-26291
http://www.openwall.com/lists/oss-security/2021/04/23/5
MLIST [oss-security] 20210423 CVE-2021-26291: Apache Maven: block repositories using http by default
https://lists.apache.org/thread.html/[email protected]%3Cdev.kafka.apache.org%3E
MLIST [kafka-dev] 20210520 [jira] [Created] (KAFKA-12820) Upgrade maven-artifact dependency to resolve CVE-2021-26291
https://lists.apache.org/thread.html/[email protected]%3Cdev.kafka.apache.org%3E
https://lists.apache.org/thread.html/[email protected]%3Cusers.maven.apache.org%3E
MLIST [maven-users] 20210423 CVE-2021-26291: Apache Maven: block repositories using http by default

- Metasploit Modules Related To CVE-2021-26291

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.