CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2020-13379

The avatar feature in Grafana 3.0.1 through 7.0.1 has an SSRF Incorrect Access Control issue. This vulnerability allows any unauthenticated user/client to make Grafana send HTTP requests to any URL and return its result to the user/client. This can be used to gain information about the network that Grafana is running on. Furthermore, passing invalid URL objects could be used for DOS'ing Grafana via SegFault.
Publish Date : 2020-06-03 Last Update Date : 2021-01-29
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.4
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 918

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2020:2641: grafana security update (Important) oval:com.redhat.rhsa:def:20202641 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2020-13379

# Product Type Vendor Product Version Update Edition Language
1 OS Fedoraproject Fedora 31 * * * Version Details Vulnerabilities
2 OS Fedoraproject Fedora 32 * * * Version Details Vulnerabilities
3 Application Grafana Grafana * * * * Version Details Vulnerabilities
4 Application Netapp E-series Performance Analyzer - * * * Version Details Vulnerabilities
5 Application Opensuse Backports Sle 15.0 SP1 * * Version Details Vulnerabilities
6 Application Opensuse Backports Sle 15.0 SP2 * * Version Details Vulnerabilities
7 OS Opensuse Leap 15.2 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Fedoraproject Fedora 2
Grafana Grafana 1
Netapp E-series Performance Analyzer 1
Opensuse Backports Sle 2
Opensuse Leap 1

- References For CVE-2020-13379

http://www.openwall.com/lists/oss-security/2020/06/03/4 CONFIRM
https://community.grafana.com/t/release-notes-v6-7-x/27119
https://community.grafana.com/t/release-notes-v7-0-x/29381
https://community.grafana.com/t/grafana-7-0-2-and-6-7-4-security-update/31408
https://grafana.com/blog/2020/06/03/grafana-6.7.4-and-7.0.2-released-with-important-security-fix/ CONFIRM
https://security.netapp.com/advisory/ntap-20200608-0006/ CONFIRM
http://www.openwall.com/lists/oss-security/2020/06/09/2
MLIST [oss-security] 20200609 Re: Grafana 6.7.4 and 7.0.2 released with fix for CVE-2020-13379
https://lists.fedoraproject.org/archives/list/[email protected]/message/O2KSCCGKNEENZN3DW7TSPFBBUZH3YZXZ/
FEDORA FEDORA-2020-e6e81a03d6
https://lists.fedoraproject.org/archives/list/[email protected]/message/EEKSZ6GE4EDOFZ23NGYWOCMD6O4JF5SO/
FEDORA FEDORA-2020-a09e5be0be
http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00060.html
SUSE openSUSE-SU-2020:0892
https://mostwanted002.cf/post/grafanados/
http://packetstormsecurity.com/files/158320/Grafana-7.0.1-Denial-Of-Service.html
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00083.html
SUSE openSUSE-SU-2020:1105
https://rhynorater.github.io/CVE-2020-13379-Write-Up
https://lists.apache.org/thread.html/[email protected]%3Cissues.ambari.apache.org%3E
MLIST [ambari-issues] 20200903 [jira] [Assigned] (AMBARI-25547) Update Grafana version to 6.7.4 to avoid CVE-2020-13379
https://lists.apache.org/thread.html/[email protected]%3Cissues.ambari.apache.org%3E
MLIST [ambari-issues] 20200903 [jira] [Created] (AMBARI-25547) Update Grafana version to 6.7.4 to avoid CVE-2020-13379
http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00009.html
SUSE openSUSE-SU-2020:1611
http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00017.html
SUSE openSUSE-SU-2020:1646
https://lists.apache.org/thread.html/[email protected]%3Cissues.ambari.apache.org%3E
MLIST [ambari-issues] 20210121 [jira] [Updated] (AMBARI-25547) Update Grafana version to 6.7.4 to avoid CVE-2020-13379
https://lists.apache.org/thread.html/[email protected]%3Cdev.ambari.apache.org%3E
MLIST [ambari-dev] 20210122 [GitHub] [ambari] dvitiiuk commented on a change in pull request #3279: AMBARI-25547 Update Grafana version to 6.7.4 to avoid CVE-2020-13379
https://lists.apache.org/thread.html/[email protected]%3Cdev.ambari.apache.org%3E
MLIST [ambari-dev] 20210125 [GitHub] [ambari] payert merged pull request #3279: AMBARI-25547 Update Grafana version to 6.7.4 to avoid CVE-2020-13379
https://lists.apache.org/thread.html/[email protected]%3Ccommits.ambari.apache.org%3E
MLIST [ambari-commits] 20210125 [ambari] branch branch-2.7 updated: AMBARI-25547 Update Grafana version to 6.7.4 to avoid CVE-2020-13379 (#3279)
https://lists.apache.org/thread.html/[email protected]%3Cdev.ambari.apache.org%3E
MLIST [ambari-dev] 20210121 [GitHub] [ambari] payert commented on a change in pull request #3279: AMBARI-25547 Update Grafana version to 6.7.4 to avoid CVE-2020-13379
https://lists.apache.org/thread.html/[email protected]%3Cdev.ambari.apache.org%3E
MLIST [ambari-dev] 20210121 [GitHub] [ambari] payert opened a new pull request #3279: AMBARI-25547 Update Grafana version to 6.7.4 to avoid CVE-2020-13379
https://lists.apache.org/thread.html/[email protected]%3Cdev.ambari.apache.org%3E
MLIST [ambari-dev] 20210122 [GitHub] [ambari] payert opened a new pull request #3279: AMBARI-25547 Update Grafana version to 6.7.4 to avoid CVE-2020-13379
https://lists.apache.org/thread.html/[email protected]%3Cdev.ambari.apache.org%3E
MLIST [ambari-dev] 20210121 [GitHub] [ambari] dvitiiuk commented on a change in pull request #3279: AMBARI-25547 Update Grafana version to 6.7.4 to avoid CVE-2020-13379
https://lists.apache.org/thread.html/[email protected]%3Cdev.ambari.apache.org%3E
MLIST [ambari-dev] 20210122 [GitHub] [ambari] payert commented on a change in pull request #3279: AMBARI-25547 Update Grafana version to 6.7.4 to avoid CVE-2020-13379
https://lists.apache.org/thread.html/[email protected]%3Cissues.ambari.apache.org%3E
MLIST [ambari-issues] 20210127 [jira] [Resolved] (AMBARI-25547) Update Grafana version to 6.7.4 to avoid CVE-2020-13379

- Metasploit Modules Related To CVE-2020-13379

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.