CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2020-11996

A specially crafted sequence of HTTP/2 requests sent to Apache Tomcat 10.0.0-M1 to 10.0.0-M5, 9.0.0.M1 to 9.0.35 and 8.5.0 to 8.5.55 could trigger high CPU usage for several seconds. If a sufficient number of such requests were made on concurrent HTTP/2 connections, the server could become unresponsive.
Publish Date : 2020-06-26 Last Update Date : 2021-07-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 400

- Products Affected By CVE-2020-11996

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Tomcat * * * * Version Details Vulnerabilities
2 Application Apache Tomcat 9.0.0 Milestone23 * * Version Details Vulnerabilities
3 Application Apache Tomcat 9.0.0 Milestone9 * * Version Details Vulnerabilities
4 Application Apache Tomcat 9.0.0 Milestone19 * * Version Details Vulnerabilities
5 Application Apache Tomcat 9.0.0 Milestone4 * * Version Details Vulnerabilities
6 Application Apache Tomcat 9.0.0 Milestone14 * * Version Details Vulnerabilities
7 Application Apache Tomcat 9.0.0 Milestone24 * * Version Details Vulnerabilities
8 Application Apache Tomcat 9.0.0 Milestone1 * * Version Details Vulnerabilities
9 Application Apache Tomcat 9.0.0 Milestone2 * * Version Details Vulnerabilities
10 Application Apache Tomcat 9.0.0 Milestone5 * * Version Details Vulnerabilities
11 Application Apache Tomcat 9.0.0 Milestone25 * * Version Details Vulnerabilities
12 Application Apache Tomcat 9.0.0 Milestone15 * * Version Details Vulnerabilities
13 Application Apache Tomcat 9.0.0 Milestone10 * * Version Details Vulnerabilities
14 Application Apache Tomcat 9.0.0 Milestone20 * * Version Details Vulnerabilities
15 Application Apache Tomcat 9.0.0 Milestone6 * * Version Details Vulnerabilities
16 Application Apache Tomcat 9.0.0 Milestone26 * * Version Details Vulnerabilities
17 Application Apache Tomcat 9.0.0 Milestone16 * * Version Details Vulnerabilities
18 Application Apache Tomcat 9.0.0 Milestone11 * * Version Details Vulnerabilities
19 Application Apache Tomcat 9.0.0 Milestone21 * * Version Details Vulnerabilities
20 Application Apache Tomcat 9.0.0 Milestone7 * * Version Details Vulnerabilities
21 Application Apache Tomcat 9.0.0 Milestone27 * * Version Details Vulnerabilities
22 Application Apache Tomcat 9.0.0 Milestone17 * * Version Details Vulnerabilities
23 Application Apache Tomcat 9.0.0 Milestone12 * * Version Details Vulnerabilities
24 Application Apache Tomcat 9.0.0 Milestone22 * * Version Details Vulnerabilities
25 Application Apache Tomcat 9.0.0 Milestone8 * * Version Details Vulnerabilities
26 Application Apache Tomcat 9.0.0 Milestone18 * * Version Details Vulnerabilities
27 Application Apache Tomcat 9.0.0 Milestone3 * * Version Details Vulnerabilities
28 Application Apache Tomcat 9.0.0 Milestone13 * * Version Details Vulnerabilities
29 Application Apache Tomcat 10.0.0 Milestone3 * * Version Details Vulnerabilities
30 Application Apache Tomcat 10.0.0 Milestone4 * * Version Details Vulnerabilities
31 Application Apache Tomcat 10.0.0 Milestone2 * * Version Details Vulnerabilities
32 Application Apache Tomcat 10.0.0 Milestone1 * * Version Details Vulnerabilities
33 Application Apache Tomcat 10.0.0 Milestone5 * * Version Details Vulnerabilities
34 OS Canonical Ubuntu Linux 20.04 * * * Version Details Vulnerabilities
35 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
36 OS Debian Debian Linux 10.0 * * * Version Details Vulnerabilities
37 Application Netapp Oncommand System Manager 3.0 * * * Version Details Vulnerabilities
38 Application Netapp Oncommand System Manager 3.1.3 * * * Version Details Vulnerabilities
39 OS Opensuse Leap 15.1 * * * Version Details Vulnerabilities
40 OS Opensuse Leap 15.2 * * * Version Details Vulnerabilities
41 Application Oracle Mysql Enterprise Monitor * * * * Version Details Vulnerabilities
42 Application Oracle Siebel Ui Framework * * * * Version Details Vulnerabilities
43 Application Oracle Workload Manager 12.2.0.1 * * * Version Details Vulnerabilities
44 Application Oracle Workload Manager 18C * * * Version Details Vulnerabilities
45 Application Oracle Workload Manager 19C * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Tomcat 33
Canonical Ubuntu Linux 1
Debian Debian Linux 2
Netapp Oncommand System Manager 2
Opensuse Leap 2
Oracle Mysql Enterprise Monitor 1
Oracle Siebel Ui Framework 1
Oracle Workload Manager 3

- References For CVE-2020-11996

https://www.oracle.com/security-alerts/cpujan2021.html
https://lists.apache.org/thread.html/[email protected]%3Cnotifications.ofbiz.apache.org%3E
MLIST [ofbiz-notifications] 20210301 [jira] [Updated] (OFBIZ-11848) Upgrade Tomcat from 9.0.34 to 9.0.36 (CVE-2020-11996)
https://usn.ubuntu.com/4596-1/
UBUNTU USN-4596-1
https://lists.apache.org/thread.html/[email protected]%3Cusers.tomcat.apache.org%3E
MLIST [tomcat-users] 20201008 Is Tomcat7 supports HTTP2
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00072.html
SUSE openSUSE-SU-2020:1063
https://www.debian.org/security/2020/dsa-4727
DEBIAN DSA-4727
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00064.html
SUSE openSUSE-SU-2020:1051
https://security.netapp.com/advisory/ntap-20200709-0002/ CONFIRM
https://lists.debian.org/debian-lts-announce/2020/07/msg00010.html
MLIST [debian-lts-announce] 20200712 [SECURITY] [DLA 2279-1] tomcat8 security update
https://lists.apache.org/thread.html/[email protected]%3Cnotifications.ofbiz.apache.org%3E
MLIST [ofbiz-notifications] 20200628 [jira] [Updated] (OFBIZ-11847) CLONE - Upgrade Tomcat from 9.0.34 to 9.0.36 (CVE-2020-11996)
https://lists.apache.org/thread.html/[email protected]%3Cnotifications.ofbiz.apache.org%3E
MLIST [ofbiz-notifications] 20200628 [jira] [Created] (OFBIZ-11848) Upgrade Tomcat from 9.0.34 to 9.0.36 (CVE-2020-11996)
https://lists.apache.org/thread.html/[email protected]%3Cnotifications.ofbiz.apache.org%3E
MLIST [ofbiz-notifications] 20200628 [jira] [Created] (OFBIZ-11847) CLONE - Upgrade Tomcat from 9.0.34 to 9.0.36 (CVE-2020-11996)
https://lists.apache.org/thread.html/[email protected]%3Cnotifications.ofbiz.apache.org%3E
MLIST [ofbiz-notifications] 20200703 [jira] [Comment Edited] (OFBIZ-11848) Upgrade Tomcat from 9.0.34 to 9.0.36 (CVE-2020-11996)
https://lists.apache.org/thread.html/[email protected]%3Cnotifications.ofbiz.apache.org%3E
MLIST [ofbiz-notifications] 20200703 [jira] [Closed] (OFBIZ-11848) Upgrade Tomcat from 9.0.34 to 9.0.36 (CVE-2020-11996)
https://lists.apache.org/thread.html/[email protected]%3Cnotifications.ofbiz.apache.org%3E
MLIST [ofbiz-notifications] 20200703 [jira] [Commented] (OFBIZ-11848) Upgrade Tomcat from 9.0.34 to 9.0.36 (CVE-2020-11996)
https://lists.apache.org/thread.html/[email protected]%3Cnotifications.ofbiz.apache.org%3E
MLIST [ofbiz-notifications] 20200701 [jira] [Reopened] (OFBIZ-11848) Upgrade Tomcat from 9.0.34 to 9.0.36 (CVE-2020-11996)
https://lists.apache.org/thread.html/[email protected]%3Cnotifications.ofbiz.apache.org%3E
MLIST [ofbiz-notifications] 20200628 [jira] [Closed] (OFBIZ-11848) Upgrade Tomcat from 9.0.34 to 9.0.36 (CVE-2020-11996)
https://lists.apache.org/thread.html/[email protected]%3Ccommits.ofbiz.apache.org%3E
MLIST [ofbiz-commits] 20200628 [ofbiz-framework] branch release18.12 updated: Fixed: Upgrades Tomcat to 9.0.36 due to CVE-2020-11996 (OFBIZ-11848)
https://lists.apache.org/thread.html/[email protected]%3Ccommits.ofbiz.apache.org%3E
MLIST [ofbiz-commits] 20200628 [ofbiz-framework] branch release17.12 updated: Fixed: Upgrades Tomcat to 9.0.36 due to CVE-2020-11996 (OFBIZ-11848)
https://lists.apache.org/thread.html/[email protected]%3Cnotifications.ofbiz.apache.org%3E
MLIST [ofbiz-notifications] 20200628 [jira] [Commented] (OFBIZ-11848) Upgrade Tomcat from 9.0.34 to 9.0.36 (CVE-2020-11996)
https://lists.apache.org/thread.html/[email protected]%3Ccommits.ofbiz.apache.org%3E
MLIST [ofbiz-commits] 20200628 [ofbiz-framework] branch trunk updated: Fixed: Upgrades Tomcat to 9.0.36 due to CVE-2020-11996 (OFBIZ-11848)
https://lists.apache.org/thread.html/r5541ef6b6b68b49f76fc4c45695940116da2bcbe0312ef204a00a2e0%40%3Cannounce.tomcat.apache.org%3E CONFIRM
https://lists.apache.org/thread.html/[email protected]%3Cnotifications.ofbiz.apache.org%3E
MLIST [ofbiz-notifications] 20200628 [jira] [Closed] (OFBIZ-11847) CLONE - Upgrade Tomcat from 9.0.34 to 9.0.36 (CVE-2020-11996)
https://www.oracle.com/security-alerts/cpuoct2020.html

- Metasploit Modules Related To CVE-2020-11996

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.