CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-1122

procps-ng before version 3.3.15 is vulnerable to a local privilege escalation in top. If a user runs top with HOME unset in an attacker-controlled directory, the attacker could achieve privilege escalation by exploiting one of several vulnerabilities in the config_file() function.
Publish Date : 2018-05-23 Last Update Date : 2019-10-02
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.4
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID CWE id is not defined for this vulnerability

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2019:2189: procps-ng security and bug fix update (Moderate) oval:com.redhat.rhsa:def:20192189 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2018-1122

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 12.04 ~~esm~~~ Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 14.04 ~~lts~~~ Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 16.04 ~~lts~~~ Version Details Vulnerabilities
4 OS Canonical Ubuntu Linux 17.10 Version Details Vulnerabilities
5 OS Canonical Ubuntu Linux 18.04 ~~lts~~~ Version Details Vulnerabilities
6 OS Debian Debian Linux 7.0 Version Details Vulnerabilities
7 OS Debian Debian Linux 8.0 Version Details Vulnerabilities
8 OS Debian Debian Linux 9.0 Version Details Vulnerabilities
9 Application Procps-ng Project Procps-ng 3.3.0 Version Details Vulnerabilities
10 Application Procps-ng Project Procps-ng 3.3.1 Version Details Vulnerabilities
11 Application Procps-ng Project Procps-ng 3.3.2 Version Details Vulnerabilities
12 Application Procps-ng Project Procps-ng 3.3.3 Version Details Vulnerabilities
13 Application Procps-ng Project Procps-ng 3.3.4 Version Details Vulnerabilities
14 Application Procps-ng Project Procps-ng 3.3.5 Version Details Vulnerabilities
15 Application Procps-ng Project Procps-ng 3.3.6 Version Details Vulnerabilities
16 Application Procps-ng Project Procps-ng 3.3.7 Version Details Vulnerabilities
17 Application Procps-ng Project Procps-ng 3.3.8 Version Details Vulnerabilities
18 Application Procps-ng Project Procps-ng 3.3.9 Version Details Vulnerabilities
19 Application Procps-ng Project Procps-ng 3.3.10 Version Details Vulnerabilities
20 Application Procps-ng Project Procps-ng 3.3.11 Version Details Vulnerabilities
21 Application Procps-ng Project Procps-ng 3.3.12 Version Details Vulnerabilities
22 Application Procps-ng Project Procps-ng 3.3.13 - Version Details Vulnerabilities
23 Application Procps-ng Project Procps-ng 3.3.13 RC1 Version Details Vulnerabilities
24 Application Procps-ng Project Procps-ng 3.3.14 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 5
Debian Debian Linux 3
Procps-ng Project Procps-ng 16

- References For CVE-2018-1122

https://lists.debian.org/debian-lts-announce/2018/05/msg00021.html
MLIST [debian-lts-announce] 20180531 [SECURITY] [DLA 1390-1] procps security update
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1122 CONFIRM
https://access.redhat.com/errata/RHSA-2019:2189
REDHAT RHSA-2019:2189
https://www.exploit-db.com/exploits/44806/
EXPLOIT-DB 44806
https://www.qualys.com/2018/05/17/procps-ng-audit-report-advisory.txt
https://www.debian.org/security/2018/dsa-4208
DEBIAN DSA-4208
https://usn.ubuntu.com/3658-1/
UBUNTU USN-3658-1
https://usn.ubuntu.com/3658-3/
UBUNTU USN-3658-3
https://security.gentoo.org/glsa/201805-14
GENTOO GLSA-201805-14
http://seclists.org/oss-sec/2018/q2/122
MLIST [oss-security] 20180517 Qualys Security Advisory - Procps-ng Audit Report
http://www.securityfocus.com/bid/104214
BID 104214 Procps-ng Procps Multiple Security Vulnerabilities Release Date:2018-05-17

- Metasploit Modules Related To CVE-2018-1122

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.