CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2017-7486

PostgreSQL versions 8.4 - 9.6 are vulnerable to information leak in pg_user_mappings view which discloses foreign server passwords to any user having USAGE privilege on the associated foreign server.
Publish Date : 2017-05-12 Last Update Date : 2018-01-04
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Obtain Information
CWE ID 200

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2017:1983: postgresql security and enhancement update (Moderate) oval:com.redhat.rhsa:def:20171983 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2017-7486

# Product Type Vendor Product Version Update Edition Language
1 Application Postgresql Postgresql 8.4 Version Details Vulnerabilities
2 Application Postgresql Postgresql 8.4.1 Version Details Vulnerabilities
3 Application Postgresql Postgresql 8.4.2 Version Details Vulnerabilities
4 Application Postgresql Postgresql 8.4.3 Version Details Vulnerabilities
5 Application Postgresql Postgresql 8.4.4 Version Details Vulnerabilities
6 Application Postgresql Postgresql 8.4.5 Version Details Vulnerabilities
7 Application Postgresql Postgresql 8.4.6 Version Details Vulnerabilities
8 Application Postgresql Postgresql 8.4.7 Version Details Vulnerabilities
9 Application Postgresql Postgresql 8.4.8 Version Details Vulnerabilities
10 Application Postgresql Postgresql 8.4.9 Version Details Vulnerabilities
11 Application Postgresql Postgresql 8.4.10 Version Details Vulnerabilities
12 Application Postgresql Postgresql 8.4.11 Version Details Vulnerabilities
13 Application Postgresql Postgresql 8.4.12 Version Details Vulnerabilities
14 Application Postgresql Postgresql 8.4.13 Version Details Vulnerabilities
15 Application Postgresql Postgresql 8.4.14 Version Details Vulnerabilities
16 Application Postgresql Postgresql 8.4.15 Version Details Vulnerabilities
17 Application Postgresql Postgresql 8.4.16 Version Details Vulnerabilities
18 Application Postgresql Postgresql 8.4.17 Version Details Vulnerabilities
19 Application Postgresql Postgresql 8.4.18 Version Details Vulnerabilities
20 Application Postgresql Postgresql 8.4.19 Version Details Vulnerabilities
21 Application Postgresql Postgresql 8.4.20 Version Details Vulnerabilities
22 Application Postgresql Postgresql 8.4.21 Version Details Vulnerabilities
23 Application Postgresql Postgresql 8.4.22 Version Details Vulnerabilities
24 Application Postgresql Postgresql 9.0 Version Details Vulnerabilities
25 Application Postgresql Postgresql 9.0.1 Version Details Vulnerabilities
26 Application Postgresql Postgresql 9.0.2 Version Details Vulnerabilities
27 Application Postgresql Postgresql 9.0.3 Version Details Vulnerabilities
28 Application Postgresql Postgresql 9.0.4 Version Details Vulnerabilities
29 Application Postgresql Postgresql 9.0.5 Version Details Vulnerabilities
30 Application Postgresql Postgresql 9.0.6 Version Details Vulnerabilities
31 Application Postgresql Postgresql 9.0.7 Version Details Vulnerabilities
32 Application Postgresql Postgresql 9.0.8 Version Details Vulnerabilities
33 Application Postgresql Postgresql 9.0.9 Version Details Vulnerabilities
34 Application Postgresql Postgresql 9.0.10 Version Details Vulnerabilities
35 Application Postgresql Postgresql 9.0.11 Version Details Vulnerabilities
36 Application Postgresql Postgresql 9.0.12 Version Details Vulnerabilities
37 Application Postgresql Postgresql 9.0.13 Version Details Vulnerabilities
38 Application Postgresql Postgresql 9.0.14 Version Details Vulnerabilities
39 Application Postgresql Postgresql 9.0.15 Version Details Vulnerabilities
40 Application Postgresql Postgresql 9.0.16 Version Details Vulnerabilities
41 Application Postgresql Postgresql 9.0.17 Version Details Vulnerabilities
42 Application Postgresql Postgresql 9.0.18 Version Details Vulnerabilities
43 Application Postgresql Postgresql 9.0.19 Version Details Vulnerabilities
44 Application Postgresql Postgresql 9.0.20 Version Details Vulnerabilities
45 Application Postgresql Postgresql 9.0.21 Version Details Vulnerabilities
46 Application Postgresql Postgresql 9.0.22 Version Details Vulnerabilities
47 Application Postgresql Postgresql 9.0.23 Version Details Vulnerabilities
48 Application Postgresql Postgresql 9.1 Version Details Vulnerabilities
49 Application Postgresql Postgresql 9.1.1 Version Details Vulnerabilities
50 Application Postgresql Postgresql 9.1.2 Version Details Vulnerabilities
51 Application Postgresql Postgresql 9.1.3 Version Details Vulnerabilities
52 Application Postgresql Postgresql 9.1.4 Version Details Vulnerabilities
53 Application Postgresql Postgresql 9.1.5 Version Details Vulnerabilities
54 Application Postgresql Postgresql 9.1.6 Version Details Vulnerabilities
55 Application Postgresql Postgresql 9.1.7 Version Details Vulnerabilities
56 Application Postgresql Postgresql 9.1.8 Version Details Vulnerabilities
57 Application Postgresql Postgresql 9.1.9 Version Details Vulnerabilities
58 Application Postgresql Postgresql 9.1.10 Version Details Vulnerabilities
59 Application Postgresql Postgresql 9.1.11 Version Details Vulnerabilities
60 Application Postgresql Postgresql 9.1.12 Version Details Vulnerabilities
61 Application Postgresql Postgresql 9.1.13 Version Details Vulnerabilities
62 Application Postgresql Postgresql 9.1.14 Version Details Vulnerabilities
63 Application Postgresql Postgresql 9.1.15 Version Details Vulnerabilities
64 Application Postgresql Postgresql 9.1.16 Version Details Vulnerabilities
65 Application Postgresql Postgresql 9.1.17 Version Details Vulnerabilities
66 Application Postgresql Postgresql 9.1.18 Version Details Vulnerabilities
67 Application Postgresql Postgresql 9.1.19 Version Details Vulnerabilities
68 Application Postgresql Postgresql 9.1.20 Version Details Vulnerabilities
69 Application Postgresql Postgresql 9.1.21 Version Details Vulnerabilities
70 Application Postgresql Postgresql 9.1.22 Version Details Vulnerabilities
71 Application Postgresql Postgresql 9.1.23 Version Details Vulnerabilities
72 Application Postgresql Postgresql 9.1.24 Version Details Vulnerabilities
73 Application Postgresql Postgresql 9.2 Version Details Vulnerabilities
74 Application Postgresql Postgresql 9.2.1 Version Details Vulnerabilities
75 Application Postgresql Postgresql 9.2.2 Version Details Vulnerabilities
76 Application Postgresql Postgresql 9.2.3 Version Details Vulnerabilities
77 Application Postgresql Postgresql 9.2.4 Version Details Vulnerabilities
78 Application Postgresql Postgresql 9.2.5 Version Details Vulnerabilities
79 Application Postgresql Postgresql 9.2.6 Version Details Vulnerabilities
80 Application Postgresql Postgresql 9.2.7 Version Details Vulnerabilities
81 Application Postgresql Postgresql 9.2.8 Version Details Vulnerabilities
82 Application Postgresql Postgresql 9.2.9 Version Details Vulnerabilities
83 Application Postgresql Postgresql 9.2.10 Version Details Vulnerabilities
84 Application Postgresql Postgresql 9.2.11 Version Details Vulnerabilities
85 Application Postgresql Postgresql 9.2.12 Version Details Vulnerabilities
86 Application Postgresql Postgresql 9.2.13 Version Details Vulnerabilities
87 Application Postgresql Postgresql 9.2.14 Version Details Vulnerabilities
88 Application Postgresql Postgresql 9.2.15 Version Details Vulnerabilities
89 Application Postgresql Postgresql 9.2.16 Version Details Vulnerabilities
90 Application Postgresql Postgresql 9.2.17 Version Details Vulnerabilities
91 Application Postgresql Postgresql 9.2.18 Version Details Vulnerabilities
92 Application Postgresql Postgresql 9.2.19 Version Details Vulnerabilities
93 Application Postgresql Postgresql 9.2.20 Version Details Vulnerabilities
94 Application Postgresql Postgresql 9.2.21 Version Details Vulnerabilities
95 Application Postgresql Postgresql 9.3 Version Details Vulnerabilities
96 Application Postgresql Postgresql 9.3.1 Version Details Vulnerabilities
97 Application Postgresql Postgresql 9.3.2 Version Details Vulnerabilities
98 Application Postgresql Postgresql 9.3.3 Version Details Vulnerabilities
99 Application Postgresql Postgresql 9.3.4 Version Details Vulnerabilities
100 Application Postgresql Postgresql 9.3.5 Version Details Vulnerabilities
101 Application Postgresql Postgresql 9.3.6 Version Details Vulnerabilities
102 Application Postgresql Postgresql 9.3.7 Version Details Vulnerabilities
103 Application Postgresql Postgresql 9.3.8 Version Details Vulnerabilities
104 Application Postgresql Postgresql 9.3.9 Version Details Vulnerabilities
105 Application Postgresql Postgresql 9.3.10 Version Details Vulnerabilities
106 Application Postgresql Postgresql 9.3.11 Version Details Vulnerabilities
107 Application Postgresql Postgresql 9.3.12 Version Details Vulnerabilities
108 Application Postgresql Postgresql 9.3.13 Version Details Vulnerabilities
109 Application Postgresql Postgresql 9.3.14 Version Details Vulnerabilities
110 Application Postgresql Postgresql 9.3.15 Version Details Vulnerabilities
111 Application Postgresql Postgresql 9.3.16 Version Details Vulnerabilities
112 Application Postgresql Postgresql 9.3.17 Version Details Vulnerabilities
113 Application Postgresql Postgresql 9.4 Version Details Vulnerabilities
114 Application Postgresql Postgresql 9.4.1 Version Details Vulnerabilities
115 Application Postgresql Postgresql 9.4.2 Version Details Vulnerabilities
116 Application Postgresql Postgresql 9.4.3 Version Details Vulnerabilities
117 Application Postgresql Postgresql 9.4.4 Version Details Vulnerabilities
118 Application Postgresql Postgresql 9.4.5 Version Details Vulnerabilities
119 Application Postgresql Postgresql 9.4.6 Version Details Vulnerabilities
120 Application Postgresql Postgresql 9.4.7 Version Details Vulnerabilities
121 Application Postgresql Postgresql 9.4.8 Version Details Vulnerabilities
122 Application Postgresql Postgresql 9.4.9 Version Details Vulnerabilities
123 Application Postgresql Postgresql 9.4.10 Version Details Vulnerabilities
124 Application Postgresql Postgresql 9.4.11 Version Details Vulnerabilities
125 Application Postgresql Postgresql 9.4.12 Version Details Vulnerabilities
126 Application Postgresql Postgresql 9.5 Version Details Vulnerabilities
127 Application Postgresql Postgresql 9.5.1 Version Details Vulnerabilities
128 Application Postgresql Postgresql 9.5.2 Version Details Vulnerabilities
129 Application Postgresql Postgresql 9.5.3 Version Details Vulnerabilities
130 Application Postgresql Postgresql 9.5.4 Version Details Vulnerabilities
131 Application Postgresql Postgresql 9.5.5 Version Details Vulnerabilities
132 Application Postgresql Postgresql 9.5.6 Version Details Vulnerabilities
133 Application Postgresql Postgresql 9.5.7 Version Details Vulnerabilities
134 Application Postgresql Postgresql 9.6 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Postgresql Postgresql 134

- References For CVE-2017-7486

https://security.gentoo.org/glsa/201710-06
GENTOO GLSA-201710-06
https://www.postgresql.org/about/news/1746/ CONFIRM
https://access.redhat.com/errata/RHSA-2017:1677
REDHAT RHSA-2017:1677
https://access.redhat.com/errata/RHSA-2017:2425
REDHAT RHSA-2017:2425
https://access.redhat.com/errata/RHSA-2017:1983
REDHAT RHSA-2017:1983
https://access.redhat.com/errata/RHSA-2017:1838
REDHAT RHSA-2017:1838
https://access.redhat.com/errata/RHSA-2017:1678
REDHAT RHSA-2017:1678
http://www.debian.org/security/2017/dsa-3851
DEBIAN DSA-3851
http://www.securityfocus.com/bid/98460
BID 98460 PostgreSQL CVE-2017-7486 Information Disclosure Vulnerability Release Date:2017-08-02
http://www.securitytracker.com/id/1038476
SECTRACK 1038476

- Metasploit Modules Related To CVE-2017-7486

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.