CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities Published In April 2017

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2017-1001000 264 2017-04-02 2017-07-24
5.0
None Remote Low Not required None Partial None
The register_routes function in wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php in the REST API in WordPress 4.7.x before 4.7.2 does not require an integer identifier, which allows remote attackers to modify arbitrary pages via a request for wp-json/wp/v2/posts followed by a numeric value and a non-numeric value, as demonstrated by the wp-json/wp/v2/posts/123?id=123helloworld URI.
2 CVE-2017-1000361 399 2017-04-24 2017-04-27
5.0
None Remote Low Not required None None Partial
DOMRpcImplementationNotAvailableException when sending Port-Status packets to OpenDaylight. Controller launches exceptions and consumes more CPU resources. Component: OpenDaylight is vulnerable to this flaw. Version: The tested versions are OpenDaylight 3.3 and 4.0.
3 CVE-2017-1000360 399 2017-04-24 2017-04-27
5.0
None Remote Low Not required None None Partial
StreamCorruptedException and NullPointerException in OpenDaylight odl-mdsal-xsql. Controller launches exceptions in the console. Component: OpenDaylight odl-mdsal-xsql is vulnerable to this flaw. Version: The tested versions are OpenDaylight 3.3 and 4.0.
4 CVE-2017-1000359 399 2017-04-24 2017-04-27
5.0
None Remote Low Not required None None Partial
Java out of memory error and significant increase in resource consumption. Component: OpenDaylight odl-mdsal-xsql is vulnerable to this flaw. Version: The tested versions are OpenDaylight 3.3 and 4.0.
5 CVE-2017-1000358 399 2017-04-24 2017-04-27
4.0
None Remote Low Single system None None Partial
Controller throws an exception and does not allow user to add subsequent flow for a particular switch. Component: OpenDaylight odl-restconf feature contains this flaw. Version: OpenDaylight 4.0 is affected by this flaw.
6 CVE-2017-1000357 399 DoS 2017-04-24 2017-06-13
5.0
None Remote Low Not required None None Partial
Denial of Service attack when the switch rejects to receive packets from the controller. Component: This vulnerability affects OpenDaylight odl-l2switch-switch, which is the feature responsible for the OpenFlow communication. Version: OpenDaylight versions 3.3 (Lithium-SR3), 3.4 (Lithium-SR4), 4.0 (Beryllium), 4.1 (Beryllium-SR1), 4.2 (Beryllium-SR2), and 4.4 (Beryllium-SR4) are affected by this flaw. Java version is openjdk version 1.8.0_91.
7 CVE-2017-8378 284 DoS Overflow 2017-04-30 2017-05-10
7.5
None Remote Low Not required Partial Partial Partial
Heap-based buffer overflow in the PdfParser::ReadObjects function in base/PdfParser.cpp in PoDoFo 0.9.5 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via vectors related to m_offsets.size.
8 CVE-2017-8374 125 DoS 2017-04-30 2017-05-12
4.3
None Remote Medium Not required None None Partial
The mad_bit_skip function in bit.c in Underbit MAD libmad 0.15.1b allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted audio file.
9 CVE-2017-8373 119 DoS Overflow 2017-04-30 2017-05-12
6.8
None Remote Medium Not required Partial Partial Partial
The mad_layer_III function in layer3.c in Underbit MAD libmad 0.15.1b allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted audio file.
10 CVE-2017-8372 20 DoS 2017-04-30 2017-05-11
2.6
None Remote High Not required None None Partial
The mad_layer_III function in layer3.c in Underbit MAD libmad 0.15.1b, if NDEBUG is omitted, allows remote attackers to cause a denial of service (assertion failure and application exit) via a crafted audio file.
11 CVE-2017-8371 200 +Info 2017-04-30 2017-05-12
4.0
None Remote Low Single system Partial None None
Schneider Electric StruxureWare Data Center Expert before 7.4.0 uses cleartext RAM storage for passwords, which might allow remote attackers to obtain sensitive information via unspecified vectors.
12 CVE-2017-8367 119 DoS Overflow 2017-04-30 2017-05-17
4.6
None Local Low Not required Partial Partial Partial
Buffer overflow in Ether Software Easy MOV Converter 1.4.24, Easy DVD Creator, Easy MPEG/AVI/DIVX/WMV/RM to DVD, Easy Avi/Divx/Xvid to DVD Burner, Easy MPEG to DVD Burner, Easy WMV/ASF/ASX to DVD Burner, Easy RM RMVB to DVD Burner, Easy CD DVD Copy, MP3/AVI/MPEG/WMV/RM to Audio CD Burner, MP3/WAV/OGG/WMA/AC3 to CD Burner, MP3 WAV to CD Burner, My Video Converter, Easy AVI DivX Converter, Easy Video to iPod Converter, Easy Video to PSP Converter, Easy Video to 3GP Converter, Easy Video to MP4 Converter, and Easy Video to iPod/MP4/PSP/3GP Converter allows local attackers to cause a denial of service (SEH overwrite) or possibly have unspecified other impact via a long username.
13 CVE-2017-8366 119 DoS Overflow 2017-04-30 2017-05-10
7.5
None Remote Low Not required Partial Partial Partial
The strescape function in ec_strings.c in Ettercap 0.8.2 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted filter that is mishandled by etterfilter.
14 CVE-2017-8365 119 DoS Overflow 2017-04-30 2017-05-05
4.3
None Remote Medium Not required None None Partial
The i2les_array function in pcm.c in libsndfile 1.0.28 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file.
15 CVE-2017-8364 119 DoS Overflow 2017-04-30 2017-05-10
6.8
None Remote Medium Not required Partial Partial Partial
The read_buf function in stream.c in rzip 2.1 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted archive.
16 CVE-2017-8363 119 DoS Overflow 2017-04-30 2017-05-05
4.3
None Remote Medium Not required None None Partial
The flac_buffer_copy function in flac.c in libsndfile 1.0.28 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted audio file.
17 CVE-2017-8362 125 DoS 2017-04-30 2017-05-05
4.3
None Remote Medium Not required None None Partial
The flac_buffer_copy function in flac.c in libsndfile 1.0.28 allows remote attackers to cause a denial of service (invalid read and application crash) via a crafted audio file.
18 CVE-2017-8361 119 DoS Overflow 2017-04-30 2017-05-05
4.3
None Remote Medium Not required None None Partial
The flac_buffer_copy function in flac.c in libsndfile 1.0.28 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other impact via a crafted audio file.
19 CVE-2017-8359 787 2017-04-30 2017-05-11
7.5
None Remote Low Not required Partial Partial Partial
Google gRPC before 2017-03-29 has an out-of-bounds write caused by a heap-based use-after-free related to the grpc_call_destroy function in core/lib/surface/call.c.
20 CVE-2017-8358 787 Overflow 2017-04-30 2017-05-19
7.5
None Remote Low Not required Partial Partial Partial
LibreOffice before 2017-03-17 has an out-of-bounds write caused by a heap-based buffer overflow related to the ReadJPEG function in vcl/source/filter/jpeg/jpegc.cxx.
21 CVE-2017-8357 119 DoS Overflow 2017-04-30 2017-05-11
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadEPTImage function in ept.c allows attackers to cause a denial of service (memory leak) via a crafted file.
22 CVE-2017-8356 119 DoS Overflow 2017-04-30 2017-05-11
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadSUNImage function in sun.c allows attackers to cause a denial of service (memory leak) via a crafted file.
23 CVE-2017-8355 119 DoS Overflow 2017-04-30 2017-05-11
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadMTVImage function in mtv.c allows attackers to cause a denial of service (memory leak) via a crafted file.
24 CVE-2017-8354 119 DoS Overflow 2017-04-30 2017-05-11
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadBMPImage function in bmp.c allows attackers to cause a denial of service (memory leak) via a crafted file.
25 CVE-2017-8353 119 DoS Overflow 2017-04-30 2017-05-11
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadPICTImage function in pict.c allows attackers to cause a denial of service (memory leak) via a crafted file.
26 CVE-2017-8352 119 DoS Overflow 2017-04-30 2017-05-11
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadXWDImage function in xwd.c allows attackers to cause a denial of service (memory leak) via a crafted file.
27 CVE-2017-8351 119 DoS Overflow 2017-04-30 2017-05-11
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadPCDImage function in pcd.c allows attackers to cause a denial of service (memory leak) via a crafted file.
28 CVE-2017-8350 119 DoS Overflow 2017-04-30 2017-05-11
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadJNGImage function in png.c allows attackers to cause a denial of service (memory leak) via a crafted file.
29 CVE-2017-8349 119 DoS Overflow 2017-04-30 2017-05-11
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadSFWImage function in sfw.c allows attackers to cause a denial of service (memory leak) via a crafted file.
30 CVE-2017-8348 119 DoS Overflow 2017-04-30 2017-05-11
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadMATImage function in mat.c allows attackers to cause a denial of service (memory leak) via a crafted file.
31 CVE-2017-8347 119 DoS Overflow 2017-04-30 2017-05-10
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadEXRImage function in exr.c allows attackers to cause a denial of service (memory leak) via a crafted file.
32 CVE-2017-8346 119 DoS Overflow 2017-04-30 2017-05-10
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadDCMImage function in dcm.c allows attackers to cause a denial of service (memory leak) via a crafted file.
33 CVE-2017-8345 119 DoS Overflow 2017-04-30 2017-05-08
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadMNGImage function in png.c allows attackers to cause a denial of service (memory leak) via a crafted file.
34 CVE-2017-8344 119 DoS Overflow 2017-04-30 2017-05-08
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadPCXImage function in pcx.c allows attackers to cause a denial of service (memory leak) via a crafted file.
35 CVE-2017-8343 119 DoS Overflow 2017-04-30 2017-05-08
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.5-5, the ReadAAIImage function in aai.c allows attackers to cause a denial of service (memory leak) via a crafted file.
36 CVE-2017-8342 362 2017-04-30 2017-05-11
4.3
None Remote Medium Not required Partial None None
Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.
37 CVE-2017-8339 DoS 2017-04-30 2017-07-17
4.9
None Local Low Not required None None Complete
PSKMAD.sys in Panda Free Antivirus 18.0 allows local users to cause a denial of service (BSoD) via a crafted DeviceIoControl request to \\.\PSMEMDriver.
38 CVE-2017-8327 399 DoS 2017-04-29 2017-06-30
7.1
None Remote Medium Not required None None Complete
The bmpr_read_uncompressed function in imagew-bmp.c in libimageworsener.a in ImageWorsener before 1.3.1 allows remote attackers to cause a denial of service (memory consumption) via a crafted image.
39 CVE-2017-8326 19 DoS 2017-04-29 2017-06-30
6.8
None Remote Medium Not required Partial Partial Partial
libimageworsener.a in ImageWorsener before 1.3.1 has "left shift cannot be represented in type int" undefined behavior issues, which might allow remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted image, related to imagew-bmp.c and imagew-util.c.
40 CVE-2017-8325 119 DoS Overflow 2017-04-29 2017-06-30
6.8
None Remote Medium Not required Partial Partial Partial
The iw_process_cols_to_intermediate function in imagew-main.c in libimageworsener.a in ImageWorsener before 1.3.1 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted image.
41 CVE-2017-8308 264 Bypass 2017-04-27 2017-05-09
5.0
None Remote Low Not required None Partial None
In Avast Antivirus before v17, an unprivileged user (and thus malware or a virus) can mark an arbitrary process as Trusted from the perspective of the Avast product. This bypasses the Self-Defense feature of the product, opening a door to subsequent attack on many of its components.
42 CVE-2017-8307 254 DoS 2017-04-27 2017-05-09
7.5
None Remote Low Not required Partial Partial Partial
In Avast Antivirus before v17, using the LPC interface API exposed by the AvastSVC.exe Windows service, it is possible to launch predefined binaries, or replace or delete arbitrary files. This vulnerability is exploitable by any unprivileged user when Avast Self-Defense is disabled. It is also exploitable in conjunction with CVE-2017-8308 when Avast Self-Defense is enabled. The vulnerability allows for Denial of Service attacks and hiding traces of a possible attack.
43 CVE-2017-8305 119 Overflow 2017-04-27 2017-05-09
7.5
None Remote Low Not required Partial Partial Partial
The UDFclient (before 0.8.8) custom strlcpy implementation has a buffer overflow. UDFclient's strlcpy is used only on systems with a C library (e.g., glibc) that lacks its own strlcpy.
44 CVE-2017-8302 79 XSS 2017-04-27 2017-05-09
3.5
None Remote Medium Single system None Partial None
Mura CMS 7.0.6967 allows admin/?muraAction= XSS attacks, related to admin/core/views/carch/list.cfm, admin/core/views/carch/loadsiteflat.cfm, admin/core/views/cusers/inc/dsp_nextn.cfm, admin/core/views/cusers/inc/dsp_search_form.cfm, admin/core/views/cusers/inc/dsp_users_list.cfm, admin/core/views/cusers/list.cfm, and admin/core/views/cusers/listusers.cfm.
45 CVE-2017-8301 254 2017-04-27 2017-05-10
2.6
None Remote High Not required None Partial None
LibreSSL 2.5.1 to 2.5.3 lacks TLS certificate verification if SSL_get_verify_result is relied upon for a later check of a verification result, in a use case where a user-provided verification callback returns 1, as demonstrated by acceptance of invalid certificates by nginx.
46 CVE-2017-8298 79 XSS 2017-04-27 2017-05-03
3.5
None Remote Medium Single system None Partial None
cnvs.io Canvas 3.3.0 has XSS in the title and content fields of a "Posts > Add New" action, and during creation of new tags and users.
47 CVE-2017-8297 22 Dir. Trav. 2017-04-27 2017-05-10
7.5
None Remote Low Not required Partial Partial Partial
A path traversal vulnerability exists in simple-file-manager before 2017-04-26, affecting index.php (the sole "Simple PHP File Manager" component).
48 CVE-2017-8296 200 +Info 2017-04-27 2017-05-10
5.0
None Remote Low Not required Partial None None
kedpm 0.5 and 1.0 creates a history file in ~/.kedpm/history that is written in cleartext. All of the commands performed in the password manager are written there. This can lead to the disclosure of the master password if the "password" command is used with an argument. The names of the password entries created and consulted are also accessible in cleartext.
49 CVE-2017-8294 125 DoS 2017-04-27 2017-05-03
5.0
None Remote Low Not required None None Partial
libyara/re.c in the regex component in YARA 3.5.0 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted rule that is mishandled in the yr_re_exec function.
50 CVE-2017-8291 704 Exec Code Bypass 2017-04-26 2017-08-15
6.8
None Remote Medium Not required Partial Partial Partial
Artifex Ghostscript through 2017-04-26 allows -dSAFER bypass and remote command execution via .rsdparams type confusion with a "/OutputFile (%pipe%" substring in a crafted .eps document that is an input to the gs program, as exploited in the wild in April 2017.
Total number of vulnerabilities : 1571   Page : 1 (This Page)2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.