CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

IBM : Security Vulnerabilities Published In 2001

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2001-1567 Bypass 2001-12-31 2008-09-05
5.0
None Remote Low Not required Partial None None
Lotus Domino server 5.0.9a and earlier allows remote attackers to bypass security restrictions and view Notes database files and possibly sensitive Notes template files (.ntf) via an HTTP request with a large number of "+" characters before the .nsf file extension, which are converted to spaces by Domino.
2 CVE-2001-1557 Overflow +Priv 2001-12-31 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflow in ftpd in IBM AIX 4.3 and 5.1 allows attackers to gain privileges.
3 CVE-2001-1554 DoS 2001-12-31 2008-09-05
5.0
None Remote Low Not required None None Partial
IBM AIX 430 does not properly unlock IPPMTU_LOCK, which allows remote attackers to cause a denial of service (hang) via Path Maximum Transmit Unit (PMTU) IP packets.
4 CVE-2001-1529 Overflow 2001-12-31 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflow in rpc.yppasswdd (yppasswd server) in AIX allows attackers to gain unauthorized access via a long string. NOTE: due to lack of details in the vendor advisory, it is not clear if this is the same issue as CVE-2001-0779.
5 CVE-2001-1504 Exec Code 2001-12-31 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Lotus Notes R5 Client 4.6 allows remote attackers to execute arbitrary commands via a Lotus Notes object with code in an event, which is automatically executed when the user processes the e-mail message.
6 CVE-2001-1441 XSS 2001-07-02 2008-09-10
6.8
None Remote Medium Not required Partial Partial Partial
Cross-site scripting (XSS) vulnerability in VisualAge for Java 3.5 Professional allows remote attackers to execute JavaScript on other clients via the URL, which injects the script in the resulting error message.
7 CVE-2001-1440 2001-12-21 2008-09-05
10.0
Admin Remote Low Not required Complete Complete Complete
Unknown vulnerability in login for AIX 5.1L, when using loadable authentication modules, allows remote attackers to gain access to the system.
8 CVE-2001-1330 Overflow +Priv 2001-06-11 2008-09-05
7.2
Admin Local Low Not required Complete Complete Complete
Buffer overflow in rsh on AIX 4.2.0.0 may allow local users to gain root privileges via a long command line argument.
9 CVE-2001-1329 Overflow 2001-06-11 2008-09-05
7.2
Admin Local Low Not required Complete Complete Complete
Buffer overflow in rsh on AIX 4.2.0.0 may allow local users to gain root priveleges via a long command line argument.
10 CVE-2001-1313 DoS Exec Code 2001-07-16 2008-09-10
7.5
User Remote Low Not required Partial Partial Partial
Lotus Domino R5 before R5.0.7a allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via miscellaneous packets with semi-valid BER encodings, as demonstrated by the PROTOS LDAPv3 test suite.
11 CVE-2001-1312 DoS Exec Code 2001-07-16 2008-09-10
7.5
User Remote Low Not required Partial Partial Partial
Format string vulnerabilities in Lotus Domino R5 before R5.0.7a allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, as demonstrated by the PROTOS LDAPv3 test suite.
12 CVE-2001-1311 DoS Exec Code Overflow 2001-07-16 2008-09-10
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflows in Lotus Domino R5 before R5.0.7a allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, as demonstrated by the PROTOS LDAPv3 test suite.
13 CVE-2001-1310 DoS Exec Code 2001-07-16 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
IBM SecureWay 3.2.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, via invalid encodings for the L field of a BER encoding, as demonstrated by the PROTOS LDAPv3 test suite.
14 CVE-2001-1309 DoS Exec Code Overflow 2001-07-16 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflows in IBM SecureWay 3.2.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, as demonstrated by the PROTOS LDAPv3 test suite.
15 CVE-2001-1265 Dir. Trav. 2001-07-20 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Directory traversal vulnerability in IBM alphaWorks Java TFTP server 1.21 allows remote attackers to conduct unauthorized operations on arbitrary files via a .. (dot dot) attack.
16 CVE-2001-1191 DoS 2001-12-11 2008-09-05
5.0
None Remote Low Not required None None Partial
WebSeal in IBM Tivoli SecureWay Policy Director 3.8 allows remote attackers to cause a denial of service (crash) via a URL that ends in %2e.
17 CVE-2001-1189 2001-12-13 2008-09-05
4.6
User Local Low Not required Partial Partial Partial
IBM Websphere Application Server 3.5.3 and earlier stores a password in cleartext in the sas.server.props file, which allows local users to obtain the passwords via a JSP script.
18 CVE-2001-1143 DoS 2001-07-11 2008-09-05
5.0
None Remote Low Not required None None Partial
IBM DB2 7.0 allows a remote attacker to cause a denial of service (crash) via a single byte to (1) db2ccs.exe on port 6790, or (2) db2jds.exe on port 6789.
19 CVE-2001-1096 Exec Code Overflow 2001-10-09 2013-07-25
4.6
User Local Low Not required Partial Partial Partial
Buffer overflows in muxatmd in AIX 4 allows an attacker to cause a core dump and possibly execute code.
20 CVE-2001-1095 Exec Code Overflow 2001-10-09 2008-09-05
4.6
User Local Low Not required Partial Partial Partial
Buffer overflow in uuq in AIX 4 could alllow local users to execute arbitrary code via a long -r parameter.
21 CVE-2001-1080 +Priv 2001-06-19 2008-09-05
10.0
Admin Remote Low Not required Complete Complete Complete
diagrpt in AIX 4.3.x and 5.1 uses the DIAGDATADIR environment variable to find and execute certain programs, which allows local users to gain privileges by modifying the variable to point to a Trojan horse program.
22 CVE-2001-1061 2001-08-31 2008-09-05
10.0
None Remote Low Not required Complete Complete Complete
Vulnerability in lsmcode in unknown versions of AIX, possibly related to a usage error.
23 CVE-2001-0998 DoS 2001-09-24 2008-09-05
5.0
None Remote Low Not required None None Partial
IBM HACMP 4.4 allows remote attackers to cause a denial of service via a completed TCP connection to HACMP ports (e.g., using a port scan) that does not send additional data, which causes a failure in snmpd.
24 CVE-2001-0982 Dir. Trav. 2001-07-23 2008-09-05
5.0
None Remote Low Not required Partial None None
Directory traversal vulnerability in IBM Tivoli WebSEAL Policy Director 3.01 through 3.7.1 allows remote attackers to read arbitrary files or directories via encoded .. (dot dot) sequences containing "%2e" strings.
25 CVE-2001-0962 +Priv 2001-09-19 2008-09-05
7.5
None Remote Low Not required Partial Partial Partial
IBM WebSphere Application Server 3.02 through 3.53 uses predictable session IDs for cookies, which allows remote attackers to gain privileges of WebSphere users via brute force guessing.
26 CVE-2001-0924 Dir. Trav. 2001-11-22 2008-09-05
5.0
None Remote Low Not required Partial None None
Directory traversal vulnerability in ifx CGI program in Informix Web DataBlade allows remote attackers to read arbitrary files via a .. (dot dot) in the LO parameter.
27 CVE-2001-0856 2001-12-06 2008-09-10
4.6
None Local Low Not required Partial Partial Partial
Common Cryptographic Architecture (CCA) in IBM 4758 allows an attacker with physical access to the system and Combine_Key_Parts permissions, to steal DES and 3DES keys by using a brute force attack to create a 3DES exporter key.
28 CVE-2001-0824 XSS 2001-12-06 2008-09-10
7.5
None Remote Low Not required Partial Partial Partial
Cross-site scripting vulnerability in IBM WebSphere 3.02 and 3.5 FP2 allows remote attackers to execute Javascript by inserting the Javascript into (1) a request for a .JSP file, or (2) a request to the webapp/examples/ directory, which inserts the Javascript into an error page.
29 CVE-2001-0797 Exec Code Overflow 2001-12-12 2008-09-05
10.0
Admin Remote Low Not required Complete Complete Complete
Buffer overflow in login in various System V based operating systems allows remote attackers to execute arbitrary commands via a large number of arguments through services such as telnet and rlogin.
30 CVE-2001-0671 Overflow +Priv 2001-12-06 2008-09-05
10.0
Admin Remote Low Not required Complete Complete Complete
Buffer overflows in (1) send_status, (2) kill_print, and (3) chk_fhost in lpd in AIX 4.3 and 5.1 allow remote attackers to gain root privileges.
31 CVE-2001-0573 +Priv 2001-08-02 2008-09-05
4.6
User Local Low Not required Partial Partial Partial
lsfs in AIX 4.x allows a local user to gain additional privileges by creating Trojan horse programs named (1) grep or (2) lslv in a certain directory that is under the user's control, which cause lsfs to access the programs in that directory.
32 CVE-2001-0554 Exec Code Overflow 2001-08-14 2008-09-05
10.0
Admin Remote Low Not required Complete Complete Complete
Buffer overflow in BSD-based telnetd telnet daemon on various operating systems allows remote attackers to execute arbitrary commands via a set of options including AYT (Are You There), which is not properly handled by the telrcv function.
33 CVE-2001-0552 Exec Code 2001-09-20 2008-09-05
10.0
Admin Remote Low Not required Complete Complete Complete
ovactiond in HP OpenView Network Node Manager (NNM) 6.1 and Tivoli Netview 5.x and 6.x allows remote attackers to execute arbitrary commands via shell metacharacters in a certain SNMP trap message.
34 CVE-2001-0533 Overflow +Priv 2001-08-14 2008-09-05
7.2
Admin Local Low Not required Complete Complete Complete
Buffer overflow in libi18n library in IBM AIX 5.1 and 4.3.x allows local users to gain root privileges via a long LANG environmental variable.
35 CVE-2001-0487 DoS 2001-06-27 2008-09-10
5.0
None Remote Low Not required None None Partial
AIX SNMP server snmpd allows remote attackers to cause a denial of service via a RST during the TCP connection.
36 CVE-2001-0472 DoS 2001-06-27 2008-09-05
5.0
None Remote Low Not required None None Partial
Hursley Software Laboratories Consumer Transaction Framework (HSLCTF) HTTP object allows remote attackers to cause a denial of service (crash) via an extremely long HTTP request.
37 CVE-2001-0446 2001-06-18 2008-09-05
5.0
None Remote Low Not required Partial None None
IBM WCS (WebSphere Commerce Suite) 4.0.1 with Application Server 3.0.2 allows remote attackers to read source code for .jsp files by appending a / to the requested URL.
38 CVE-2001-0390 DoS 2001-07-02 2008-09-05
5.0
None Remote Low Not required None None Partial
IBM Websphere/NetCommerce3 3.1.2 allows remote attackers to cause a denial of service by directly calling the macro.d2w macro with a long string of %0a characters.
39 CVE-2001-0389 2001-07-02 2008-09-05
5.0
None Remote Low Not required Partial None None
IBM Websphere/NetCommerce3 3.1.2 allows remote attackers to determine the real path of the server by directly calling the macro.d2w macro with a NOEXISTINGHTMLBLOCK argument.
40 CVE-2001-0319 2001-05-03 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
orderdspc.d2w macro in IBM Net.Commerce 3.x allows remote attackers to execute arbitrary SQL queries by inserting them into the order_rn option of the report capability.
41 CVE-2001-0312 Bypass 2001-06-02 2008-09-05
5.0
None Remote Low Not required Partial None None
IBM WebSphere plugin for Netscape Enterprise server allows remote attackers to read source code for JSP files via an HTTP request that contains a host header that references a host that is not in WebSphere's host aliases list, which will bypass WebSphere processing.
42 CVE-2001-0122 DoS 2001-03-13 2008-09-05
5.0
None Remote Low Not required None None Partial
Kernel leak in AfpaCache module of the Fast Response Cache Accelerator (FRCA) component of IBM HTTP Server 1.3.x and Websphere 3.52 allows remote attackers to cause a denial of service via a series of malformed HTTP requests that generate a "bad request" error.
43 CVE-2001-0052 DoS 2001-02-16 2008-09-05
2.1
None Local Low Not required None None Partial
IBM DB2 Universal Database version 6.1 allows users to cause a denial of service via a malformed query.
44 CVE-2001-0051 2001-02-16 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
IBM DB2 Universal Database version 6.1 creates an account with a default user name and password, which allows remote attackers to gain access to the databasse.
45 CVE-2000-1215 +Info 2001-09-19 2008-09-10
5.0
None Remote Low Not required Partial None None
The default configuration of Lotus Domino server 5.0.8 includes system information (version, operating system, and build date) in the HTTP headers of replies, which allows remote attackers to obtain sensitive information.
46 CVE-2000-1202 Exec Code 2001-08-31 2008-09-05
7.2
Admin Local Low Not required Complete Complete Complete
ikeyman in IBM IBMHSSSB 1.0 sets the CLASSPATH environmental variable to include the user's own CLASSPATH directories before the system's directories, which allows a malicious local user to execute arbitrary code as root via a Trojan horse Ikeyman class.
47 CVE-2000-1168 DoS Exec Code 2001-01-09 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
IBM HTTP Server 1.3.6 (based on Apache) allows remote attackers to cause a denial of service and possibly execute arbitrary commands via a long GET request.
48 CVE-2000-1138 2001-01-09 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Lotus Notes R5 client R5.0.5 and earlier does not properly warn users when an S/MIME email message has been modified, which could allow an attacker to modify the email in transit without being detected.
49 CVE-2000-1124 Overflow +Priv 2001-01-09 2008-09-05
7.2
Admin Local Low Not required Complete Complete Complete
Buffer overflow in piobe command in IBM AIX 4.3.x allows local users to gain privileges via long environmental variables.
50 CVE-2000-1123 Exec Code Overflow 2001-01-09 2008-09-05
7.2
Admin Local Low Not required Complete Complete Complete
Buffer overflow in pioout command in IBM AIX 4.3.x and earlier may allow local users to execute arbitrary commands.
Total number of vulnerabilities : 59   Page : 1 (This Page)2
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.