CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Autotrace Project : Security Vulnerabilities

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2017-9200 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-tga.c:528:63.
2 CVE-2017-9199 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-tga.c:192:19.
3 CVE-2017-9198 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-tga.c:508:18.
4 CVE-2017-9197 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-tga.c:498:55.
5 CVE-2017-9196 189 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "negative-size-param" issue in the ReadImage function in input-tga.c:528:7.
6 CVE-2017-9195 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the ReadImage function in input-tga.c:620:27.
7 CVE-2017-9194 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the ReadImage function in input-tga.c:559:29.
8 CVE-2017-9193 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the ReadImage function in input-tga.c:538:33.
9 CVE-2017-9192 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-tga.c:528:7.
10 CVE-2017-9191 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the rle_fread function in input-tga.c:252:15.
11 CVE-2017-9190 416 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid free), related to the free_bitmap function in bitmap.c:24:5.
12 CVE-2017-9189 125 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid read and application crash), related to the GET_COLOR function in color.c:16:11.
13 CVE-2017-9188 20 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "left shift ... cannot be represented in type int" issue in input-bmp.c:516:63.
14 CVE-2017-9187 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-bmp.c:486:7.
15 CVE-2017-9186 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-bmp.c:326:17.
16 CVE-2017-9185 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-bmp.c:319:7.
17 CVE-2017-9184 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-bmp.c:314:7.
18 CVE-2017-9183 704 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-bmp.c:309:7.
19 CVE-2017-9182 416 DoS 2017-05-23 2017-05-29
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (use-after-free and invalid heap read), related to the GET_COLOR function in color.c:16:11.
20 CVE-2017-9181 787 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid write and SEGV), related to the ReadImage function in input-bmp.c.
21 CVE-2017-9180 125 DoS 2017-05-23 2017-05-29
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid read and SEGV), related to the ReadImage function in input-bmp.c:440:14.
22 CVE-2017-9179 125 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid read and SEGV), related to the ReadImage function in input-bmp.c:425:14.
23 CVE-2017-9178 787 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid write and SEGV), related to the ReadImage function in input-bmp.c:421:11.
24 CVE-2017-9177 125 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid read and SEGV), related to the ReadImage function in input-bmp.c:390:12.
25 CVE-2017-9176 787 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid write and SEGV), related to the ReadImage function in input-bmp.c:370:25.
26 CVE-2017-9175 787 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid write and SEGV), related to the ReadImage function in input-bmp.c:353:25.
27 CVE-2017-9174 125 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid read and SEGV), related to the GET_COLOR function in color.c:21:23.
28 CVE-2017-9173 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:497:29.
29 CVE-2017-9172 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:496:29.
30 CVE-2017-9171 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the ReadImage function in input-bmp.c:492:24.
31 CVE-2017-9170 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:370:25.
32 CVE-2017-9169 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:355:25.
33 CVE-2017-9168 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:353:25.
34 CVE-2017-9167 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:337:25.
35 CVE-2017-9166 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the GET_COLOR function in color.c:18:11.
36 CVE-2017-9165 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the GET_COLOR function in color.c:17:11.
37 CVE-2017-9164 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the GET_COLOR function in color.c:16:11.
38 CVE-2017-9163 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in pxl-outline.c:106:54.
39 CVE-2017-9162 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in autotrace.c:191:2.
40 CVE-2017-9161 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in autotrace.c:188:23.
41 CVE-2017-9160 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a stack-based buffer overflow in the pnmscanner_gettoken function in input-pnm.c:458:12.
42 CVE-2017-9159 787 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid write and SEGV), related to the pnm_load_rawpbm function in input-pnm.c:391:15.
43 CVE-2017-9158 787 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid write and SEGV), related to the pnm_load_raw function in input-pnm.c:336:11.
44 CVE-2017-9157 787 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid write and SEGV), related to the pnm_load_ascii function in input-pnm.c:306:14.
45 CVE-2017-9156 787 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid write and SEGV), related to the pnm_load_ascii function in input-pnm.c:303:12.
46 CVE-2017-9155 125 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid read and SEGV), related to the input_pnm_reader function in input-pnm.c:243:3.
47 CVE-2017-9154 125 DoS 2017-05-23 2017-05-28
5.0
None Remote Low Not required None None Partial
libautotrace.a in AutoTrace 0.31.1 allows remote attackers to cause a denial of service (invalid read and SEGV), related to the GET_COLOR function in color.c:16:11.
48 CVE-2017-9153 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the pnm_load_rawpbm function in input-pnm.c:391:13.
49 CVE-2017-9152 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the pnm_load_raw function in input-pnm.c:346:41.
50 CVE-2017-9151 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the pnm_load_ascii function in input-pnm.c:303:12.
Total number of vulnerabilities : 52   Page : 1 (This Page)2
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.