CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities Related To CWE-119

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2017-6300 119 Overflow 2017-02-23 2017-02-24
6.8
None Remote Medium Not required Partial Partial Partial
An issue was discovered in ytnef before 1.9.1. This is related to a patch described as "3 of 9. Buffer Overflow in version field in lib/tnef-types.h."
2 CVE-2017-6187 119 Exec Code Overflow 2017-02-22 2017-02-23
7.5
None Remote Low Not required Partial Partial Partial
Buffer overflow in the built-in web server in DiskSavvy Enterprise 9.4.18 allows remote attackers to execute arbitrary code via a long URI in a GET request.
3 CVE-2017-6010 119 Overflow 2017-02-16 2017-02-23
4.3
None Remote Medium Not required None None Partial
An issue was discovered in icoutils 0.31.1. A buffer overflow was observed in the "extract_icons" function in the "extract.c" source file. This issue can be triggered by processing a corrupted ico file and will result in an icotool crash.
4 CVE-2017-6009 119 Overflow 2017-02-16 2017-02-23
4.3
None Remote Medium Not required None None Partial
An issue was discovered in icoutils 0.31.1. A buffer overflow was observed in the "decode_ne_resource_id" function in the "restable.c" source file. This is happening because the "len" parameter for memcpy is not checked for size and thus becomes a negative integer in the process, resulting in a failed memcpy. This affects wrestool.
5 CVE-2017-5881 119 DoS Overflow Mem. Corr. 2017-02-21 2017-02-23
6.8
None Remote Medium Not required Partial Partial Partial
GOM Player 2.3.10.5266 allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a crafted fpx file.
6 CVE-2017-5563 119 Exec Code Overflow 2017-01-23 2017-01-26
6.8
None Remote Medium Not required Partial Partial Partial
LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in DoS or code execution via a crafted bmp image to tools/bmp2tiff.
7 CVE-2017-5495 119 Overflow 2017-01-24 2017-01-26
7.8
None Remote Low Not required None None Complete
All versions of Quagga, 0.93 through 1.1.0, are vulnerable to an unbounded memory allocation in the telnet 'vty' CLI, leading to a Denial-of-Service of Quagga daemons, or even the entire host. When Quagga daemons are configured with their telnet CLI enabled, anyone who can connect to the TCP ports can trigger this vulnerability, prior to authentication. Most distributions restrict the Quagga telnet interface to local access only by default. The Quagga telnet interface 'vty' input buffer grows automatically, without bound, so long as a newline is not entered. This allows an attacker to cause the Quagga daemon to allocate unbounded memory by sending very long strings without a newline. Eventually the daemon is terminated by the system, or the system itself runs out of memory. This is fixed in Quagga 1.1.1 and Free Range Routing (FRR) Protocol Suite 2017-01-10.
8 CVE-2017-5486 119 Overflow 2017-01-27 2017-02-01
7.5
None Remote Low Not required Partial Partial Partial
The ISO CLNS parser in tcpdump before 4.9.0 has a buffer overflow in print-isoclns.c:clnp_print().
9 CVE-2017-5485 119 Overflow 2017-01-27 2017-02-01
7.5
None Remote Low Not required Partial Partial Partial
The ISO CLNS parser in tcpdump before 4.9.0 has a buffer overflow in addrtoname.c:lookup_nsap().
10 CVE-2017-5484 119 Overflow 2017-01-27 2017-02-01
7.5
None Remote Low Not required Partial Partial Partial
The ATM parser in tcpdump before 4.9.0 has a buffer overflow in print-atm.c:sig_print().
11 CVE-2017-5483 119 Overflow 2017-01-27 2017-02-01
7.5
None Remote Low Not required Partial Partial Partial
The SNMP parser in tcpdump before 4.9.0 has a buffer overflow in print-snmp.c:asn1_parse().
12 CVE-2017-5482 119 Overflow 2017-01-27 2017-02-01
7.5
None Remote Low Not required Partial Partial Partial
The Q.933 parser in tcpdump before 4.9.0 has a buffer overflow in print-fr.c:q933_print(), a different vulnerability than CVE-2016-8575.
13 CVE-2017-5364 119 DoS Exec Code Overflow Mem. Corr. 2017-01-13 2017-02-02
6.8
None Remote Medium Not required Partial Partial Partial
Memory Corruption Vulnerability in Foxit PDF Toolkit v1.3 allows an attacker to cause Denial of Service and Remote Code Execution when the victim opens the specially crafted PDF file. The Vulnerability has been fixed in v2.0.
14 CVE-2017-5342 119 Overflow 2017-01-27 2017-02-01
7.5
None Remote Low Not required Partial Partial Partial
In tcpdump before 4.9.0, a bug in multiple protocol parsers (Geneve, GRE, NSH, OTV, VXLAN and VXLAN GPE) could cause a buffer overflow in print-ether.c:ether_print().
15 CVE-2017-5341 119 Overflow 2017-01-27 2017-02-01
7.5
None Remote Low Not required Partial Partial Partial
The OTV parser in tcpdump before 4.9.0 has a buffer overflow in print-otv.c:otv_print().
16 CVE-2017-5225 119 Exec Code Overflow 2017-01-12 2017-01-27
7.5
None Remote Low Not required Partial Partial Partial
LibTIFF version 4.0.7 is vulnerable to a heap buffer overflow in the tools/tiffcp resulting in DoS or code execution via a crafted BitsPerSample value.
17 CVE-2017-5216 119 Overflow 2017-01-09 2017-01-10
4.3
None Remote Medium Not required None None Partial
Stack-based buffer overflow vulnerability in Netop Remote Control versions 11.53, 12.21 and prior. The affected module in the Guest client is the "Import to Phonebook" option. When a specially designed malicious file containing special characters is loaded, the overflow occurs. 12.51 is the fixed version. The Support case ref is 00109744.
18 CVE-2017-5209 119 DoS Overflow +Info 2017-01-11 2017-01-13
6.4
None Remote Low Not required Partial None Partial
The base64decode function in base64.c in libimobiledevice libplist through 1.12 allows attackers to obtain sensitive information from process memory or cause a denial of service (buffer over-read) via split encoded Apple Property List data.
19 CVE-2017-5205 119 Overflow 2017-01-27 2017-02-01
7.5
None Remote Low Not required Partial Partial Partial
The ISAKMP parser in tcpdump before 4.9.0 has a buffer overflow in print-isakmp.c:ikev2_e_print().
20 CVE-2017-5204 119 Overflow 2017-01-27 2017-02-01
7.5
None Remote Low Not required Partial Partial Partial
The IPv6 parser in tcpdump before 4.9.0 has a buffer overflow in print-ip6.c:ip6_print().
21 CVE-2017-5203 119 Overflow 2017-01-27 2017-02-01
7.5
None Remote Low Not required Partial Partial Partial
The BOOTP parser in tcpdump before 4.9.0 has a buffer overflow in print-bootp.c:bootp_print().
22 CVE-2017-5202 119 Overflow 2017-01-27 2017-02-01
7.5
None Remote Low Not required Partial Partial Partial
The ISO CLNS parser in tcpdump before 4.9.0 has a buffer overflow in print-isoclns.c:clnp_print().
23 CVE-2017-5025 119 Overflow 2017-02-17 2017-02-17
4.3
None Remote Medium Not required None None Partial
FFmpeg in Google Chrome prior to 56.0.2924.76 for Linux, Windows and Mac, failed to perform proper bounds checking, which allowed a remote attacker to potentially exploit heap corruption via a crafted video file.
24 CVE-2017-5024 119 Overflow 2017-02-17 2017-02-23
4.3
None Remote Medium Not required None None Partial
FFmpeg in Google Chrome prior to 56.0.2924.76 for Linux, Windows and Mac, failed to perform proper bounds checking, which allowed a remote attacker to potentially exploit heap corruption via a crafted video file.
25 CVE-2017-5014 119 Overflow 2017-02-17 2017-02-17
6.8
None Remote Medium Not required Partial Partial Partial
Heap buffer overflow during image processing in Skia in Google Chrome prior to 56.0.2924.76 for Linux, Windows and Mac, and 56.0.2924.87 for Android, allowed a remote attacker to perform an out of bounds memory read via a crafted HTML page.
26 CVE-2017-5012 119 Overflow 2017-02-17 2017-02-17
6.8
None Remote Medium Not required Partial Partial Partial
A heap buffer overflow in V8 in Google Chrome prior to 56.0.2924.76 for Linux, Windows and Mac, and 56.0.2924.87 for Android, allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
27 CVE-2017-5009 119 Overflow 2017-02-17 2017-02-17
6.8
None Remote Medium Not required Partial Partial Partial
WebRTC in Google Chrome prior to 56.0.2924.76 for Linux, Windows and Mac, and 56.0.2924.87 for Android, failed to perform proper bounds checking, which allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
28 CVE-2017-5005 119 Exec Code Overflow 2017-01-02 2017-01-03
7.5
None Remote Low Not required Partial Partial Partial
Stack-based buffer overflow in Quick Heal Internet Security 10.1.0.316 and earlier, Total Security 10.1.0.316 and earlier, and AntiVirus Pro 10.1.0.316 and earlier on OS X allows remote attackers to execute arbitrary code via a crafted LC_UNIXTHREAD.cmdsize field in a Mach-O file that is mishandled during a Security Scan (aka Custom Scan) operation.
29 CVE-2017-3824 119 DoS Overflow 2017-02-03 2017-02-23
5.4
None Remote High Not required None None Complete
A vulnerability in the handling of list headers in Cisco cBR Series Converged Broadband Routers could allow an unauthenticated, remote attacker to cause the device to reload, resulting in a denial of service (DoS) condition. Cisco cBR-8 Converged Broadband Routers running vulnerable versions of Cisco IOS XE are affected. More Information: CSCux40637. Known Affected Releases: 15.5(3)S 15.6(1)S. Known Fixed Releases: 15.5(3)S2 15.6(1)S1 15.6(2)S 15.6(2)SP 16.4(1).
30 CVE-2017-3823 119 Exec Code Overflow 2017-02-01 2017-02-24
9.3
None Remote Medium Not required Complete Complete Complete
An issue was discovered in the Cisco WebEx Extension before 1.0.7 on Google Chrome, the ActiveTouch General Plugin Container before 106 on Mozilla Firefox, the GpcContainer Class ActiveX control plugin before 10031.6.2017.0126 on Internet Explorer, and the Download Manager ActiveX control plugin before 2.1.0.10 on Internet Explorer. A vulnerability in these Cisco WebEx browser extensions could allow an unauthenticated, remote attacker to execute arbitrary code with the privileges of the affected browser on an affected system. This vulnerability affects the browser extensions for Cisco WebEx Meetings Server and Cisco WebEx Centers (Meeting Center, Event Center, Training Center, and Support Center) when they are running on Microsoft Windows. The vulnerability is a design defect in an application programing interface (API) response parser within the extension. An attacker that can convince an affected user to visit an attacker-controlled web page or follow an attacker-supplied link with an affected browser could exploit the vulnerability. If successful, the attacker could execute arbitrary code with the privileges of the affected browser.
31 CVE-2017-2996 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-15
10.0
None Remote Low Not required Complete Complete Complete
Adobe Flash Player versions 24.0.0.194 and earlier have an exploitable memory corruption vulnerability in Primetime SDK. Successful exploitation could lead to arbitrary code execution.
32 CVE-2017-2992 119 Exec Code Overflow 2017-02-15 2017-02-15
10.0
None Remote Low Not required Complete Complete Complete
Adobe Flash Player versions 24.0.0.194 and earlier have an exploitable heap overflow vulnerability when parsing an MP4 header. Successful exploitation could lead to arbitrary code execution.
33 CVE-2017-2991 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-15
10.0
None Remote Low Not required Complete Complete Complete
Adobe Flash Player versions 24.0.0.194 and earlier have an exploitable memory corruption vulnerability in the h264 codec (related to decompression). Successful exploitation could lead to arbitrary code execution.
34 CVE-2017-2990 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-15
10.0
None Remote Low Not required Complete Complete Complete
Adobe Flash Player versions 24.0.0.194 and earlier have an exploitable memory corruption vulnerability in the h264 decompression routine. Successful exploitation could lead to arbitrary code execution.
35 CVE-2017-2988 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-15
10.0
None Remote Low Not required Complete Complete Complete
Adobe Flash Player versions 24.0.0.194 and earlier have an exploitable memory corruption vulnerability when performing garbage collection. Successful exploitation could lead to arbitrary code execution.
36 CVE-2017-2986 119 Exec Code Overflow 2017-02-15 2017-02-15
10.0
None Remote Low Not required Complete Complete Complete
Adobe Flash Player versions 24.0.0.194 and earlier have an exploitable heap overflow vulnerability in the Flash Video (FLV) codec. Successful exploitation could lead to arbitrary code execution.
37 CVE-2017-2984 119 Exec Code Overflow 2017-02-15 2017-02-15
10.0
None Remote Low Not required Complete Complete Complete
Adobe Flash Player versions 24.0.0.194 and earlier have an exploitable heap overflow vulnerability in the h264 decoder routine. Successful exploitation could lead to arbitrary code execution.
38 CVE-2017-2981 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-16
5.0
None Remote Low Not required None None Partial
Adobe Digital Editions versions 4.5.3 and earlier have an exploitable memory corruption vulnerability. Successful exploitation could lead to arbitrary code execution.
39 CVE-2017-2980 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-16
5.0
None Remote Low Not required None None Partial
Adobe Digital Editions versions 4.5.3 and earlier have an exploitable memory corruption vulnerability. Successful exploitation could lead to arbitrary code execution.
40 CVE-2017-2979 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-16
5.0
None Remote Low Not required None None Partial
Adobe Digital Editions versions 4.5.3 and earlier have an exploitable memory corruption vulnerability. Successful exploitation could lead to arbitrary code execution.
41 CVE-2017-2978 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-16
5.0
None Remote Low Not required None None Partial
Adobe Digital Editions versions 4.5.3 and earlier have an exploitable memory corruption vulnerability. Successful exploitation could lead to arbitrary code execution.
42 CVE-2017-2977 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-16
5.0
None Remote Low Not required None None Partial
Adobe Digital Editions versions 4.5.3 and earlier have an exploitable memory corruption vulnerability. Successful exploitation could lead to arbitrary code execution.
43 CVE-2017-2976 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-16
5.0
None Remote Low Not required None None Partial
Adobe Digital Editions versions 4.5.3 and earlier have an exploitable memory corruption vulnerability. Successful exploitation could lead to arbitrary code execution.
44 CVE-2017-2975 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-16
5.0
None Remote Low Not required None None Partial
Adobe Digital Editions versions 4.5.3 and earlier have an exploitable memory corruption vulnerability. Successful exploitation could lead to arbitrary code execution.
45 CVE-2017-2974 119 Exec Code Overflow Mem. Corr. 2017-02-15 2017-02-16
5.0
None Remote Low Not required None None Partial
Adobe Digital Editions versions 4.5.3 and earlier have an exploitable memory corruption vulnerability. Successful exploitation could lead to arbitrary code execution.
46 CVE-2017-2973 119 Exec Code Overflow 2017-02-15 2017-02-16
10.0
None Remote Low Not required Complete Complete Complete
Adobe Digital Editions versions 4.5.3 and earlier have an exploitable heap overflow vulnerability. Successful exploitation could lead to arbitrary code execution.
47 CVE-2017-2972 119 Exec Code Overflow Mem. Corr. 2017-01-24 2017-01-27
9.3
None Remote Medium Not required Complete Complete Complete
Adobe Acrobat Reader versions 15.020.20042 and earlier, 15.006.30244 and earlier, 11.0.18 and earlier have an exploitable memory corruption vulnerability in the image conversion module related to JPEG parsing. Successful exploitation could lead to arbitrary code execution.
48 CVE-2017-2971 119 Exec Code Overflow 2017-01-24 2017-01-27
9.3
None Remote Medium Not required Complete Complete Complete
Adobe Acrobat Reader versions 15.020.20042 and earlier, 15.006.30244 and earlier, 11.0.18 and earlier have an exploitable heap overflow vulnerability in the JPEG decoder routine. Successful exploitation could lead to arbitrary code execution.
49 CVE-2017-2970 119 Exec Code Overflow 2017-01-24 2017-01-26
9.3
None Remote Medium Not required Complete Complete Complete
Adobe Acrobat Reader versions 15.020.20042 and earlier, 15.006.30244 and earlier, 11.0.18 and earlier have an exploitable heap overflow vulnerability in the XSLT engine related to template manipulation. Successful exploitation could lead to arbitrary code execution.
50 CVE-2017-2967 119 Exec Code Overflow Mem. Corr. 2017-01-10 2017-01-17
9.3
None Remote Medium Not required Complete Complete Complete
Adobe Acrobat Reader versions 15.020.20042 and earlier, 15.006.30244 and earlier, 11.0.18 and earlier have an exploitable memory corruption vulnerability in the XFA engine related to a form's structure and organization. Successful exploitation could lead to arbitrary code execution.
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.