CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2014-1879

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.
Publish Date : 2014-02-20 Last Update Date : 2014-07-18
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
3.5
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Cross Site Scripting
CWE ID 79

- Related OVAL Definitions

Title Definition Id Class Family
DSA-2975-1 -- phpmyadmin - security update oval:org.mitre.oval:def:24956 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2014-1879

# Product Type Vendor Product Version Update Edition Language
1 Application Phpmyadmin Phpmyadmin 1.0.0 Version Details Vulnerabilities
2 Application Phpmyadmin Phpmyadmin 1.0.1 Version Details Vulnerabilities
3 Application Phpmyadmin Phpmyadmin 1.0.2 Version Details Vulnerabilities
4 Application Phpmyadmin Phpmyadmin 1.0.3 Version Details Vulnerabilities
5 Application Phpmyadmin Phpmyadmin 1.0.4 Version Details Vulnerabilities
6 Application Phpmyadmin Phpmyadmin 1.0.5 Version Details Vulnerabilities
7 Application Phpmyadmin Phpmyadmin 1.0.6 Version Details Vulnerabilities
8 Application Phpmyadmin Phpmyadmin 1.0.6 A Version Details Vulnerabilities
9 Application Phpmyadmin Phpmyadmin 1.0.7 Version Details Vulnerabilities
10 Application Phpmyadmin Phpmyadmin 1.0.8 Version Details Vulnerabilities
11 Application Phpmyadmin Phpmyadmin 1.1 Version Details Vulnerabilities
12 Application Phpmyadmin Phpmyadmin 1.2 Version Details Vulnerabilities
13 Application Phpmyadmin Phpmyadmin 1.2.1 Version Details Vulnerabilities
14 Application Phpmyadmin Phpmyadmin 1.2.2 Version Details Vulnerabilities
15 Application Phpmyadmin Phpmyadmin 1.2.3 Version Details Vulnerabilities
16 Application Phpmyadmin Phpmyadmin 1.2.4 Version Details Vulnerabilities
17 Application Phpmyadmin Phpmyadmin 1.2.5 Version Details Vulnerabilities
18 Application Phpmyadmin Phpmyadmin 1.2.6 Version Details Vulnerabilities
19 Application Phpmyadmin Phpmyadmin 1.2.7 Version Details Vulnerabilities
20 Application Phpmyadmin Phpmyadmin 1.2.8 Version Details Vulnerabilities
21 Application Phpmyadmin Phpmyadmin 1.2.9 Version Details Vulnerabilities
22 Application Phpmyadmin Phpmyadmin 1.2.9.1 Version Details Vulnerabilities
23 Application Phpmyadmin Phpmyadmin 1.2.9.2 Version Details Vulnerabilities
24 Application Phpmyadmin Phpmyadmin 1.2.9.3 Version Details Vulnerabilities
25 Application Phpmyadmin Phpmyadmin 1.2.9.4 C Version Details Vulnerabilities
26 Application Phpmyadmin Phpmyadmin 1.2.9.4 B Version Details Vulnerabilities
27 Application Phpmyadmin Phpmyadmin 1.2.9.5 Version Details Vulnerabilities
28 Application Phpmyadmin Phpmyadmin 1.3 Version Details Vulnerabilities
29 Application Phpmyadmin Phpmyadmin 1.3 Alpha Version Details Vulnerabilities
30 Application Phpmyadmin Phpmyadmin 2.11.0 Version Details Vulnerabilities
31 Application Phpmyadmin Phpmyadmin 2.11.1.0 Version Details Vulnerabilities
32 Application Phpmyadmin Phpmyadmin 2.11.1.1 Version Details Vulnerabilities
33 Application Phpmyadmin Phpmyadmin 2.11.1.2 Version Details Vulnerabilities
34 Application Phpmyadmin Phpmyadmin 2.11.2.0 Version Details Vulnerabilities
35 Application Phpmyadmin Phpmyadmin 2.11.2.1 Version Details Vulnerabilities
36 Application Phpmyadmin Phpmyadmin 2.11.2.2 Version Details Vulnerabilities
37 Application Phpmyadmin Phpmyadmin 2.11.3.0 Version Details Vulnerabilities
38 Application Phpmyadmin Phpmyadmin 2.11.4.0 Version Details Vulnerabilities
39 Application Phpmyadmin Phpmyadmin 2.11.5.0 Version Details Vulnerabilities
40 Application Phpmyadmin Phpmyadmin 2.11.5.1 Version Details Vulnerabilities
41 Application Phpmyadmin Phpmyadmin 2.11.5.2 Version Details Vulnerabilities
42 Application Phpmyadmin Phpmyadmin 2.11.6.0 Version Details Vulnerabilities
43 Application Phpmyadmin Phpmyadmin 2.11.7.0 Version Details Vulnerabilities
44 Application Phpmyadmin Phpmyadmin 2.11.7.1 Version Details Vulnerabilities
45 Application Phpmyadmin Phpmyadmin 2.11.8.0 Version Details Vulnerabilities
46 Application Phpmyadmin Phpmyadmin 2.11.9.0 Version Details Vulnerabilities
47 Application Phpmyadmin Phpmyadmin 2.11.9.1 Version Details Vulnerabilities
48 Application Phpmyadmin Phpmyadmin 2.11.9.2 Version Details Vulnerabilities
49 Application Phpmyadmin Phpmyadmin 2.11.9.3 Version Details Vulnerabilities
50 Application Phpmyadmin Phpmyadmin 2.11.9.4 Version Details Vulnerabilities
51 Application Phpmyadmin Phpmyadmin 2.11.9.5 Version Details Vulnerabilities
52 Application Phpmyadmin Phpmyadmin 2.11.9.6 Version Details Vulnerabilities
53 Application Phpmyadmin Phpmyadmin 2.11.10.0 Version Details Vulnerabilities
54 Application Phpmyadmin Phpmyadmin 2.11.10.1 Version Details Vulnerabilities
55 Application Phpmyadmin Phpmyadmin 3.0.0 RC1 Version Details Vulnerabilities
56 Application Phpmyadmin Phpmyadmin 3.0.0 Version Details Vulnerabilities
57 Application Phpmyadmin Phpmyadmin 3.0.0 Alpha Version Details Vulnerabilities
58 Application Phpmyadmin Phpmyadmin 3.0.0 Beta Version Details Vulnerabilities
59 Application Phpmyadmin Phpmyadmin 3.0.1 Version Details Vulnerabilities
60 Application Phpmyadmin Phpmyadmin 3.0.1 RC1 Version Details Vulnerabilities
61 Application Phpmyadmin Phpmyadmin 3.0.1.1 Version Details Vulnerabilities
62 Application Phpmyadmin Phpmyadmin 3.1.0 Version Details Vulnerabilities
63 Application Phpmyadmin Phpmyadmin 3.1.0 Beta1 Version Details Vulnerabilities
64 Application Phpmyadmin Phpmyadmin 3.1.1 Version Details Vulnerabilities
65 Application Phpmyadmin Phpmyadmin 3.1.1 RC1 Version Details Vulnerabilities
66 Application Phpmyadmin Phpmyadmin 3.1.2 Version Details Vulnerabilities
67 Application Phpmyadmin Phpmyadmin 3.1.2 RC1 Version Details Vulnerabilities
68 Application Phpmyadmin Phpmyadmin 3.1.3 RC1 Version Details Vulnerabilities
69 Application Phpmyadmin Phpmyadmin 3.1.3 Version Details Vulnerabilities
70 Application Phpmyadmin Phpmyadmin 3.1.3.1 Version Details Vulnerabilities
71 Application Phpmyadmin Phpmyadmin 3.1.3.2 Version Details Vulnerabilities
72 Application Phpmyadmin Phpmyadmin 3.1.4 Version Details Vulnerabilities
73 Application Phpmyadmin Phpmyadmin 3.1.4 RC2 Version Details Vulnerabilities
74 Application Phpmyadmin Phpmyadmin 3.1.5 Version Details Vulnerabilities
75 Application Phpmyadmin Phpmyadmin 3.1.5 RC1 Version Details Vulnerabilities
76 Application Phpmyadmin Phpmyadmin 3.2.0 Version Details Vulnerabilities
77 Application Phpmyadmin Phpmyadmin 3.2.0 Beta1 Version Details Vulnerabilities
78 Application Phpmyadmin Phpmyadmin 3.2.0 RC1 Version Details Vulnerabilities
79 Application Phpmyadmin Phpmyadmin 3.2.1 RC1 Version Details Vulnerabilities
80 Application Phpmyadmin Phpmyadmin 3.2.1 Version Details Vulnerabilities
81 Application Phpmyadmin Phpmyadmin 3.2.2 Version Details Vulnerabilities
82 Application Phpmyadmin Phpmyadmin 3.2.2 RC1 Version Details Vulnerabilities
83 Application Phpmyadmin Phpmyadmin 3.3.0.0 Version Details Vulnerabilities
84 Application Phpmyadmin Phpmyadmin 3.3.1.0 Version Details Vulnerabilities
85 Application Phpmyadmin Phpmyadmin 3.3.2.0 Version Details Vulnerabilities
86 Application Phpmyadmin Phpmyadmin 3.3.3.0 Version Details Vulnerabilities
87 Application Phpmyadmin Phpmyadmin 3.3.4.0 Version Details Vulnerabilities
88 Application Phpmyadmin Phpmyadmin 3.3.5.0 Version Details Vulnerabilities
89 Application Phpmyadmin Phpmyadmin 3.3.5.1 Version Details Vulnerabilities
90 Application Phpmyadmin Phpmyadmin 3.3.6 Version Details Vulnerabilities
91 Application Phpmyadmin Phpmyadmin 3.3.7 Version Details Vulnerabilities
92 Application Phpmyadmin Phpmyadmin 3.3.8 Version Details Vulnerabilities
93 Application Phpmyadmin Phpmyadmin 3.3.8.1 Version Details Vulnerabilities
94 Application Phpmyadmin Phpmyadmin 3.3.9.0 Version Details Vulnerabilities
95 Application Phpmyadmin Phpmyadmin 3.3.9.1 Version Details Vulnerabilities
96 Application Phpmyadmin Phpmyadmin 3.3.9.2 Version Details Vulnerabilities
97 Application Phpmyadmin Phpmyadmin 3.3.10.0 Version Details Vulnerabilities
98 Application Phpmyadmin Phpmyadmin 3.4.0.0 Version Details Vulnerabilities
99 Application Phpmyadmin Phpmyadmin 3.4.1.0 Version Details Vulnerabilities
100 Application Phpmyadmin Phpmyadmin 3.4.2.0 Version Details Vulnerabilities
101 Application Phpmyadmin Phpmyadmin 3.4.3.0 Version Details Vulnerabilities
102 Application Phpmyadmin Phpmyadmin 3.4.3.1 Version Details Vulnerabilities
103 Application Phpmyadmin Phpmyadmin 3.4.3.2 Version Details Vulnerabilities
104 Application Phpmyadmin Phpmyadmin 3.4.4.0 Version Details Vulnerabilities
105 Application Phpmyadmin Phpmyadmin 3.4.5.0 Version Details Vulnerabilities
106 Application Phpmyadmin Phpmyadmin 3.4.6.0 Version Details Vulnerabilities
107 Application Phpmyadmin Phpmyadmin 3.4.7.0 Version Details Vulnerabilities
108 Application Phpmyadmin Phpmyadmin 3.4.7.1 Version Details Vulnerabilities
109 Application Phpmyadmin Phpmyadmin 3.4.8.0 Version Details Vulnerabilities
110 Application Phpmyadmin Phpmyadmin 3.4.9.0 Version Details Vulnerabilities
111 Application Phpmyadmin Phpmyadmin 3.4.10.0 Version Details Vulnerabilities
112 Application Phpmyadmin Phpmyadmin 3.4.10.1 Version Details Vulnerabilities
113 Application Phpmyadmin Phpmyadmin 3.4.10.2 Version Details Vulnerabilities
114 Application Phpmyadmin Phpmyadmin 3.4.11 Version Details Vulnerabilities
115 Application Phpmyadmin Phpmyadmin 3.5.0.0 Version Details Vulnerabilities
116 Application Phpmyadmin Phpmyadmin 3.5.1.0 Version Details Vulnerabilities
117 Application Phpmyadmin Phpmyadmin 3.5.2.0 Version Details Vulnerabilities
118 Application Phpmyadmin Phpmyadmin 3.5.2.1 Version Details Vulnerabilities
119 Application Phpmyadmin Phpmyadmin 3.5.2.2 Version Details Vulnerabilities
120 Application Phpmyadmin Phpmyadmin 3.5.3.0 Version Details Vulnerabilities
121 Application Phpmyadmin Phpmyadmin 3.5.4 Version Details Vulnerabilities
122 Application Phpmyadmin Phpmyadmin 3.5.5 Version Details Vulnerabilities
123 Application Phpmyadmin Phpmyadmin 3.5.6 Version Details Vulnerabilities
124 Application Phpmyadmin Phpmyadmin 3.5.7 Version Details Vulnerabilities
125 Application Phpmyadmin Phpmyadmin 3.5.7 RC1 Version Details Vulnerabilities
126 Application Phpmyadmin Phpmyadmin 3.5.8 Version Details Vulnerabilities
127 Application Phpmyadmin Phpmyadmin 3.5.8 RC1 Version Details Vulnerabilities
128 Application Phpmyadmin Phpmyadmin 3.5.8.1 Version Details Vulnerabilities
129 Application Phpmyadmin Phpmyadmin 3.5.8.2 Version Details Vulnerabilities
130 Application Phpmyadmin Phpmyadmin 4.0.0 Version Details Vulnerabilities
131 Application Phpmyadmin Phpmyadmin 4.0.0 RC2 Version Details Vulnerabilities
132 Application Phpmyadmin Phpmyadmin 4.0.0 RC3 Version Details Vulnerabilities
133 Application Phpmyadmin Phpmyadmin 4.0.1 Version Details Vulnerabilities
134 Application Phpmyadmin Phpmyadmin 4.0.2 Version Details Vulnerabilities
135 Application Phpmyadmin Phpmyadmin 4.0.3 Version Details Vulnerabilities
136 Application Phpmyadmin Phpmyadmin 4.0.4 Version Details Vulnerabilities
137 Application Phpmyadmin Phpmyadmin 4.0.4.1 Version Details Vulnerabilities
138 Application Phpmyadmin Phpmyadmin 4.0.4.2 Version Details Vulnerabilities
139 Application Phpmyadmin Phpmyadmin 4.0.5 Version Details Vulnerabilities
140 Application Phpmyadmin Phpmyadmin 4.0.6 Version Details Vulnerabilities
141 Application Phpmyadmin Phpmyadmin 4.0.7 Version Details Vulnerabilities
142 Application Phpmyadmin Phpmyadmin 4.0.8 Version Details Vulnerabilities
143 Application Phpmyadmin Phpmyadmin 4.0.9 Version Details Vulnerabilities
144 Application Phpmyadmin Phpmyadmin 4.1.0 Version Details Vulnerabilities
145 Application Phpmyadmin Phpmyadmin 4.1.1 Version Details Vulnerabilities
146 Application Phpmyadmin Phpmyadmin 4.1.2 Version Details Vulnerabilities
147 Application Phpmyadmin Phpmyadmin 4.1.3 Version Details Vulnerabilities
148 Application Phpmyadmin Phpmyadmin 4.1.4 Version Details Vulnerabilities
149 Application Phpmyadmin Phpmyadmin 4.1.5 Version Details Vulnerabilities
150 Application Phpmyadmin Phpmyadmin 4.1.6 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Phpmyadmin Phpmyadmin 150

- References For CVE-2014-1879

http://secunia.com/advisories/59832
SECUNIA 59832
http://lists.opensuse.org/opensuse-updates/2014-03/msg00017.html
SUSE openSUSE-SU-2014:0344
https://github.com/phpmyadmin/phpmyadmin/commit/968d5d5f486820bfa30af046f063b9f23304e14a CONFIRM
http://www.phpmyadmin.net/home_page/security/PMASA-2014-1.php CONFIRM

- Metasploit Modules Related To CVE-2014-1879

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.