CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2013-7341

Multiple cross-site scripting (XSS) vulnerabilities in Flowplayer Flash before 3.2.17, as used in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2, allow remote attackers to inject arbitrary web script or HTML by (1) providing a crafted playerId or (2) referencing an external domain, a related issue to CVE-2013-7342.
Publish Date : 2014-03-24 Last Update Date : 2014-03-24
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Cross Site Scripting
CWE ID 79

- Products Affected By CVE-2013-7341

# Product Type Vendor Product Version Update Edition Language
1 Application Flowplayer Flowplayer Flash 3.0.0 Version Details Vulnerabilities
2 Application Flowplayer Flowplayer Flash 3.0.1 Version Details Vulnerabilities
3 Application Flowplayer Flowplayer Flash 3.0.2 Version Details Vulnerabilities
4 Application Flowplayer Flowplayer Flash 3.0.3 Version Details Vulnerabilities
5 Application Flowplayer Flowplayer Flash 3.0.4 Version Details Vulnerabilities
6 Application Flowplayer Flowplayer Flash 3.0.5 Version Details Vulnerabilities
7 Application Flowplayer Flowplayer Flash 3.0.6 Version Details Vulnerabilities
8 Application Flowplayer Flowplayer Flash 3.1.0 Version Details Vulnerabilities
9 Application Flowplayer Flowplayer Flash 3.1.1 Version Details Vulnerabilities
10 Application Flowplayer Flowplayer Flash 3.1.2 Version Details Vulnerabilities
11 Application Flowplayer Flowplayer Flash 3.1.3 Version Details Vulnerabilities
12 Application Flowplayer Flowplayer Flash 3.1.4 Version Details Vulnerabilities
13 Application Flowplayer Flowplayer Flash 3.1.5 Version Details Vulnerabilities
14 Application Flowplayer Flowplayer Flash 3.2.0 Version Details Vulnerabilities
15 Application Flowplayer Flowplayer Flash 3.2.1 Version Details Vulnerabilities
16 Application Flowplayer Flowplayer Flash 3.2.2 Version Details Vulnerabilities
17 Application Flowplayer Flowplayer Flash 3.2.3 Version Details Vulnerabilities
18 Application Flowplayer Flowplayer Flash 3.2.4 Version Details Vulnerabilities
19 Application Flowplayer Flowplayer Flash 3.2.5 Version Details Vulnerabilities
20 Application Flowplayer Flowplayer Flash 3.2.6 Version Details Vulnerabilities
21 Application Flowplayer Flowplayer Flash 3.2.7 Version Details Vulnerabilities
22 Application Flowplayer Flowplayer Flash 3.2.8 Version Details Vulnerabilities
23 Application Flowplayer Flowplayer Flash 3.2.9 Version Details Vulnerabilities
24 Application Flowplayer Flowplayer Flash 3.2.10 Version Details Vulnerabilities
25 Application Flowplayer Flowplayer Flash 3.2.11 Version Details Vulnerabilities
26 Application Flowplayer Flowplayer Flash 3.2.12 Version Details Vulnerabilities
27 Application Flowplayer Flowplayer Flash 3.2.13 Version Details Vulnerabilities
28 Application Flowplayer Flowplayer Flash 3.2.14 Version Details Vulnerabilities
29 Application Flowplayer Flowplayer Flash 3.2.15 Version Details Vulnerabilities
30 Application Flowplayer Flowplayer Flash 3.2.16 Version Details Vulnerabilities
31 Application Moodle Moodle 2.0 Version Details Vulnerabilities
32 Application Moodle Moodle 2.0.1 Version Details Vulnerabilities
33 Application Moodle Moodle 2.0.2 Version Details Vulnerabilities
34 Application Moodle Moodle 2.0.3 Version Details Vulnerabilities
35 Application Moodle Moodle 2.0.4 Version Details Vulnerabilities
36 Application Moodle Moodle 2.0.5 Version Details Vulnerabilities
37 Application Moodle Moodle 2.0.6 Version Details Vulnerabilities
38 Application Moodle Moodle 2.0.7 Version Details Vulnerabilities
39 Application Moodle Moodle 2.0.8 Version Details Vulnerabilities
40 Application Moodle Moodle 2.0.9 Version Details Vulnerabilities
41 Application Moodle Moodle 2.1 Version Details Vulnerabilities
42 Application Moodle Moodle 2.1.1 Version Details Vulnerabilities
43 Application Moodle Moodle 2.1.2 Version Details Vulnerabilities
44 Application Moodle Moodle 2.1.3 Version Details Vulnerabilities
45 Application Moodle Moodle 2.1.4 Version Details Vulnerabilities
46 Application Moodle Moodle 2.1.5 Version Details Vulnerabilities
47 Application Moodle Moodle 2.1.6 Version Details Vulnerabilities
48 Application Moodle Moodle 2.1.7 Version Details Vulnerabilities
49 Application Moodle Moodle 2.1.8 Version Details Vulnerabilities
50 Application Moodle Moodle 2.1.9 Version Details Vulnerabilities
51 Application Moodle Moodle 2.1.10 Version Details Vulnerabilities
52 Application Moodle Moodle 2.2 Version Details Vulnerabilities
53 Application Moodle Moodle 2.2.1 Version Details Vulnerabilities
54 Application Moodle Moodle 2.2.2 Version Details Vulnerabilities
55 Application Moodle Moodle 2.2.3 Version Details Vulnerabilities
56 Application Moodle Moodle 2.2.4 Version Details Vulnerabilities
57 Application Moodle Moodle 2.2.5 Version Details Vulnerabilities
58 Application Moodle Moodle 2.2.6 Version Details Vulnerabilities
59 Application Moodle Moodle 2.2.7 Version Details Vulnerabilities
60 Application Moodle Moodle 2.2.8 Version Details Vulnerabilities
61 Application Moodle Moodle 2.2.9 Version Details Vulnerabilities
62 Application Moodle Moodle 2.2.10 Version Details Vulnerabilities
63 Application Moodle Moodle 2.2.11 Version Details Vulnerabilities
64 Application Moodle Moodle 2.3 Version Details Vulnerabilities
65 Application Moodle Moodle 2.3.1 Version Details Vulnerabilities
66 Application Moodle Moodle 2.3.2 Version Details Vulnerabilities
67 Application Moodle Moodle 2.3.3 Version Details Vulnerabilities
68 Application Moodle Moodle 2.3.4 Version Details Vulnerabilities
69 Application Moodle Moodle 2.3.5 Version Details Vulnerabilities
70 Application Moodle Moodle 2.3.6 Version Details Vulnerabilities
71 Application Moodle Moodle 2.3.7 Version Details Vulnerabilities
72 Application Moodle Moodle 2.3.8 Version Details Vulnerabilities
73 Application Moodle Moodle 2.3.9 Version Details Vulnerabilities
74 Application Moodle Moodle 2.3.10 Version Details Vulnerabilities
75 Application Moodle Moodle 2.3.11 Version Details Vulnerabilities
76 Application Moodle Moodle 2.4 Version Details Vulnerabilities
77 Application Moodle Moodle 2.4.1 Version Details Vulnerabilities
78 Application Moodle Moodle 2.4.2 Version Details Vulnerabilities
79 Application Moodle Moodle 2.4.3 Version Details Vulnerabilities
80 Application Moodle Moodle 2.4.4 Version Details Vulnerabilities
81 Application Moodle Moodle 2.4.5 Version Details Vulnerabilities
82 Application Moodle Moodle 2.4.6 Version Details Vulnerabilities
83 Application Moodle Moodle 2.4.7 Version Details Vulnerabilities
84 Application Moodle Moodle 2.4.8 Version Details Vulnerabilities
85 Application Moodle Moodle 2.5 Version Details Vulnerabilities
86 Application Moodle Moodle 2.5.1 Version Details Vulnerabilities
87 Application Moodle Moodle 2.5.2 Version Details Vulnerabilities
88 Application Moodle Moodle 2.5.3 Version Details Vulnerabilities
89 Application Moodle Moodle 2.5.4 Version Details Vulnerabilities
90 Application Moodle Moodle 2.6 Version Details Vulnerabilities
91 Application Moodle Moodle 2.6.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Flowplayer Flowplayer Flash 30
Moodle Moodle 61

- References For CVE-2013-7341

http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-43344 CONFIRM
http://flash.flowplayer.org/documentation/version-history.html CONFIRM
https://moodle.org/mod/forum/discuss.php?d=256420 CONFIRM
http://openwall.com/lists/oss-security/2014/03/17/1
MLIST [oss-security] 20140317 Moodle security notifications public
https://github.com/flowplayer/flash/issues/121 CONFIRM

- Metasploit Modules Related To CVE-2013-7341

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.